Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 5 von 5

Thema: VKE bleibt 0 - Seltsames Problem

  1. #1
    Registriert seit
    03.09.2007
    Ort
    Saarland
    Beiträge
    79
    Danke
    4
    Erhielt 7 Danke für 7 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo, wer kann helfen?

    In meinem Programm wird ein FC aus einem FC aufgerufen.

    Code:
        
    Netzwerk 8
          U     M    140.0      FP    M    140.2
          L     "DB_FU_Allgemein".Referenz_X.FU_Inkremente
          DTR   
          L     1.200000e+002
          /R    
          T     "DB_FU_Allgemein".Referenz_X.Ref_mm
    
    
    Netzwerk 9
          U     M     40.0
          =     L     17.0
          BLD   103
          CALL  FC    23
           Eingang:=L17.0
           Ausgang:=M40.1
          NOP   0
    Funktioniert nicht. = L17.0 wird nicht "1" wenn M40.0 = "1" ist.


    Code:
        
    Netzwerk 8
          U     M    140.0      
          FP    M    140.2
          L     "DB_FU_Allgemein".Referenz_X.FU_Inkremente
          DTR   
          L     1.200000e+002
          /R    
          T     "DB_FU_Allgemein".Referenz_X.Ref_mm
    
          CLR
    
    
    Netzwerk 9
          U     M     40.0
          =     L     17.0
          BLD   103
          CALL  FC    23
           Eingang:=L17.0
           Ausgang:=M40.1
          NOP   0

    Funktioniert... Warum?

    Ich bin etwas ratlos.
    Zitieren Zitieren VKE bleibt 0 - Seltsames Problem  

  2. #2
    Registriert seit
    19.06.2008
    Ort
    Ostalbkreis
    Beiträge
    3.140
    Danke
    201
    Erhielt 553 Danke für 498 Beiträge

    Standard

    Hallo
    Code:
    Netzwerk 8
          U     M    140.0      
          FP    M    140.2
          L     "DB_FU_Allgemein".Referenz_X.FU_Inkremente   <---- wird unabhängig vom VKE ausgeführt
          DTR   
          L     1.200000e+002
          /R    
          T     "DB_FU_Allgemein".Referenz_X.Ref_mm
    
        
    Netzwerk 9
    
          CALL  FC    23
           Eingang:=  M     40.0
           Ausgang:=M40.1
          NOP   0
    vielleicht so...

  3. Folgender Benutzer sagt Danke zu Verpolt für den nützlichen Beitrag:

    Hardy81 (25.02.2015)

  4. #3
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.732
    Danke
    314
    Erhielt 1.520 Danke für 1.282 Beiträge

    Standard

    Weil das:
    U M 140.0
    FP M 140.2
    im vermuteten Kontext absolut sinnfrei ist, da L/T etc. absolut VKE-unabhängig agieren
    und du ob dieses Effektes keine abgeschlossene Verknüpfung hast (/ER Bit) und die Verknüpfung dann mit U M40.0 weitergeführt wird.
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  5. Folgender Benutzer sagt Danke zu MSB für den nützlichen Beitrag:

    Hardy81 (25.02.2015)

  6. #4
    Registriert seit
    22.11.2006
    Ort
    CH
    Beiträge
    3.618
    Danke
    776
    Erhielt 646 Danke für 492 Beiträge

    Standard

    Weil die Verknüpfung von U M140.0 und FP 140.2 noch offen ist.
    den Code zwischen FP im Netzwerk 8 und dem U im Netzwerk 9 startet keine neue Verknüpfung.

    mfG René

  7. Folgender Benutzer sagt Danke zu vollmi für den nützlichen Beitrag:

    Hardy81 (25.02.2015)

  8. #5
    Registriert seit
    03.09.2007
    Ort
    Saarland
    Beiträge
    79
    Danke
    4
    Erhielt 7 Danke für 7 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ok, Fehler erkannt.

    Flankenauswertung mit Sprung macht dann wohl mehr Sinn...


    Vielen Dank!

Ähnliche Themen

  1. S5 135/155 mit Intouch - Seltsames Problem
    Von mpexx im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 09.08.2011, 17:37
  2. Seltsames Problem mit Festo Ventilinsel
    Von Rodewijn im Forum Feldbusse
    Antworten: 5
    Letzter Beitrag: 13.07.2008, 16:20
  3. VKE Problem
    Von rene im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 10.07.2007, 21:03
  4. Seltsames Problem -> Wechselspannung auf Digitalausgangskarte ?
    Von Betriebselektriker28 im Forum Simatic
    Antworten: 11
    Letzter Beitrag: 13.09.2006, 20:01
  5. Seltsames
    Von drfunfrock im Forum Stammtisch
    Antworten: 2
    Letzter Beitrag: 02.03.2005, 08:56

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •