Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 3 ErsteErste 123 LetzteLetzte
Ergebnis 11 bis 20 von 24

Thema: Plötzlicher Stillstand der CPU

  1. #11
    Registriert seit
    20.12.2006
    Beiträge
    275
    Danke
    20
    Erhielt 29 Danke für 27 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hast du denn die neuste Firmware schon aufgespielt. Müsste 3.3.11 sein. Diese CPU hatte einige Probleme mit dem schreib-lesezugriff CPU --MMC.
    Meier Meinung wird das mit dem Update erledigt sein.
    MFG
    Bitverbieger

    Gelingt Dir etwas auf Anhieb, so lass Dir Deine Verblüffung nicht anmerken.

  2. #12
    Registriert seit
    03.04.2008
    Beiträge
    6.200
    Danke
    237
    Erhielt 815 Danke für 689 Beiträge

    Standard

    Wenn du fragst was unlinked ist, dann habt ihr es vermutlich nicht.
    Ein Firmwareupdate ist vielleicht eine Lösung.
    Wenn ihr andere Anlagen mit der selben Ausstattung habt, welche CPU mit welchen Firmwareständen werden dort eingesetzt?
    Denn wenn du die Möglichkeit zu vergleichen, würde ich zuerst schauen was ist anders bzw ist alles gleich.

    Wenn du an die CPU rankommst, dann würde ich mir den Speicher anschauen, so mit vergleich und Auslastung.


    bike
    "Any fool can write code that a computer can understand.
    Good programmers write code that humans can understand."
    --Martin Fowler

  3. #13
    SPS_NEU ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    02.03.2009
    Beiträge
    301
    Danke
    3
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Kann man auf eine CPU mit der Version V3.0 (auf die CPU aufgedruckt) die V3.3 aufspielen? Ich bin immer davon ausgegangen, dass die Versionsnummer zur CPU passen muss.
    Die CPU wurde durch eine ganz neue ersetzt. Das ist erstmal erledigt. Ich müsste jetzt aber sozusagen rausbekommen, wo der Fehler lag. Wie könnte ich diesen Zusatnd versuchen nach zu stellen?

    Die gleiche CPU wurde auch in sämtlichen anderen Anlagen (Baugleich) bei uns verbaut. Auch das Kaufdatum ist das gleiche.

  4. #14
    Registriert seit
    03.04.2008
    Beiträge
    6.200
    Danke
    237
    Erhielt 815 Danke für 689 Beiträge

    Standard

    Dann kommt der Fehler nicht von der Firmware, wenn andere Anlagen in der beschriebenen Konfiguration funktionieren.

    Klar, kannst du eine neue Firmware aufspielen. Der Aufdruck besagt nur, welche Version installiert ist.
    Wenn du diese änderst, dann kennzeichne bitte die CPU was du dort gemacht hast.


    bike
    "Any fool can write code that a computer can understand.
    Good programmers write code that humans can understand."
    --Martin Fowler

  5. #15
    Registriert seit
    26.02.2015
    Ort
    Nürnberg
    Beiträge
    6
    Danke
    0
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Zitat Zitat von SPS_NEU Beitrag anzeigen
    Ohne das es einen Zugriff (Beobachtung / Veränderung) gab, blieb die CPU letztens stehen und blinkte mit allen LEDs gleichzeitig.
    Die CPU hat einen fatalen Fehler erkannt und ging sicherheitshalber in den Defekt-Zustand. Das ist das berüchtigte Defekt-Blinken. Auch "der Christbaum" genannt.

    Zitat Zitat von SPS_NEU Beitrag anzeigen
    Kennt jemand disen Fehler oder weiss, wo durch dieser ausgelöst werden kann?
    Diesen speziellen Fehler kenne ich auch nicht. Allgemein gibt es zwei Ursachen:

    1. Wie schon andere Leute schrieben ein Firmware-Fehler. Aktualisieren auf die neueste Firmware-Version könnte das Problem beheben.
    2. Was bisher noch nicht erwähnt wurde: Die CPU könnte auch einen Hardware-Schaden haben, der sporadisch zuschlägt. Wenn eine baugleiche CPU zur Verfügung steht, mal tauschen und schauen ob der Fehler mitwandert.

  6. #16
    Registriert seit
    06.10.2003
    Beiträge
    3.414
    Danke
    451
    Erhielt 506 Danke für 408 Beiträge

    Standard

    Zitat Zitat von SPS_NEU Beitrag anzeigen
    ..Die gleiche CPU wurde auch in sämtlichen anderen Anlagen (Baugleich) bei uns verbaut. Auch das Kaufdatum ist das gleiche.
    Sind es die erwähnten 100 Stück? Wie lange laufen sie schon? Ich würde nach diesem Vorfall unbedingt die neuste Firmware auf alle diese CPUs übertragen.

    Zitat Zitat von bike Beitrag anzeigen
    Dann kommt der Fehler nicht von der Firmware, wenn andere Anlagen in der beschriebenen Konfiguration funktionieren...
    Bike, es gibt bei Siemens "hochsporadische" Dinge die man einfach nicht verstehen muss. Ich hatte auch schon einen ähnlichen Fehler, der erst nach mehreren Monaten irgendwann einmal bei einer einzigen CPU aufgetreten ist.

    Ich hatte hier im Forum berichtet.
    Es gibt viel mehr Leute, die freiwillig aufgeben, als solche, die echt scheitern.
    Henry Ford

  7. #17
    SPS_NEU ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    02.03.2009
    Beiträge
    301
    Danke
    3
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Die ganzen Anlagen laufen jetzt schon 4 Jahre. Ohne dass ich je so einen Fehler hatte. Es wurde jetzt bei der fehlerhaften Anlage eine ganz neue CPU mit der neusten Firmware eingesetzt.
    Das ist alles nicht das Problem. Ich suche nur halt nach der Ursache.

  8. #18
    Registriert seit
    03.04.2008
    Beiträge
    6.200
    Danke
    237
    Erhielt 815 Danke für 689 Beiträge

    Standard

    Zitat Zitat von Onkel Dagobert Beitrag anzeigen
    Bike, es gibt bei Siemens "hochsporadische" Dinge die man einfach nicht verstehen muss. Ich hatte auch schon einen ähnlichen Fehler, der erst nach mehreren Monaten irgendwann einmal bei einer einzigen CPU aufgetreten ist.

    Ich hatte hier im Forum berichtet.
    Onkel, auch dies habe ich gelesen.
    Doch bei der selben Konstellation und Nutzung solch ein Verhalten?
    Und wer übernimmt die Garantie, dass wenn alle CPU hochgerüstet sind, dass nicht ein anderer Fehlerteufel sich einnistet?

    Bei uns wird das GP oder NCK Software nur dann hochgerüstet, wenn es einen zwingenden Grund, also bekannten und reproduzierbaren Fehler, dafür gibt.


    bike
    "Any fool can write code that a computer can understand.
    Good programmers write code that humans can understand."
    --Martin Fowler

  9. #19
    Registriert seit
    06.10.2003
    Beiträge
    3.414
    Danke
    451
    Erhielt 506 Danke für 408 Beiträge

    Standard

    Hallo Bike,

    Zitat Zitat von bike Beitrag anzeigen
    ..Doch bei der selben Konstellation und Nutzung solch ein Verhalten?..
    Ja, genau das war ja mein Gedanke. Dass es ein "hochsporadischer" Fehler war, steht wohl außer Zweifel. Jedenfalls sehe ich das so. Ich hätte Befürchtungen dass derselbe Fehler übermorgen an einer anderen Steuerung ähnlicher Konstellation auftritt.

    Zitat Zitat von bike Beitrag anzeigen
    ..Und wer übernimmt die Garantie, dass wenn alle CPU hochgerüstet sind, dass nicht ein anderer Fehlerteufel sich einnistet?..
    Das kann natürlich niemand garantieren. Wenn ich allerdings einen internen Systemfehler habe der durch ein Firmware-Update behoben werden kann, dann würde ich nicht lange überlegen. Ok, mittels einem Schnellschuß gleich 100 Steuerungen zu verjüngen wäre vielleicht auch nicht so klug. Vielleicht sollte man doch erst einmal etwas abwarten.

    Zitat Zitat von bike Beitrag anzeigen
    ..Bei uns wird das GP oder NCK Software nur dann hochgerüstet, wenn es einen zwingenden Grund, also bekannten und reproduzierbaren Fehler, dafür gibt..
    "Reproduzierbar" wird in so einem Fall für unsereiner sehr schwierig bis nahezu unmöglich. Man sollte sich irgendwo auch mal auf Siemens bzw. auf den Hersteller verlassen (können müssen). Natürlich renne ich auch nicht bei jedem Update los. Never touch a running system, iss ja klar. Man muß es halt irgendwie abwägen. Wenn eine ganze Walzstraße eines Stahlwerkes zum Stillstand kommt und der aufgetretene Fehler durch ein Update beseitigt werden kann, dann tut man es. Man hat eigentlich garkeine andere Wahl. Wenn dadurch ein anderer Fehler entsteht, hat man Pech gehabt. Aber man hat zumindest alles getan, damit der aufgetretene Fehler nicht noch einmal auftritt. Tut man es nicht und derselbe Fehler tritt erneut auf, gibt es hinterher viele schlaue Leute mit dem Spruch "Warum hast du denn nicht.." Das kennen wir doch alle .


    Gruß, Onkel
    Es gibt viel mehr Leute, die freiwillig aufgeben, als solche, die echt scheitern.
    Henry Ford

  10. #20
    SPS_NEU ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    02.03.2009
    Beiträge
    301
    Danke
    3
    Erhielt 2 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    ich greif mal dieses Thema wieder auf. ICh habe jetzt schon wieder den gleichen Effekt bei einer anderen Anlage. Diesmal mit einer 317-2AK14-0ABO V3.3. System läuft seit über 2 Jahren fehlerfrei.
    Die CPUs sitzen jeweils in 3 Busringen (über CP-343 und CP342) und sind damit verbunden. Beide CPUs liefen jetzt lange fehlerfrei und nun innerhalb eines Monats diese Fehlerbilder bei beiden.

    Sonst haben die nichts mit einander gemeinsam.

    Wie hoch ist die Wahrscheinlichkeit eines "Virus"? Kann so etwas sein?

Ähnliche Themen

  1. Bitte Hilfe: Motor baut zu hohes Drehmoment auf im Stillstand
    Von flashgorny im Forum Antriebstechnik
    Antworten: 5
    Letzter Beitrag: 22.01.2014, 20:22
  2. Pendelnde ServoAchse mit Stillstand
    Von Blackdriver im Forum Programmierstrategien
    Antworten: 4
    Letzter Beitrag: 15.04.2012, 11:09
  3. Mechanische Leistung im Stillstand
    Von dizz3l im Forum Antriebstechnik
    Antworten: 8
    Letzter Beitrag: 06.06.2011, 18:53
  4. Plötzlicher Totalausfall
    Von MatMer im Forum Simatic
    Antworten: 11
    Letzter Beitrag: 06.04.2011, 15:12
  5. Geschwindigkeitsreduzierung ohne Stillstand.... (Sinamics S120 CU320)
    Von Housse B @ HAGE im Forum Antriebstechnik
    Antworten: 6
    Letzter Beitrag: 11.11.2008, 20:36

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •