Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 3 123 LetzteLetzte
Ergebnis 1 bis 10 von 24

Thema: Plötzlicher Stillstand der CPU

  1. #1
    Registriert seit
    02.03.2009
    Beiträge
    301
    Danke
    3
    Erhielt 2 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,

    ich habe bei einer S7-300 Anlage eine CPU 315-2AH14-0AB0 verbaut. Diese war zum Einbau vor ca. 1 Jahr neu.
    Die CPU lief durch weg. Ohne das es einen Zugriff (Beobachtung / Veränderung) gab, blieb die CPU letztens stehen und blinkte mit allen LEDs gleichzeitig.

    Laut Diagnose war das der Fehler: Meldung z1: f014

    Siemens meinte, dass dies nur durch gleichzeitiges Beobachten und laden passieren kann. Dem war aber nicht so. Man sollte die Version v3.3 nutzen.

    Fehler_CPU.JPG

    Kennt jemand disen Fehler oder weiss, wo durch dieser ausgelöst werden kann?

    Ich habe versucht, es nachzustellen, aber ohne Erfolg. Da es sich um eine Anlage handelt, die nicht stehen bleiben darf, ist es mir wichtig, den Fehler zu finden.

    Danke schon mal....
    Zitieren Zitieren Plötzlicher Stillstand der CPU  

  2. #2
    Registriert seit
    03.04.2008
    Beiträge
    6.200
    Danke
    237
    Erhielt 815 Danke für 689 Beiträge

    Standard

    ich kenne es solch einen Fehler auch, wenn z.B. ein Speicherfehler vorliegt.
    Hast du eine Speicherkarte gesteckt?
    Kann es sein, dass jemand etwas geschaltet hat?
    Hast du einmal nachgeschaut, welcher Baustein war bearbeitet als letztes bearbeitet wurde?
    Hast du versucht die Bausteine zu lesen / vergleichen?


    bike
    "Any fool can write code that a computer can understand.
    Good programmers write code that humans can understand."
    --Martin Fowler

  3. #3
    Registriert seit
    13.10.2007
    Beiträge
    12.033
    Danke
    2.788
    Erhielt 3.269 Danke für 2.157 Beiträge

    Standard

    Zitat Zitat von bike Beitrag anzeigen
    Hast du eine Speicherkarte gesteckt?
    ohne wird es wohl nicht funktionieren.
    - - -
    Wer als Werkzeug nur einen Hammer hat, sieht in jedem Problem einen Nagel.

  4. #4
    SPS_NEU ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    02.03.2009
    Beiträge
    301
    Danke
    3
    Erhielt 2 Danke für 2 Beiträge

    Standard

    eine Karte war gesteckt (512kb). Zu der Zeit wurde nicht auf die CPU geladen oder beobachtet. An der CPU ist ein CP343 angeschlossen, der mit anderen Anlagen kommuniziert. Kann es sein, dass über diesen CP343 die CPU eine Störung bekam?
    Die letzten bearbeiteten Bausteine sind leider nicht mehr rauszubekommen.

  5. #5
    Registriert seit
    03.04.2008
    Beiträge
    6.200
    Danke
    237
    Erhielt 815 Danke für 689 Beiträge

    Standard

    Zitat Zitat von rostiger Nagel Beitrag anzeigen
    ohne wird es wohl nicht funktionieren.
    Es gibt einige 315er, die auch ohne Karte funktionieren und ich kenne nicht alle Bestellnummern.
    Fragen kostet nichts und hilft oft.

    Gut, dass du alles weißt.


    bike
    "Any fool can write code that a computer can understand.
    Good programmers write code that humans can understand."
    --Martin Fowler

  6. #6
    Registriert seit
    13.10.2007
    Beiträge
    12.033
    Danke
    2.788
    Erhielt 3.269 Danke für 2.157 Beiträge

    Standard

    Zitat Zitat von bike Beitrag anzeigen
    Gut, dass du alles weißt.
    Was soll das den jetzt, ich habe ledig geholfen, das er diesen Punkt
    mit der Speicherkarte getrost vergessen kann.
    - - -
    Wer als Werkzeug nur einen Hammer hat, sieht in jedem Problem einen Nagel.

  7. #7
    Registriert seit
    03.04.2008
    Beiträge
    6.200
    Danke
    237
    Erhielt 815 Danke für 689 Beiträge

    Standard

    Zitat Zitat von rostiger Nagel Beitrag anzeigen
    Was soll das den jetzt, ich habe ledig geholfen, das er diesen Punkt
    mit der Speicherkarte getrost vergessen kann.
    Der TE hat doch geantwortet. Das ist eine Aussage die erklärt was vor Ort installiert ist, denn ich sehe von hier nicht.
    Ist dir noch nie eine Speicherkarte begegnet, die volllief bzw die defekt ging, wenn zu oft schreibend darauf zugegriffen wurde?

    Ich frage eben, damit ich Probleme verstehe, ggF rekonstruierne und dann helfen kann.

    @TE: hast du einmal den Staus des Speichers angeschaut?


    bike
    "Any fool can write code that a computer can understand.
    Good programmers write code that humans can understand."
    --Martin Fowler

  8. #8
    SPS_NEU ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    02.03.2009
    Beiträge
    301
    Danke
    3
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Noch mal zur genauen Erklärung: Die oben genannte CPU ist verbaut und hat als Baugruppen DIs, DOs, einen CP343 und eine Regelbaugruppe FM355c.
    Der Speicher der Karte war nicht annähernd ausgelastet. Es ist ein eigentlich nur kleines Programm aufgespielt. Es agb auch relativ wenig zugriffe durch Umprogrammierung.
    Oder was meinst Du mit zu oft schreiben zugegriffen?

    Den Status des Speichers konnte ich noch nicht einsehen....

    Wenn ich die CPU habe, wie könnte ich versuchen, diesen Fehler zu provozieren?

  9. #9
    Registriert seit
    03.04.2008
    Beiträge
    6.200
    Danke
    237
    Erhielt 815 Danke für 689 Beiträge

    Standard

    Nicht nur beim Umprogrammieren wird auf die Speicherkarte zu gegriffen.
    Habt ihr unlinked DB eingesetzt?
    Irgend so etwas wie Sicherungen von Daten auf die Karte schreiben?
    Hm, also die FM355c da muss ich mal schauen, was und wie die genau mit der CPU sich austauscht.

    Wenn verschiedene intelligente Baugruppen verbaut sind, kann es, aber muss nicht, zu Zugrifffehler auf den Speicher kommen.



    bike
    "Any fool can write code that a computer can understand.
    Good programmers write code that humans can understand."
    --Martin Fowler

  10. #10
    SPS_NEU ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    02.03.2009
    Beiträge
    301
    Danke
    3
    Erhielt 2 Danke für 2 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    wir haben hier über 100 Anlagen mit gleichem Aufbau. Diese Anlagen laufen auch schon über 10 Jahre. Also der Grundsätzliche Aufbau funktioniert. Was meinst Du mit "unlinked DBs"?

Ähnliche Themen

  1. Bitte Hilfe: Motor baut zu hohes Drehmoment auf im Stillstand
    Von flashgorny im Forum Antriebstechnik
    Antworten: 5
    Letzter Beitrag: 22.01.2014, 20:22
  2. Pendelnde ServoAchse mit Stillstand
    Von Blackdriver im Forum Programmierstrategien
    Antworten: 4
    Letzter Beitrag: 15.04.2012, 11:09
  3. Mechanische Leistung im Stillstand
    Von dizz3l im Forum Antriebstechnik
    Antworten: 8
    Letzter Beitrag: 06.06.2011, 18:53
  4. Plötzlicher Totalausfall
    Von MatMer im Forum Simatic
    Antworten: 11
    Letzter Beitrag: 06.04.2011, 15:12
  5. Geschwindigkeitsreduzierung ohne Stillstand.... (Sinamics S120 CU320)
    Von Housse B @ HAGE im Forum Antriebstechnik
    Antworten: 6
    Letzter Beitrag: 11.11.2008, 20:36

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •