Hallo allerseits.

Ich bin noch recht unerfahren und gerade in der Einarbeitung im Umgang mit SPS und S7, aber leider meint ein Anlagenteil nach über 10 Jahren Betrieb streiken zu müssen und meine Aufgabe ist die Behebung dieser Störung, da keiner mit Erfahrung vom Innenleben dieses Teils mehr da ist.

Die Hauptkomponente ist eine S7-300 mit der CPU315-2 DP, programmiert mit S7 V5.3+SP2. Daran angeschlossen sind u.a. eine FM 357-2 und ein Bedienpanel OP 270. Diese wurde nach der Programmierung an eine S7-400 gehangen, damit eine automatisierte Steuerung über diese erfolgen kann, sie aber auch für sich allein manuell bedienbar bleibt.

Beim Start passiert folgendes:
1. Während des Startvorgangs des Panels kommen in folgender Reihenfolge die Fehlermeldungen
-80029 - Aktualisierung der Archive beendet. 3 Archive melden Fehler
-140001 - Verbindung abgebaut: Steuerung_1, Station 7,Rack 0, Platz 2
-170003 - Steuerung_1 Diagnose nicht möglich; Fehlercode 0x80000104
2. Im Versuch das Programm abzuarbeiten und die Anlage zu starten hört man dann auch einen Schalter klicken, nur um sofort den gesamten Prozess zu stoppen und auf der FM 357-2 leutet die rote Fehlerdiode auf. Ergo geschieht dann dasselbe auf der S7-300. Auf der FM 357-2 blinkt dann auch die gelbe DIAG LED. Das sieht aber aus wie das im Handbuch beschriebene Lebenszeichen von 3 Hz und auch konnte ich kein dreimaliges Blinken als Fehlerankündigung erkennen.
3. Schließlich nach ca. 20 s später zeigt das Panel folgendes an:
-140000 - Verbindung aufgebaut: Steuerung_1, Station 7,Rack 0, Platz 2

Nach etwas Recherche hier und im Siemens Forum könnte ein Formatieren der Memorykarte helfen, aber bevor ich da vor presche und mehr kaputt mache, hätte ich gerne einige Zweitmeinungen eingesammelt.

Daher meine Fragen: Wie könnte man das Problem hier lösen? Woher könnte es stammen, nachdem es 10 Jahre lang ohne Störung auskam? Vielleicht leere Batterie? Unsauberes Abschalten? Defekte Karte?
Was mich weiterhin verwundert ist, dass die eine Verbindung abgebaut wird, es dann natürlich(?) zur Fehlermeldung dort kommen muss, und sie später wiederherstellt. Dass diese wiederhergestellt werden kann, schließt eine defekte Verbindung aus?

Vielen Dank.

Ciao
D.