Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 12

Thema: Ethernet

  1. #1
    Registriert seit
    14.10.2014
    Beiträge
    16
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Kann mir jemand helfen??

    Meine Frage: wenn ich versuche mit meinem Laptop und z.B. der CPU 315-2 PN/DP eine Ethernetverbindung über meine >Internet und Netzwerk> Netzwerkverbindungen bei den Eigenschaften IP auto, klappt gar nicht. Aber wenn ich bei den Eigenschaften IP eine beliebige IP adresse selbst vergebe, dann bin ich mit der CPU verbunden und kann auch alles übertragen. Warum klappt es nur wenn ich die IP selbst vergebe??? Gibs da nicht irgendwelche Einstellungen im Simaticmanger oder im Laptop bei den Netzwerken/Internet??

    Mein Laptop hat ein Betriebssystem Win 7 prof 64 Bit und Simatic S7 2012.
    Zitieren Zitieren Ethernet  

  2. #2
    Registriert seit
    12.04.2005
    Ort
    Black Forest
    Beiträge
    1.344
    Danke
    28
    Erhielt 131 Danke für 118 Beiträge

    Standard

    Welche Adresse vergibst Du als "beliebige IP", also in welchem Range?

    Die Steuerung hat ja eine bestimmte IP Adresse in einem bestimmten SubNet (z.B. 192.168.214.1). Der Rechner mit dem Simatic Manager benötigt nun halt eine IP welche zu dem Range und dem Sub-Netz passt.
    Glaube entweder vergibt Windows bei Auto eine Adresse im 10.10 oder 196.xxx Bereich, wenn diese keine IP von einem DHSP Server bekommt.
    Diese Privaten-Bereiche können nicht Routen und daher wirst wohl auch keine Verbindung aufbauen können ...
    Daher gibts bei Windows die Möglichkeit eine Alternativ Konfiguration anzugeben (also wenn kein DHCP verfügbar).

    Eigenschaft Lan-Verbindung --> Internet Protokoll Version 4 (TCP/IPv4) --> Alternative Konfiguration --> Benutzerdefiniert ...
    Geändert von Boxy (04.05.2015 um 13:17 Uhr)

    „Eine Frage raubt mir den Verstand bin ich verrückt oder sind es die Anderen ?“

    Albert Einstein

  3. #3
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.639
    Danke
    377
    Erhielt 803 Danke für 644 Beiträge

    Standard

    Um einfach gleichzeitig mit das Firmennetz und ein S7 SPS in Verbinding zu sein, habe ich 2 Netz Verbindungen:
    Firmen-Netz: Wi-fi LAN und DHCP.
    S7 SPS: Kupfer LAN und feste IP Adresse wie Boxy es beschreibt.

    Es gibt andere Verfahren, aber dies ist der einfachste.
    Um der S7 SPS oder Profinet Knoten mit ein IP zu taufen muss der Verbindung direkt und über Kupfer gehen.
    Jesper M. Pedersen

  4. #4
    Coolmen ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    14.10.2014
    Beiträge
    16
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Aber bei meinem Chef klappt es, wenn er auf "auto" einstellt im Adaptereinstellungen sieht er meine IP von der CPU und von SEW Frequenzumrichter und mit Wlan geht er ins Firmnetz.

    Bei mir allein schon wenn ich in HW Konfg. versuche die IP`s zusuchen oder Ethernetteilnemmer zusuchen, findet mein Laptop über Patchkabel garnicht. Nur wenn ich wie gesagt selbst eine eigene vergebe, dann zeigt er zwar die IP von CPU an, aber nicht die ganze Bezeichnug von der CPU. Und die Frequenzumrichter zeigt mein Laptop er gar nicht an.

    Die SEW Frequenzumrichter sind natürlich schon programmiert und adressiert.
    Zitieren Zitieren Weiter zu meine Frage  

  5. #5
    Registriert seit
    16.03.2006
    Ort
    Franken
    Beiträge
    3.843
    Danke
    30
    Erhielt 942 Danke für 819 Beiträge

    Standard

    Hi,

    mit diesem komischen Auto meinst du vermutlich im Windows DHCP oder?
    Bei DHCP on und keinen DHCP Server wird automatisch eine Adresse aus dem APIPA Band eingestellt (169.254.x.x), damit verfügt unter Windows diese Schnittstelle über eine "eingeschränkte Konnektivität", was nix anderes bedeutet als:
    "Ich bin nicht so konfiguriert wie ich sollte und mach mal einen Notbetrieb".

    Kann es sein das dein Chefe das Auto nicht bei den Windows Netzwerkeinstellungen einstellt sonder bei "PG/PC Schnittstelle einstellen" die Einstellung TCPIP(Auto) bzw. TCPIP.Auto wählt, das sind nämlich zwei unterschiedliche Baustellen, letzteres sorgt dafür das Step7 eine temporäre IP Adresse aktiviert um mit den gefundenen Teilnehmern zu kommunizieren.

  6. #6
    Registriert seit
    12.04.2005
    Ort
    Black Forest
    Beiträge
    1.344
    Danke
    28
    Erhielt 131 Danke für 118 Beiträge

    Standard

    Einfach doch mal das beschriebene versuchen und berichten obs hilft

    Welche IP hat der NW Adapter von deinem Chefe den und welche hat deiner wenn der Rechner gestartet wird und dieser keine IP von einem DHCP Server bekommt (also kein Kabel)?
    Es mag ja sein, das der Chefe ne passende IP bekommt oder noch hat wegen z.B. der Lease time (kann man sogar irgendwie in WIN einstellen welche IP er sich Privat vergibt). Oder hat er ggf. ne Alternativ Konfiguration eingestellt? Ist der Reiter neben Allgemein wo Du "Auto" beschriebst (mal rein schauen)!

    Aber am einfachsten geht es mittels der Alternativ Konfiguration des LAN-Adapters oder via USB Lan-Adapter welcher ne feste Konfig hat.

    „Eine Frage raubt mir den Verstand bin ich verrückt oder sind es die Anderen ?“

    Albert Einstein

  7. #7
    Registriert seit
    16.03.2006
    Ort
    Franken
    Beiträge
    3.843
    Danke
    30
    Erhielt 942 Danke für 819 Beiträge

    Standard

    von welchem Betriebssystem reden wir eigentlich?

  8. #8
    Registriert seit
    12.04.2005
    Ort
    Black Forest
    Beiträge
    1.344
    Danke
    28
    Erhielt 131 Danke für 118 Beiträge

    Standard

    Zitat Zitat von ChristophD Beitrag anzeigen
    von welchem Betriebssystem reden wir eigentlich?
    Zitat Zitat von Coolmen Beitrag anzeigen
    Kann mir jemand helfen??

    Mein Laptop hat ein Betriebssystem Win 7 prof 64 Bit und Simatic S7 2012.
    Er hat jetzt zwei Ansätze welche er beim seinem Chefe mal prüfen und uns danach berichten kann
    Aber das mit dem TCPIP.Auto im S7 muss ich auch mal testen.

    „Eine Frage raubt mir den Verstand bin ich verrückt oder sind es die Anderen ?“

    Albert Einstein

  9. #9
    Coolmen ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    14.10.2014
    Beiträge
    16
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ja das meinte ich.

  10. #10
    Registriert seit
    16.03.2006
    Ort
    Franken
    Beiträge
    3.843
    Danke
    30
    Erhielt 942 Danke für 819 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von Coolmen Beitrag anzeigen
    Ja das meinte ich.
    Was genau meintest du? TCPIP.AUTO bei PG/PC Schnittstelle Einstellungen?

    Wie kommt es dann das es funktioniert wenn du eine IP fest einstellst, weil das machst du doch im Windows !

    Was ist das überhaupt für eine Step7 Version ? 2012 gibt es nicht.
    Meinst du Step7 Professional 2010 SR2 oder TIA Portal V12 oder was?

Ähnliche Themen

  1. Antworten: 6
    Letzter Beitrag: 20.02.2012, 13:42
  2. Ethernet <--> PC
    Von SPS-Max im Forum Feldbusse
    Antworten: 7
    Letzter Beitrag: 20.04.2009, 13:24
  3. PRIM Ethernet - Frei definierbares Protokoll für Ethernet TCP/IP
    Von whatisnesps im Forum Werbung und Produktneuheiten
    Antworten: 0
    Letzter Beitrag: 20.08.2008, 13:51
  4. Ethernet
    Von Unregistriert im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 16.02.2006, 15:49
  5. S5 Ethernet
    Von kolbendosierer im Forum Feldbusse
    Antworten: 14
    Letzter Beitrag: 06.05.2005, 21:09

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •