Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 10 von 10

Thema: 3 TP900 mit gleichen Projekt an 1517F betreiben

  1. #1
    Registriert seit
    26.01.2008
    Ort
    Weida
    Beiträge
    127
    Danke
    58
    Erhielt 47 Danke für 36 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ich Betreiber 3 Pulte an einer CPU. Programmtechnisch sind diePulte gleich.
    Übertragenen der Software erfolgt über den „erweiterten Download“(TIA13SP1Upd3). Dabei gebe ich die eingestellte IP an (x.x.x.8 bis 10).

    Bei den Download wird nun außer dem Projekt auch dieprojektierte IP-Adresse (x.x.x.8 sowie der PN-Name mit übertragen und aktiviert.
    Somit habe ich nach den Download auf allen Pulten die Adresse x.x.x.8.

    Gibt es eine Möglichkeit dies zu verhindert oder kann man vielleichtüber eine .bat Datei unter Windows CE die IP-Adresse zurückschreiben?

    Harald
    Zitieren Zitieren 3 TP900 mit gleichen Projekt an 1517F betreiben  

  2. #2
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.197
    Danke
    926
    Erhielt 3.292 Danke für 2.661 Beiträge

    Standard

    Bist Du sicher, daß bei dem Transfer auch die IP und der Name des Panels verändert wird?
    Das war meines Wissens noch nie so Beides muß im Control panel des Panels eingestellt werden.

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  3. #3
    Funky ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    26.01.2008
    Ort
    Weida
    Beiträge
    127
    Danke
    58
    Erhielt 47 Danke für 36 Beiträge

    Standard

    Ja, ganz sicher.

    Harald

  4. #4
    Registriert seit
    12.12.2013
    Ort
    Kaiserslautern
    Beiträge
    1.339
    Danke
    388
    Erhielt 219 Danke für 173 Beiträge

    Standard

    Änderst du die IP-Adressen nach dem Laden wieder am Panel selbst zurück?

    Was meinst du mit erweiterte Download? nicht einfach der Ladebutton ?


    Bram
    Wenn es nicht auf STRAVA ist, ist es nicht passiert !!

  5. #5
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.197
    Danke
    926
    Erhielt 3.292 Danke für 2.661 Beiträge

    Standard

    Ahhh, eine weitere "Comfort"-Funktion für die ach-so-dummen Durchschnitts-Panel-Projektierer.

    Wie kann eine WinCC (TIA Portal) Projektierung über Ethernet auf ein Bediengerät übertragen werden?
    Laut dieser Anleitung und laut Gerätehandbuch wird (vermeidbar?) tatsächlich die IP-Adresse und der Profinet-Devicename aus der WinCC-Projektierung übernommen.

    Ich habe mit dem TIA 13 gar keine Erfahrung, doch ich interpretiere die Anleitung so, daß wenn man in der Projektierung für die Ethernet-Schnittstelle eine IP-Adresse einträgt, dann wird diese beim Runtimestart vom Panel übernommen (steht ja auch da: IP-Adresse im Projekt einstellen)
    Anscheinend/möglicherweise kann man diese Projektierung leer lassen oder deaktivieren oder auf "IP-Adresse auf anderem Weg beziehen" umstellen. Dann wird vielleicht nicht die am Panel vorhandene IP geändert.

    Was das Verhindern der Übernahme des projektierten Profinet-Gerätenamens angeht habe ich nichts gefunden.

    Wäre mal interessant zu hören, wie Siemens sich so eine häufig benötigte "Massen"-Projektierung von mehreren gleichen (Linien-)Panelen vorstellt... besonders wo es jetzt biszusoundsovielprozent schneller gehen soll und TIA den Projektierer vor allen möglichen Fehlbedienungen schützt...

    PS: wie ist das eigentlich? Nach dem Transfer hat sich die IP-Adresse verstellt - man geht zum Panel, stellt wieder die richtige IP ein - Panel Neustart und Runtime-Start - die in WinCC projektierte Adresse ist wieder da???

    Harald
    Geändert von PN/DP (02.06.2015 um 22:47 Uhr)
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  6. #6
    Registriert seit
    03.04.2004
    Beiträge
    121
    Danke
    7
    Erhielt 14 Danke für 10 Beiträge

    Standard

    Hallo,

    dass von Funky beschriebene Verhalten ist nichts TIA-spezifisches, sondern war bei WinCC flex auch schon so.

    Will man auf mehrere Panels, welche über Ethernet mit der CPU verbunden sind, die gleiche Projektierung laden,
    darf man nicht erst im Transfer-Dialog die IP-Adresse einstellen, sondern muss dies bereits in 'Geräte und Netze' tun.
    Früher hat man dies halt in 'NetPro' eingestellt.

  7. #7
    Registriert seit
    16.03.2006
    Ort
    Franken
    Beiträge
    3.797
    Danke
    30
    Erhielt 917 Danke für 798 Beiträge

    Standard

    Hi,

    einfach im TIA bei der Schnittstelle des Panels die Optionen "Anpassen der IP-Adresse direkt am Gerät erlauben" und "Anpassen des PROFINET-Gerätenamens direkt am Gerät erlauben".
    Dann werden diese Daten nicht im Projekt festgelegt sondern direkt im Panel und das Problem tritt nicht mehr auf.

    Gruß
    Christoph

  8. Folgende 3 Benutzer sagen Danke zu ChristophD für den nützlichen Beitrag:

    Funky (03.06.2015),PN/DP (03.06.2015),RONIN (03.06.2015)

  9. #8
    Registriert seit
    23.07.2009
    Ort
    Österreich
    Beiträge
    2.354
    Danke
    455
    Erhielt 694 Danke für 519 Beiträge

    Standard

    War das nicht bei Flex auch schon so? Kann mich düster erinnern das ich bei gleichen Panels (bei Profinet bin ich mir nicht 100pro) zumindest bei Profibus immer die Adresse in der Projektierung ändern musste bevor ich übertragen hatte.
    Da hatte das Panel bei Runitme-Start auch immer die projektierte Adresse angenommen.
    If at first you don't succeed, you're not Van Damme!
    ... or maybe using TIA!

  10. #9
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.197
    Danke
    926
    Erhielt 3.292 Danke für 2.661 Beiträge

    Standard

    Zitat Zitat von Joerg123 Beitrag anzeigen
    dass von Funky beschriebene Verhalten ist nichts TIA-spezifisches, sondern war bei WinCC flex auch schon so.
    Das ist falsch. WinCC Flex stellt keine IP-Adressen ein. Ethernet-Projekte können ohne Änderungen auf mehrere Panels geladen werden.

    nicht erst im Transfer-Dialog die IP-Adresse einstellen, sondern muss dies bereits in 'Geräte und Netze' tun.
    Früher hat man dies halt in 'NetPro' eingestellt.
    Im Transfer-Dialog (und "in NetPro") wird nicht die IP-Adresse eingestellt, welche das Gerät erhalten soll, sondern zu welcher IP transferiert werden soll.


    Zitat Zitat von RONIN Beitrag anzeigen
    War das nicht bei Flex auch schon so?
    Nur Profibus/MPI-Adressen. IP-Adressen wurden nicht im Projekt festgelegt, sondern mussten immer am Panel eingestellt werden.

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  11. Folgender Benutzer sagt Danke zu PN/DP für den nützlichen Beitrag:

    RONIN (03.06.2015)

  12. #10
    Funky ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    26.01.2008
    Ort
    Weida
    Beiträge
    127
    Danke
    58
    Erhielt 47 Danke für 36 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    @de vliegende hollander

    ja ich ändere die IP - Adresse jedes Mal zurück von x.x.x.8 auf x.x.x.9 bzw. x.x.x.10 bei Pult 2 & 3.
    Danach braucht man nur die Runtime neu starten.

    @PN/DP

    "IP-Adresse auf anderem Weg beziehen" bezieht sich ja auf DHCP. Ich werde es testen. IP Adresse im Projekt "leer lassen" ist nicht erlaubt.

    @Joerg123

    In WinCC flex wird beim übertragen der Projektierung die IP-Adresse nicht geändert. Unter flex habe ich mehrere Projekte mit gleichen Panels wo ich im Projekt nur eines habe und beim Übertragen die IP-Adresse ändere.

    @ChristophD

    Danke! das sind die Hacken die ich gesucht habe.

    Harald

Ähnliche Themen

  1. Antworten: 1
    Letzter Beitrag: 16.04.2015, 10:00
  2. TIA TIA V12 Probleme mit TP900 Comfort
    Von Flachschipp im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 02.05.2013, 22:45
  3. Probleme mit 2 Laptops im gleichen Profinet
    Von Knut333 im Forum Simatic
    Antworten: 17
    Letzter Beitrag: 04.12.2012, 15:12
  4. 2 Panels mit gleichen Funktionen
    Von Weschi im Forum HMI
    Antworten: 6
    Letzter Beitrag: 03.05.2011, 10:09
  5. Problem mit 2 gleichen FC´s
    Von smartie im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 08.07.2008, 22:34

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •