Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 4 von 4

Thema: S7-1200 DC - PWM - Transistor defekt ?

  1. #1
    Registriert seit
    07.10.2012
    Ort
    Heusenstamm
    Beiträge
    4
    Danke
    1
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Moin moin zusammen,

    bin grade nen bischen am rumspielen mit meine S7-1200 (CPU1214c) und meinem TP177b-Color...eigentlich wollte ich nur nen paar Bilder des HMI "aufräumen" aber so wie es aussieht hab ich plötzlich nen HW Defekt.

    Mithilfe des PWM ausgangs werden lüfter in ihrer Drehzahl geregelt...doch auf ein mal gingn die Lüfter alle auf Maximum und ab und an auf Minimum (Die Ist-Drehzahl wird im Diagramm auf dem HMI dargestellt)....
    Ich bin sofort in den Onlinemodus gewechselt und hab mir die Ausgangswerte angesehen....sie schwankten nicht !
    Hab dann die Stromversorgung getrennt, kurz gewartet und wieder eingeschaltet....lüfter gingen sofort auf max (schwanken war weg).

    Als ich mit Oszi mir die PWM anschaute, war mir klar warum die lüfter auf max liefen...der Ausgang hatte +24V

    Hab dan zum testen das Programm etwas modifiziert so das ich mithilfe eines Analogen eingangs (0-10V vom Poti) direkt die PWM beeinflussen konnte.

    Dabei viel mir dann auf, das ich die PWM minimalst sehe....Oszi eingang von AC auf DC Kopplung gestellt und siehe da die PWM ist sichtbar....hat aber nur einige hundert mV Amplitude.

    Für mich sieht es so aus, als ob hier ein HW Defekt vorliegt (Transistorendstufe defekt) oder was meint ihr ?

    PS:
    Zum Bild vom Oszi: Gelb ist CH1 = DC-Kop. ist. Und Blau ist CH2 = AC-Kop.
    Angehängte Grafiken Angehängte Grafiken
    Zitieren Zitieren S7-1200 DC - PWM - Transistor defekt ?  

  2. #2
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.263
    Danke
    537
    Erhielt 2.708 Danke für 1.957 Beiträge

    Standard

    Hast du die Lüfter direkt am PWM? Wieviel Strom bringt der denn maximal, evtl. hast du ihn ja wirklich überlastet. Sieht für mich auch so aus, als ob dem Treibertransistor die Hosen geplatzt sind, dann siehst du jetzt wohl nur das Steuersignal aus der Vorstufe die so ein bisschen die 24 V schwanken lassen, die durch den Transistor gehen.
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  3. #3
    SnakeHanau ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    07.10.2012
    Ort
    Heusenstamm
    Beiträge
    4
    Danke
    1
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Nee nicht direkt hängt nen MosFET + R dazwischen, da der Eingang der Lüfter internen Pullup hat.....In Zukunft kommt da nen Optokoppler dazwischen !

    Steht eigentlich irgendwo wie viel mA/A man aus dem Ausgang im PWM/PTO betrieb ziehen darf ?

  4. #4
    Registriert seit
    04.11.2013
    Beiträge
    143
    Danke
    14
    Erhielt 26 Danke für 21 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Erlaubt sind 0,5A, egal ob PWM oder nicht, ist ja auch nur Ein/Ausschalten. Ein MOSFET-Defekt (verbaut sind 10-20A-Typen) durch Überstrom/Kurzschluss sollte sich aber am Geruch erkennen lassen. Hast du den Ausgang mal ohne PWM direkt getestet ?

Ähnliche Themen

  1. Siemens S7-1200 defekt
    Von Colus im Forum Elektronik
    Antworten: 20
    Letzter Beitrag: 22.05.2015, 15:19
  2. PWM Steller
    Von magus111 im Forum Elektronik
    Antworten: 6
    Letzter Beitrag: 15.02.2012, 09:44
  3. Unterschied zwischen Transistor und Relais Ausgang
    Von Papa_Bene im Forum Elektronik
    Antworten: 10
    Letzter Beitrag: 16.02.2011, 18:57
  4. Transistor
    Von Rechi im Forum Elektronik
    Antworten: 2
    Letzter Beitrag: 20.11.2005, 10:37
  5. Antworten: 5
    Letzter Beitrag: 23.03.2005, 14:12

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •