Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 8 von 8

Thema: Problem mit freier UDP Verbindung

  1. #1
    Registriert seit
    18.02.2007
    Ort
    Nordfriesland
    Beiträge
    47
    Danke
    5
    Erhielt 3 Danke für 3 Beiträge

    Idee


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo ihr Wissenden,

    hoffe ihr könnt mir bei meinem Problem helfen.

    Ich habe eine CPU 314C-2PN und eine CP343-1 Lean und möchte damit eine UDP Verbindung zu einer Loxone Steuerung projektieren.
    In den Beispielen die ich für eine Freie UDP Kommunikation gefunden habe werden aber immer Bausteine FB63 -FB68 verwendet.

    Diese Bausteine kann ich aber nicht in mein Projekt laden.

    Geht das mit meiner Hardware vielleicht gar nicht ?

    Ich wäre für jeden Tipp sehr dankbar.

    Grüße
    Udo
    Zitieren Zitieren Problem mit freier UDP Verbindung  

  2. #2
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.163
    Danke
    921
    Erhielt 3.286 Danke für 2.655 Beiträge

    Standard

    Die T-Bausteine FB63... funktionieren nur mit der in der CPU integrierten PN-Schnittstelle, nicht mit dem CP.
    Siehe mal hier die FAQ Linkliste SIMATIC-Kommunikation über Ethernet, da findest Du Programmierbeispiele zu beiden Schnittstellen.

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  3. #3
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.163
    Danke
    921
    Erhielt 3.286 Danke für 2.655 Beiträge

    Standard

    Zitat Zitat von udo_39 Beitrag anzeigen
    Diese Bausteine kann ich aber nicht in mein Projekt laden.
    Was heißt "ich kann nicht"?

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  4. #4
    Registriert seit
    18.02.2007
    Ort
    Nordfriesland
    Beiträge
    47
    Danke
    5
    Erhielt 3 Danke für 3 Beiträge

    Standard

    Danke für die superschnelle Antwort

    hab mich gerade verschrieben, ich hab ja nur eine CPU 314-2DP ohne PN welches Beispiel wäre da dann zu nehmen ?

  5. #5
    Registriert seit
    18.02.2007
    Ort
    Nordfriesland
    Beiträge
    47
    Danke
    5
    Erhielt 3 Danke für 3 Beiträge

    Standard

    kann nicht heißt
    das beim Laden die Fehlermeldung kommt "Baustein konnte nicht kopiert werden"

    Fehler bei der Übersetzung eines Bausteins in S7-300 CPU

    Die VersionsNr des Bausteins ist 2.4

  6. #6
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.725
    Danke
    314
    Erhielt 1.519 Danke für 1.282 Beiträge

    Standard

    Wenn du eine 314C-2DP dann kann das natürlich nicht gehen, allerdings hast du im Eingangspost geschrieben:
    Ich habe eine CPU 314C-2PN und eine CP343-1 Lean
    UDP-Verbindung in Netpro projektieren, und dann so weiter:
    https://support.industry.siemens.com.../view/17853532

    Mfg
    Manuel
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  7. Folgender Benutzer sagt Danke zu MSB für den nützlichen Beitrag:

    udo_39 (08.06.2015)

  8. #7
    Registriert seit
    18.02.2007
    Ort
    Nordfriesland
    Beiträge
    47
    Danke
    5
    Erhielt 3 Danke für 3 Beiträge

    Standard

    ich bin jetzt etwas weiter
    ich kann Daten an die Loxone senden.
    Das empfangen funktioniert aber nicht.

    was muß im Header der Daten von der Loxone stehen damit die S7 es erkennt.?

    Der FC6 meldet zuerst 8180 das keine Daten vorliegen und dann 8183 das die Projektierung fehlt.

    Ich habe die Verbindung aber in NetPro projektiert.

    im Moment bin ich ratlos vielleicht habt Ihr noch eine Idee,
    grüße
    Udo

  9. #8
    Registriert seit
    18.02.2007
    Ort
    Nordfriesland
    Beiträge
    47
    Danke
    5
    Erhielt 3 Danke für 3 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Lösung gefunden
    Adressvergabe am Baustein musste aktiviert werden.

    Dank an alle für die Hilfen

Ähnliche Themen

  1. Antworten: 11
    Letzter Beitrag: 19.02.2014, 12:24
  2. Step 5 UDP Verbindung mit FB65 öffnen
    Von WinniePooh im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 27.04.2013, 18:15
  3. UDP-Verbindung
    Von MrChiliCheese im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 05.11.2012, 13:11
  4. Verständnisfrage 315PN UDP-Verbindung
    Von hobby im Forum Simatic
    Antworten: 11
    Letzter Beitrag: 16.02.2008, 15:02
  5. freie UDP-Verbindung
    Von DerWolf im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 22.07.2007, 12:47

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •