Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 2 ErsteErste 12
Ergebnis 11 bis 20 von 20

Thema: Sprungbefehle bei Simulation

  1. #11
    Stutz ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    09.04.2015
    Beiträge
    15
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Vielen Dank war wirklich ein Fehler.


    Was ich gnau machen will:

    Eine ähnliche Schrittkette hab ich schon im TIA mit SCL Programmiert und läuft.

    Also ich will eine Drag and Drop Schrittkette, unversal für jegliche Maschinen einsetztbar.

    Aber mein Prolem ist immer noch der spb obwohl das VKE = 0 ist.

  2. #12
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.333
    Danke
    932
    Erhielt 3.333 Danke für 2.691 Beiträge

    Standard

    Woran meinst Du zu sehen, daß Dein SPB trotz VKE=0 ausgeführt wird?
    Die Funktionsweise des SPB ist Dir geläufig bzw. hast Du in der Step7-Hilfe schnell mal nachgelesen? SPB setzt auf jeden Fall VKE und STA auf 1, egal ob der Sprung ausgeführt wird oder nicht. Das Beobachten des Programms zeigt den Status nach Ausführung der Operation.

    Falls Du immer noch nicht an die korrekte Ausführung des SPB glaubst: Lade Dein Programm in PLCSIM und steppe Deine Schleife im Einzelschrittbetrieb durch.

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  3. Folgender Benutzer sagt Danke zu PN/DP für den nützlichen Beitrag:

    Stutz (09.07.2015)

  4. #13
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.333
    Danke
    932
    Erhielt 3.333 Danke für 2.691 Beiträge

    Standard

    Zitat Zitat von Stutz Beitrag anzeigen
    Also ich will eine Drag and Drop Schrittkette, unversal für jegliche Maschinen einsetztbar.
    Viel Erfolg bei der Erfindung des Universalprogramms für "jegliche" Maschinen, welches ohne Programmierung auskommt und lediglich per Drag'n Drop angepasst wird! Das haben schon sooo viele vor Dir versucht.

    Das konnte ich mir nicht verkneifen

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  5. #14
    Stutz ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    09.04.2015
    Beiträge
    15
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Wenns dann doch funktioniert?

  6. #15
    Registriert seit
    12.04.2005
    Ort
    Black Forest
    Beiträge
    1.346
    Danke
    28
    Erhielt 131 Danke für 118 Beiträge

    Standard

    Zitat Zitat von Stutz Beitrag anzeigen
    Wenns dann doch funktioniert?
    Dann wäre ich der zweite der dies haben möcht

    „Eine Frage raubt mir den Verstand bin ich verrückt oder sind es die Anderen ?“

    Albert Einstein

  7. #16
    Stutz ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    09.04.2015
    Beiträge
    15
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Zitat Zitat von PN/DP Beitrag anzeigen
    Woran meinst Du zu sehen, daß Dein SPB trotz VKE=0 ausgeführt wird?
    Die Funktionsweise des SPB ist Dir geläufig bzw. hast Du in der Step7-Hilfe schnell mal nachgelesen? SPB setzt auf jeden Fall VKE und STA auf 1, egal ob der Sprung ausgeführt wird oder nicht. Das Beobachten des Programms zeigt den Status nach Ausführung der Operation.

    Falls Du immer noch nicht an die korrekte Ausführung des SPB glaubst: Lade Dein Programm in PLCSIM und steppe Deine Schleife im Einzelschrittbetrieb durch.

    Harald
    Danke Harald,

    du hattest von Anfang an recht es ist ein Fehler im Beobachten. Ich hab mir ja selber den Loop gebaut um vorwärts zu zählen, ich hab jedoch den Sprung zurück an die falsche Stelle geschrieben und somit einen "Schmarn" in den Loop Counter eingetragen.

    Aber jetzt sind alle Fehler der STEP-Funktionen sind weg und die Schrittkette läuft (in der Simulation).

    Vielleicht sollte ich ein Thema "Schrittkette: Drag and Drop" erstellen, es gibt ja doch recht viele Zweifler.


    Schönen Gruß noch

  8. #17
    Registriert seit
    19.06.2015
    Beiträge
    459
    Danke
    26
    Erhielt 40 Danke für 35 Beiträge

    Standard

    Hallo Stutz,

    schick mir mal deine Eierlegende Wollmilchsau.

    Gruß

  9. #18
    Stutz ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    09.04.2015
    Beiträge
    15
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo zusammen,

    ich würde mein Programm gerne Posten, bloß wie?

  10. #19
    Registriert seit
    19.06.2015
    Beiträge
    459
    Danke
    26
    Erhielt 40 Danke für 35 Beiträge

    Standard

    SO:

    email:sv-330859@versanet.de

    Andere Frage.ich versuche mich gerade im Graph 7 einzuarbeiten.Hast du da eine Ahnung?
    Mir gehts vorallem um die Betriebsarten und die ganzen Ein und Augänge de Graph 7 Bausteins.
    Die SK selber aufzustellen ist mir vom Prinzip klar.

  11. #20
    Registriert seit
    21.11.2014
    Beiträge
    228
    Danke
    7
    Erhielt 30 Danke für 28 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von silverfreaky Beitrag anzeigen
    SO:

    email:sv-330859@versanet.de

    Andere Frage.ich versuche mich gerade im Graph 7 einzuarbeiten.Hast du da eine Ahnung?
    Mir gehts vorallem um die Betriebsarten und die ganzen Ein und Augänge de Graph 7 Bausteins.
    Die SK selber aufzustellen ist mir vom Prinzip klar.
    Bis auf den quittiereingang kannst du im Prinzip alle löschen, es sei denn du möchtest die graph fehlerverwaltung oder den ketten reset oder ähnliche Funktion tatsächlich verwenden.

    Notwendig ist theoretisch nur die quittierung.
    Geändert von Christmaspoo (10.07.2015 um 17:04 Uhr)

Ähnliche Themen

  1. Bei Simulation ***INVALID: 16#xx***
    Von der dude im Forum CODESYS und IEC61131
    Antworten: 6
    Letzter Beitrag: 03.02.2014, 10:56
  2. Hilfe bei WinCC Simulation
    Von flashgorny im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 08.04.2013, 18:52
  3. Problem bei Simulation
    Von Andreas1984 im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 15.02.2009, 00:41
  4. Sprungbefehle
    Von Stoesl im Forum Simatic
    Antworten: 15
    Letzter Beitrag: 01.12.2006, 21:32
  5. Simulation bei Step7
    Von MRT im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 15.12.2005, 08:18

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •