Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 5 von 5

Thema: CPU nicht Online erreichbar

  1. #1
    Registriert seit
    13.11.2014
    Ort
    Paderborn
    Beiträge
    190
    Danke
    15
    Erhielt 13 Danke für 12 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    CPU 314c 2PN/DP

    Moin,

    ich habe gestern fälschlicherweise ein falsches Haardware Konfig auf meine CPU geladen die eigentlich für das Panel angedacht war (falls das überhaupt möglich ist). Jetzt wollte ich das heute morgen beheben aber ich kann die richtige HWK nicht mehr auf die CPU laden. Ich sehe zwar unter erreichbare Teilnehmer die CPU, sobald ich dann allerdings in der Hardware Konfig "In Baugruppe laden" und mir den Teilnehmeranzeige und anschliessend die HWK reinladen möchte erscheint eine Fehlermeldung. Teilnehmer antwortet nicht. Hab es sowohl über ethernet versucht als auch über mpi. Baudrate kontrolliert, Busadresse kontrolliert....

    Wenn man dann auf Hilfe klickt, steht da was von XDB.datei die in der SPS sein könnte und durch eine falsche HWK (siehe oben Panel HWK von gestern) auftreten kann, so dass die CPU offline bleibt. ...und wie bekomme ich die da wieder raus?`Urlöschen hilft da wohl nicht viel
    Zitieren Zitieren CPU nicht Online erreichbar  

  2. #2
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.192
    Danke
    925
    Erhielt 3.292 Danke für 2.661 Beiträge

    Standard

    Die richtige HW Konfig über MPI oder Profibus laden.
    Oder per "Zielsystem > Ethernetteilnehmer bearbeiten..." der CPU die richtige IP-Adresse zuweisen und danach die richtige HW Konfig per Ethernet laden.

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  3. #3
    Registriert seit
    05.10.2005
    Beiträge
    2.373
    Danke
    321
    Erhielt 296 Danke für 266 Beiträge

    Standard

    Wenn du sie unter erreichbare Teilnehmer siehst, solltest du doch auch die Systemdatenbausteine aus deinem Projekt draufkopieren können. Anschließend Neustart...

  4. #4
    Avatar von Junge
    Junge ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    13.11.2014
    Ort
    Paderborn
    Beiträge
    190
    Danke
    15
    Erhielt 13 Danke für 12 Beiträge

    Standard

    Es hat geklappt. Werde es heute abend berichten. Tausend Dank!!!!!!!

  5. #5
    Avatar von Junge
    Junge ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    13.11.2014
    Ort
    Paderborn
    Beiträge
    190
    Danke
    15
    Erhielt 13 Danke für 12 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    So nochmal kurze Rückmeldung.

    Folgendes war das Problem: Hatte versehentlich in meine CPU 324c-2 PN/DP eine Hardware Konfig für eine CPU 315F .. reingeladen ( Keine Ahnung wie das überhaupt möglich ist. aber es wurde mir so angezeigt)

    ..danach konnte ich sowohl über Ethernet also auch über MPI nicht mehr auf die CPU zugreifen. bzw. ich konnte die CPU zwar Online sehen (Online Teilnehmer) aber ich konnte keine neue Hardware Konfig mehr reinladen.

    Sobald ich auf "Lade in Baugruppe" geklickt habe und mit dem Ethernet Kabel verbunden war kam sofort eine Fehlermeldung das die CPU Offline ist und keine Verbindung hergestellt werden konnte-Sofort Abbruch!

    Mit Mpi konnte ich erstmal mit "Extra->PG/PC Schnittstelle->Diagnose" die korrekte Baudrate rausfinden indem ich dort den "test" gemacht habe. Die bautrate hat sich seltsamerweise auch verändert wahrscheinlich war diese aus dem vorherigen Projekt. Jetzt konnte ich zwar die Schritte soweit in der Hardware Konfig mit "Lade in Baugruppe" durch arbeiten, dass ich bis zum eiglt. Transfer kam, dann kam aber auch anschließend die Fehlermeldung CPU ist Offline.

    Urlöschung hat auch nichts gebracht.

    Erst der Tipp von "PN/DP" mit "Zielsystem > Ethernetteilnehmer bearbeiten..." hat mir weitergeholfen, da habe ich die IP Adresse anpassen können und danach ging es mit dem MPI Kabel. Die in der Hardware Konfig erstellte IP war unterschiedlich zu der in der CPU und ich denke, daran ist es gescheitert, weil der Teilnehmer mit der richtigen IP nicht gefunden wurde.

    Jetzt ist nur die Frage was hat das MPI Kabel mit der IP Adresse zu tun?

Ähnliche Themen

  1. Antworten: 7
    Letzter Beitrag: 15.07.2015, 11:23
  2. Antworten: 0
    Letzter Beitrag: 09.09.2010, 00:27
  3. CPU über MPI nicht erreichbar
    Von voni_1 im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 06.08.2010, 07:45
  4. CPU 315-2DP nicht online
    Von achim532000 im Forum Simatic
    Antworten: 12
    Letzter Beitrag: 02.12.2009, 11:57
  5. CPU 313C - Baustein ist Online wird aber nicht gezeigt.
    Von Jochen Kühner im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 09.11.2007, 14:21

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •