Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 15

Thema: Datenpunkte bei CP1243-1 IEC

  1. #1
    Registriert seit
    04.08.2011
    Beiträge
    77
    Danke
    2
    Erhielt 11 Danke für 11 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    Ich benutze eine S7-1200 mit einem CP1243-1 IEC (TIA V13 SP1 upd. 3)
    Parametrierung ist klar und Modul läuft auch. In der Datenpunktliste konnte ich auch einige Datenpunkttypen anlegen.
    Jetzt habe ich Schwierigkeiten mit 'Double-point information, IEC Typ <3>
    Laut Manual soll man einen Datenbaustein mit einem Array von genau 2 Bool anlegen.
    Hab ich gemacht, aber in der Auswahlbox für den Datenpunkttyp bekomme ich kein 'Double-point information' (3)

    Grüße
    Angehängte Grafiken Angehängte Grafiken
    Zitieren Zitieren Datenpunkte bei CP1243-1 IEC  

  2. #2
    König ist offline Benutzer
    Themenstarter
    Registriert seit
    04.08.2011
    Beiträge
    77
    Danke
    2
    Erhielt 11 Danke für 11 Beiträge

    Standard

    Ich hab das Gefühl ich bin Erstanwender, keiner weiß was.......

  3. #3
    Registriert seit
    22.05.2005
    Ort
    sonniges Maifeld
    Beiträge
    1.067
    Danke
    77
    Erhielt 205 Danke für 159 Beiträge

    Standard

    Ich habs eben mal probiert, bei mir funktioniert das auch nicht. Musst du wohl an Siemens melden...
    "Man kann auf seinem Standpunkt stehen, aber man sollte nicht darauf sitzen" - Erich Kästner

  4. Folgender Benutzer sagt Danke zu Lars Weiß für den nützlichen Beitrag:

    König (24.08.2015)

  5. #4
    Registriert seit
    30.04.2005
    Beiträge
    908
    Danke
    57
    Erhielt 161 Danke für 147 Beiträge

    Standard

    Ich habe es versucht und auch keine Probleme damit gehabt.
    Einen DB mit lauter Arrays[1..2] of bool erstellt.
    Jeder dieser Arrays ist dann ein Datenpunkt in der CP, als Typ auch korrekt mit 3 angegeben.

    Anscheinend muss aber jeder Double auch wirklich ein eigenes Array sein, alles andere wie eigenen Datentyp in einem Array oder diesen Array in einen weiteren Array hat nicht funktioniert.
    Geändert von centipede (24.08.2015 um 09:53 Uhr)
    Krieg ist Gottes Art den Amerikanern Geographie beizubringen

  6. #5
    König ist offline Benutzer
    Themenstarter
    Registriert seit
    04.08.2011
    Beiträge
    77
    Danke
    2
    Erhielt 11 Danke für 11 Beiträge

    Standard

    Welche Version des TIA Portals hast Du denn?

  7. #6
    Registriert seit
    30.04.2005
    Beiträge
    908
    Danke
    57
    Erhielt 161 Danke für 147 Beiträge

    Standard

    Aktuell V13 SP1 Upd4
    Krieg ist Gottes Art den Amerikanern Geographie beizubringen

  8. #7
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.163
    Danke
    921
    Erhielt 3.286 Danke für 2.655 Beiträge

    Standard

    Zitat Zitat von centipede Beitrag anzeigen
    Ich habe es versucht und auch keine Probleme damit gehabt.
    Einen DB mit lauter Arrays[1..2] of bool erstellt.
    Kann es sein, daß es nicht funktioniert mit ARRAY[0..1] of Bool?
    Ist das HSP 0147 installiert?

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  9. #8
    Registriert seit
    30.04.2005
    Beiträge
    908
    Danke
    57
    Erhielt 161 Danke für 147 Beiträge

    Standard

    Funktioniert auch mit 0..1 und HSP ist bei mir installiert.
    Krieg ist Gottes Art den Amerikanern Geographie beizubringen

  10. #9
    König ist offline Benutzer
    Themenstarter
    Registriert seit
    04.08.2011
    Beiträge
    77
    Danke
    2
    Erhielt 11 Danke für 11 Beiträge

    Standard

    Ich lade gerade das Upd 4 runter und will dann mal schauen.
    Kann vielleicht noch ein Unterschied sein, ob man TIA Prof. oder Basic verwendet?
    Ich habe Basic.

  11. #10
    Registriert seit
    30.04.2005
    Beiträge
    908
    Danke
    57
    Erhielt 161 Danke für 147 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Also Update 4 ist keine Voraussetzung, ob Basic oder Prof., dazu steht nichts dabei

    Technische Voraussetzungen / Kompatibilität:
    CPU: Für den Betrieb des CP1243-1 IEC ist eine S7-1200 CPU ab Firmwareversion 3 notwendig.
    Engineering: Zur Konfiguration des CP1243-1 IEC mit Firmware 1.2 ist Step7 V13 SP 1 Update 1 mit entsprechendem HSP zu verwenden.
    Leitstelle: Zur Anbindung an die Leitstellensysteme PCS7/WinCC sind die entsprechenden Telecontrol Pakete zur Unterstützung des IEC 60870-5 Protokolls notwendig.
    Krieg ist Gottes Art den Amerikanern Geographie beizubringen

Ähnliche Themen

  1. Datenpunkte von B&R X20 Modulen auslesen
    Von slayter im Forum CODESYS und IEC61131
    Antworten: 3
    Letzter Beitrag: 17.11.2013, 11:12
  2. Modbus TCP Server Mapping der Datenpunkte
    Von Justuz im Forum CODESYS und IEC61131
    Antworten: 0
    Letzter Beitrag: 20.08.2013, 14:25
  3. Einzelschritt bei IEC Schrittkette
    Von rheumakay im Forum Programmierstrategien
    Antworten: 4
    Letzter Beitrag: 18.03.2011, 10:23
  4. Hilfe bei IEC 61508
    Von LordKimbot im Forum Maschinensicherheit - Normen und Richtlinien
    Antworten: 5
    Letzter Beitrag: 04.08.2009, 09:27
  5. Wie Datenpunkte kalkulieren ?
    Von sk1rie im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 21.02.2009, 15:33

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •