Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 7 von 7

Thema: Probleme mit LabView und S7-200

  1. #1
    Dogma Gast

    Böse


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo liebe Experten,

    habe vor kurzem schonmal gepostet zu einem anderen Thema.Habe das Problem nun gelöst.Danke nochmal!
    Unser Projekt beschäftigt sich mit einer Online Qualitätsüberwachung.Überwacht wird ein Prozess,bei dem 2 Löcher in eine Platte gestanzt werden sollen.Über eine Kamera und diverse Software,mit der sich meine anderen kollegen beschäftigen werden Tags in LabView geschrieben und diese später der SPS als Signale ausgegeben.Das Problem besteht nun darin,das diese Signale nur als Merker an die SPS gegeben werden können.
    Meine Ablaufsteurung ist aber mit Eingängen (Inputs 0.....)versehn.
    Wie kann ich diese Inputs in Merker umwandeln.Bitte um schnelle Antwort!

    Danke schonmal im voraus!

    Gruß Marco
    Zitieren Zitieren Gelöst: Probleme mit LabView und S7-200  

  2. "Hallo,

    wie ist den die Anbindung zwischen LabVIEW
    und der S7-200 realisert?

    Ist die LabVIEW-Applikation "fertig" oder können
    Sie dort Änderungen vornehmen?

    Muss es über LabVIEW gehen oder könnte es
    sinnvoll sein, von der Kamerasoftware direkt
    mit der S7-200 zu kommunizieren (über Libnodave,
    AGLink oder ähnlichem)?

    Viele Grüße

    Gerhard Bäurle"


  3. #2
    Registriert seit
    25.07.2005
    Ort
    Vogelsbergkreis
    Beiträge
    1.717
    Danke
    48
    Erhielt 68 Danke für 60 Beiträge

    Standard

    Zitat Zitat von Dogma
    Hallo liebe Experten,

    habe vor kurzem schonmal gepostet zu einem anderen Thema.Habe das Problem nun gelöst.Danke nochmal!
    Unser Projekt beschäftigt sich mit einer Online Qualitätsüberwachung.Überwacht wird ein Prozess,bei dem 2 Löcher in eine Platte gestanzt werden sollen.Über eine Kamera und diverse Software,mit der sich meine anderen kollegen beschäftigen werden Tags in LabView geschrieben und diese später der SPS als Signale ausgegeben.Das Problem besteht nun darin,das diese Signale nur als Merker an die SPS gegeben werden können.
    Meine Ablaufsteurung ist aber mit Eingängen (Inputs 0.....)versehn.
    Wie kann ich diese Inputs in Merker umwandeln.Bitte um schnelle Antwort!

    Danke schonmal im voraus!

    Gruß Marco
    Ganz einfach in der SPS mit Laden und Transferieren, oder nicht? (S7 200, ich hab keine Ahnung)

  4. #3
    Registriert seit
    20.10.2003
    Ort
    Biberach
    Beiträge
    5.068
    Danke
    959
    Erhielt 1.457 Danke für 922 Beiträge

    Standard

    Hallo,

    wie ist den die Anbindung zwischen LabVIEW
    und der S7-200 realisert?

    Ist die LabVIEW-Applikation "fertig" oder können
    Sie dort Änderungen vornehmen?

    Muss es über LabVIEW gehen oder könnte es
    sinnvoll sein, von der Kamerasoftware direkt
    mit der S7-200 zu kommunizieren (über Libnodave,
    AGLink oder ähnlichem)?

    Viele Grüße

    Gerhard Bäurle
    Beste Grüße Gerhard Bäurle
    _________________________________________________________________
    Hardware: the parts of a computer that can be kicked. – Jeff Pesis

  5. #4
    Dogma Gast

    Böse

    Nein das VI ist quasi fertig.Über LabView kann man den Process dann auch simulieren,jedoch wenn wir den Process über SPS laufen lassen,muss Labview mit der SPS kommunizieren.Das geht halt nur über Merker.Deshalb muss ich die Eingänge die ich jetzt schon in dei Ablaufsteuerung eingebaut habe als Merker transferieren.Aber wie mach ich das??
    Bitte hleft mir!!

  6. #5
    Registriert seit
    14.01.2004
    Ort
    Hattorf
    Beiträge
    3.201
    Danke
    297
    Erhielt 311 Danke für 266 Beiträge

    Standard

    Hallo,
    lade die Eingangsworte in die Merkerworte.
    so etwa:
    LD SM0.0
    MOVW EW0, MW0
    mfg

    dietmar

    Nichts ist so beständig wie ein Provisorium.

  7. #6
    Dogma Gast

    Unglücklich

    Sorry ,muss nochmal nerven.Bin echt noch nicht so konform in der S7 Programmierung.Was meinst du mit Eingangsworte in Merkerworte.Was muss ich genau machen.Hab auf KOP programmiert.AWL kenn ich nich so.Bitte gebt mir noch nen Tip,wie ich die Eingänge in Merker konvertioeren kann.

    Danke schonma!

  8. #7
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.725
    Danke
    314
    Erhielt 1.519 Danke für 1.282 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Eigentlich ganz einfach,
    das sogenannte PAE wird von der SPS unmittelbar vor dem Zyklusbeginn eingelesen,
    und nur einmalig.
    Das hat zu Folge das der Wert des entsprechenden Eingangsbits aktiv im Programme beeinflusst werden kann.

    Wenn du jetzt z.B. schreibst:
    LD SM0.0
    = I0.0

    Dann wird I0.0 immer den Zustand High führen, unabhängig vom entsprechenden
    Hardware-Eingang.

    So kannst du auch mit deinem Lab-View Merkern verfahren.

    LD LabViewMerker_Maschine_Läuft
    = Eingang Maschine_Läuft

    Mfg
    Manuel
    Geändert von MSB (11.05.2006 um 08:48 Uhr)
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

Ähnliche Themen

  1. Labview und OPC
    Von Nais im Forum Hochsprachen - OPC
    Antworten: 5
    Letzter Beitrag: 02.12.2007, 15:38
  2. LabView mit RS-232
    Von da_kine im Forum Sonstige Steuerungen
    Antworten: 8
    Letzter Beitrag: 20.03.2007, 16:47
  3. Labview mit SPS
    Von hakan im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 20.07.2006, 11:04
  4. LabView
    Von drfunfrock im Forum Stammtisch
    Antworten: 0
    Letzter Beitrag: 13.05.2006, 23:49
  5. CPU-222 und LabView?
    Von papabär im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 25.04.2004, 19:00

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •