Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 8 von 8

Thema: Peripherie-Zugriffsfehler nach Austausch Profibus Teilnehmer

  1. #1
    Registriert seit
    25.09.2014
    Beiträge
    28
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Sehr geehrtes Forum,

    wir haben heute an einer NCU einen Profibusteilnehmer (Messrechner) ausgetauscht.

    6ES7 315-2AF03-0AB0 V1.2

    Der alte Messrechner hatte eine Hilscher CIF30 Karte verbaut.
    der neue Messrechner Hilscher CIF90 Karte. (HIL_0B69.GSD)

    Im Projekt die alte GSD Datei gelöscht und die neue eingefügt.
    Profibusadresse und die Adressbereiche sind gleigeblieben.

    Seitdem haben wir einen Peripherie-Zugriffsfehler lesend-schreibend.

    kann es sein das der NCU nicht mit neuen Karte arbeiten kann?

    Zu Testzwecken haben wir den neuen Messrechner mal an eine 317 CPU gehängt, da hat alles auf Anhieb geklappt.


    Danke

    Viele Grüße Sven
    Zitieren Zitieren Peripherie-Zugriffsfehler nach Austausch Profibus Teilnehmer  

  2. #2
    Registriert seit
    29.03.2004
    Beiträge
    5.741
    Danke
    143
    Erhielt 1.687 Danke für 1.226 Beiträge

    Standard

    Was sagt denn die Step 7 Teilnehmerdiagnose?

  3. #3
    Bonsai32 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    25.09.2014
    Beiträge
    28
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Die Teilnehmer Diagnose ist OK...Baugruppe vorhanden und OK

  4. #4
    Registriert seit
    29.03.2004
    Beiträge
    5.741
    Danke
    143
    Erhielt 1.687 Danke für 1.226 Beiträge

    Standard

    Was meinst du denn mit "GSD Datei gelöscht"?
    Ich hätte jetzt gesagt/gemacht, die neue GSD Datei in der HW-Konfig importieren, Slave löschen und neu anlegen. Und dann HW-Konfig in die SPS laden.

  5. #5
    Bonsai32 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    25.09.2014
    Beiträge
    28
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Da hab ich mich etwas unglücklich ausgedrückt, da es bei einer anderen CPU klappt...können wir ja eigentlich nichts falsch gemacht haben.

  6. #6
    Registriert seit
    29.03.2004
    Beiträge
    5.741
    Danke
    143
    Erhielt 1.687 Danke für 1.226 Beiträge

    Standard

    Vielleicht ist etwas an den Einstellungen der Konsistenz nicht ganz richtig, und auch bei der anderen Test-CPU anders eingestellt.
    Bei Peripheriezugriffsfehler werdet ihr ja mit PEW/PAW auf die Adressen zugreifen. Du könntest es mal stattdessen mit den passenden SFCs konsistent lesen/schreiben, vielleicht geben diese dann über den Statusausgang noch mehr Details zu einem Fehler heraus.
    Du kannst aber nur etweder oder, also entweder alles über PEW/PAW, oder alles über die SFCs.

  7. #7
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.197
    Danke
    926
    Erhielt 3.292 Danke für 2.661 Beiträge

    Standard

    Zitat Zitat von Bonsai32 Beitrag anzeigen
    Profibusadresse und die Adressbereiche sind gleigeblieben.

    Seitdem haben wir einen Peripherie-Zugriffsfehler lesend-schreibend.
    Die Diagnosemeldungen verraten doch sicher auch noch Details, z.B. die Adressen auf die das Programm zugreifen will. Zu welchem DP-Teilnehmer gehören die Zugriffsfehler-Adressen? Das ist vielleicht garnicht der neue Teilnehmer. Kommen die Zugriffsfehler aus dem Programm oder von der Prozessabbild-Aktualisierung?

    Überprüfe nochmal penibelst die Konfiguration des betroffenen DP-Teilnehmers auf Unterschiede zur alten HW Konfig. Sind die Anfangsadressen, die Länge, die E/A-Typen und Modulreihenfolge sowie die Konsistenzen wirklich exakt gleich eingestellt? Hat der Teilnehmer vielleicht Spezial-Einstellungen im Dialog "Parametrieren"? Ist die Diagnoseadresse gleich eingestellt?

    War das Ausgangsprojekt das richtige zur Maschine gehörende Projekt?

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  8. #8
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.626
    Danke
    377
    Erhielt 801 Danke für 642 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ja, ich wurde auch die Einträge in der Diagnosepuffer sorgfältig untersuchen. Eventuell den Diagnosepuffer exportieren und hier posten.

    Eine Idée: Wenn es geklappt hat den ganze HW Konfiguration auf eine ande CPU neu anzulegen und laden, probier mal dasselbe mit der alte 315.

    Es stört mich das der 315er so alt ist. Es kann maximal 1kB E oder A. Sind z.B. Diagnoseadressen von der Hilscher Slave >1023 ?
    Jesper M. Pedersen

Ähnliche Themen

  1. Antworten: 1
    Letzter Beitrag: 16.09.2015, 14:21
  2. Step 7 Peripherie-Zugriffsfehler, lesend
    Von BastiMG im Forum Simatic
    Antworten: 12
    Letzter Beitrag: 24.11.2014, 14:56
  3. Peripherie Zugriffsfehler
    Von hoelle1985 im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 16.07.2013, 11:34
  4. Peripherie-Zugriffsfehler
    Von zloyduh im Forum Simatic
    Antworten: 24
    Letzter Beitrag: 20.08.2012, 14:50
  5. Antworten: 15
    Letzter Beitrag: 28.11.2008, 23:06

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •