Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 2 ErsteErste 12
Ergebnis 11 bis 13 von 13

Thema: DB im Projekt und Online nicht sichtbar bzw. nicht vorhanden ?!?

  1. #11
    spqr76 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    12.09.2006
    Beiträge
    125
    Danke
    26
    Erhielt 4 Danke für 4 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hier nochmal eine kopie aus dem Programm :

    Netzwerk 9 : Fehler während OB100 Bearbeitung aufgetreten

    L DB7.DBW 128
    L 1
    >I
    SPBN B_ok
    S M 100.1
    T MB 801
    CALL FC 200
    A_68xxxx :=DB168.DBX4.1
    MeldungsType:='M'
    B_ok: L DB7.DBW 130
    L 3
    >I
    SPBN K_ok
    S M 100.1
    T MB 801
    CALL FC 200
    A_68xxxx :=DB168.DBX4.2
    MeldungsType:='M'
    K_ok: L DB7.DBW 132
    L 19 // nur wegen Transline
    >I
    SPBN A_ok
    S M 100.1
    T MB 801
    CALL FC 200
    A_68xxxx :=DB168.DBX0.6
    MeldungsType:='M'
    A_ok: NOP 0

  2. #12
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.197
    Danke
    926
    Erhielt 3.292 Danke für 2.661 Beiträge

    Standard

    Wie ist der Eingangsparameter "A_68xxxx" von FC200/FC220 deklariert?
    Wenn das POINTER oder ANY ist, dann führt der FC-Aufruf selber nicht zu einem Zugriffsfehler. Und innerhalb der FC muß das Programm ja nicht auf die übergebenen Adressen zugreifen (absichtlich oder unabsichtlich).

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  3. Folgender Benutzer sagt Danke zu PN/DP für den nützlichen Beitrag:

    spqr76 (19.10.2015)

  4. #13
    spqr76 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    12.09.2006
    Beiträge
    125
    Danke
    26
    Erhielt 4 Danke für 4 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo PN/DP,
    ja du hast recht der IN Parameter ist vom Typ ANY. Dann scheint das wohl des Rätsels Lösung. Ich nehme das mal so hin obwohl ich es sehr unschön finde so zu programmieren.
    Vielen dank für eure Unterstützung !!

Ähnliche Themen

  1. TIA RecipeExport und Import Bausteine nicht vorhanden
    Von Nick_K im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 12.08.2015, 10:03
  2. Antworten: 1
    Letzter Beitrag: 07.08.2015, 18:16
  3. Antworten: 3
    Letzter Beitrag: 26.03.2014, 18:31
  4. DB online nicht mehr sichtbar!
    Von klauserl im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 28.09.2009, 10:39
  5. Antworten: 0
    Letzter Beitrag: 30.07.2006, 19:37

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •