Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 2 von 2

Thema: Rd_sinfo

  1. #1
    Registriert seit
    08.02.2007
    Ort
    A-2320
    Beiträge
    2.252
    Danke
    244
    Erhielt 332 Danke für 303 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Grüß euch!

    Ich möchte beim Anlauf eines AG's Initialwerte setzen.
    Dazu verwende ich (wie das eigentlich beim PCS7 so üblich ist) den SFC "RD_SINFO".

    Leider klappt das nicht, weil..

    Code:
          CALL  "RD_SINFO"
           RET_VAL    :=#RETVAL
           TOP_SI     :=#TOP_SI
           START_UP_SI:=#START_UP_SI
    
          L     #TOP_SI.NUM
          UD    DW#16#FF
          L     100
          ==I   
          S     M    100.0 //also hier käme dann der SPB hin wo ich die Initialwerte setze
    ... nach einem Neustart (von PLCSIM) der M100.0 nicht true wird, was er aber nach meinem Wunsch machen sollte.

    Ideen?

    Gruß
    Karl
    Zitieren Zitieren Rd_sinfo  

  2. #2
    borromeus ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    08.02.2007
    Ort
    A-2320
    Beiträge
    2.252
    Danke
    244
    Erhielt 332 Danke für 303 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ich habe den "Fehler" schon gefunden.
    Natürlich muss man bei dem Baustein auch in der S7_tasklist den OB100 hineinschreiben, sonst wird er dort nicht aufgerufen.
    Anfängerfehler!

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •