Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 7 von 7

Thema: Kommunikation PG <-> CP343-1 Adv <-> CPU315 <-> FU

  1. #1
    Registriert seit
    14.10.2014
    Beiträge
    13
    Danke
    6
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Irgendwie komme ich nicht weiter und frage mich, ob das was ich machen will überhaupt funktioniert.
    Ich habe folgenden Testaufbau:
    Eine CPU315F 2PN/DP mit einem CP343-1 Advanced. An einem Ethernet-Port der CPU ist ein Lenze Umrichter (9400) über Profinet angeschlossen. An dem CP hängen zum Beispiel HMIs.

    Meine Frage ist, besteht die Möglichkeit auf den FU mit der Umrichter-Konfigurationssoftware zuzugreifen, wenn man sich an einen Port am CP hängt.

    In einer Anlage haben wir SEW FUs an einem Profibus CP (443-5 Ext) mit 417er CPU. Auf die kann man mit der SEW Software zugreifen, wenn man in NetPro ein PG dafür konfiguriert. Das PG ist über Ethernet mit der 400er CPU verbunden, an der der CP angeschlossen ist. Dann geht man in die HW-Konfig, Rechtsklick auf den jeweiligen Umrichter und dann "Device Tool starten". So kommt man mit der SEW Software auf die FUs.
    Mit meinem Aufbau habe ich das nicht hinbekommen. Ich frage mich an welcher Komponente das liegt, sprich CP oder FU oder Profinet oder FU-Konfigurationssoftware oder dem Typ, der vor dem PG sitzt, etc.

    Ich habe schon mal probiert den FU an den CP anzuschließen aber dann habe ich gar keine Kommunikation zum FU, nicht mal über Step 7 (weiß nicht ob es evtl. am Treiber vom FU liegt). Deshalb hängt der FU am CPU Ethernet Port. Wenn jemand weiß, dass es nicht geht, wäre eine Quelle praktisch. Dann könnte ich das Kapitel definitiv abschließen.
    Zitieren Zitieren Kommunikation PG <-> CP343-1 Adv <-> CPU315 <-> FU  

  2. #2
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.316
    Danke
    932
    Erhielt 3.331 Danke für 2.689 Beiträge

    Standard

    Das Verfahren nennt sich S7-Routing und die Lenze-Software muß das können/unterstützen. (ich weiß nicht ob/wie Lenze das kann)

    Damit die SPS-CPU von ihrer Routing-Funktion weiß und Routing-Informationen erzeugt werden, muß man in NetPro die CPU und den CP mit 2 verschiedenen Ethernet vernetzen. Für den gerouteten Zugriff von Step7 durch die CPU und CP ist es nützlich, wenn man im Projekt ein PG-Objekt zuordnet.

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  3. #3
    Wurzel2 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    14.10.2014
    Beiträge
    13
    Danke
    6
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Hi, danke für die Antwort.

    Jou, so habe ich das eigentich auch gemacht. Vielleicht ist meine Konfiguration noch irgendwo falsch. Werde mal berichten ob es klappt oder auch nicht.

  4. #4
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.639
    Danke
    377
    Erhielt 803 Danke für 644 Beiträge

    Standard

    Auf Seite 81 in diesen Handbuch ist S7-Routing für Lenze beschrieben:
    http://download.lenze.com/TD/Drive%2...__v1-0__EN.pdf
    Jesper M. Pedersen

  5. #5
    Wurzel2 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    14.10.2014
    Beiträge
    13
    Danke
    6
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Hi, danke für die Antworten und die PDF. Irgendwie kriege ich die Verbindung trotzdem nicht hin. Ich frage mich ob das Step 7 Routing auch bei Profinet mit unterschiedlichen Netzen funktioniert. Falls ich eine Lösung finde, werde ich berichten.

  6. #6
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.639
    Danke
    377
    Erhielt 803 Danke für 644 Beiträge

    Standard

    Ich kenne nur Simatic Starter software für Simatic Drives. Dies kann in ein ähnliche weise wie die Lenze software FU's über Routing erreichen.
    Was wichtig ist wenn Starter nicht in ein STEP7 Projekt integriert ist (entspricht wie die Lenze software funktioniert), dann muss man das Subnet ID manuell einstellen. Das Subnet ID findet man in das STEP7 Projekt.
    Vielleicht liegt es daran ?
    Jesper M. Pedersen

  7. #7
    Wurzel2 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    14.10.2014
    Beiträge
    13
    Danke
    6
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ich werde das mal bei Gelegenheit probieren, danke für den Tipp

Ähnliche Themen

  1. Printronix Barcode Drucker an CP343-1 ADV
    Von Tomcat69 im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 13.10.2015, 14:07
  2. Step 7 CP343-1 mit CPU315-2 DP
    Von rugl90 im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 10.06.2015, 11:26
  3. S7-300 mit CPU315 und CP343-1 betreiben
    Von Nico M im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 06.09.2008, 12:29
  4. Antworten: 3
    Letzter Beitrag: 27.12.2007, 19:26
  5. Antworten: 1
    Letzter Beitrag: 23.01.2006, 15:43

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •