Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 5 von 5

Thema: Problem mit Referenzdaten

  1. #1
    Registriert seit
    01.10.2012
    Beiträge
    203
    Danke
    12
    Erhielt 56 Danke für 36 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,

    ich habe hier ein Projekt in dem Änderungen gemacht werden sollen und ich wollte erstmal in die Referenzdaten schauen, da kommt die Auswahl aktualisieren / neu generieren und wenn ich auf ersteres klicke fängt er an die ganzen Quellen neu zu übersetzen. Das will ich aber nicht. Wenn ich bei der Auswahl auf NEIN klicke komme ich zwar in die Refrenzdaten, aber da kann ja dann Zeugs fehlen.
    Ich habe noch eine zweite ähnliche Anlage derselben Firma und bei dem Projekt passiert das nicht.

    Ist das ein Fehler im Projekt? Gibts da irgendwelche Erfahrungen?
    Der Bausteinvergleich zeigt an das alles schick ist und ich habe Bauchschmerzen das ganze Projekt neu zu kompilieren, da sind ne Menge riesiger Multiinstanzen usw. drinn.

    Step 7 V5.5

    MfG
    Nüchtern betrachtet war es besoffen besser.
    Zitieren Zitieren Problem mit Referenzdaten  

  2. #2
    Registriert seit
    12.12.2013
    Ort
    Kaiserslautern
    Beiträge
    1.353
    Danke
    393
    Erhielt 221 Danke für 175 Beiträge

    Standard

    Sind da selbst geschriebene SCL Quellen ?.
    Wenn nicht, dann lösche sie doch alle einfach und probier's dann noch mal.

    Vorher immer Programmsicherung machen !!

    Bram
    Wenn es nicht auf STRAVA ist, ist es nicht passiert !!

  3. #3
    Bapho ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    01.10.2012
    Beiträge
    203
    Danke
    12
    Erhielt 56 Danke für 36 Beiträge

    Standard

    Danke
    Auf die Idee bin ich garnicht gekommen.
    Ich habe im Projekt ein neues S7 Programm erstellt und da die Quellen hinkopiert, danach habe ich die im normalen Programm gelöscht und die Referenzdaten aufgerufen. Da hats dann ne Weile gedauert und ich hatte aktualisierte Referenzen. Dann die Quellen wieder zurück kopiert und alles wieder in Butter.

    Ich denke mal das ist ein Siemens Bug.
    Nüchtern betrachtet war es besoffen besser.

  4. #4
    Registriert seit
    29.03.2004
    Beiträge
    5.792
    Danke
    144
    Erhielt 1.706 Danke für 1.238 Beiträge

    Standard

    Nur kannst dann die SCL Quellen nicht mehr online beobachten, und du weißt genauso wenig ob sich am Code etwas geändert hat. Du verschiebst das Problem nur nach hinten.

    Überprüfe mal im SCL-Editor, ob die Option "Referenzdaten erzeugen" gesetzt ist. Ich setze mittlerweile alle Übersetzungsoptionen in jeder SCL-Quelldatei (für das Generieren der Referenzdaten z.B. SCL_GenerateReferenceData :='y').

    Aber es kommt trotzdem schon mal vor, dass Step7 die Referenzdaten neu erzeugen will.
    Wenn Step7 anmeckert, die Referenzdaten seien nicht aktuell, kann dafür auch ein AWL-Baustein verantwortlich sein. Dort gibt es aber nur die Option, die Referenzdaten beim neuen Anlegen des Bausteins zu erzeugen. Eigentlich sollte Step7 das dann bei jeder Änderung machen, aber ich vermute auch da hakt es etwas.

  5. #5
    Bapho ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    01.10.2012
    Beiträge
    203
    Danke
    12
    Erhielt 56 Danke für 36 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Da hast du sicher Recht, nur ist das Projekt von einem Anlagenhersteller, die sind sehr kulant und sind auch froh wenn wir selber Änderungen durchführen. Ich habe also ein Projekt das komplett symbolisch in SCL programmiert ist, mit einer Visu oben drauf die in Delphi bzw. dem Nachfolger geschrieben ist und einem selber gestrickten OPC Server inkl. einer Embarcado Datenbank.
    Wenn die ganze Geschichte auf meinem Mist gewachsen wäre, würde ich das neu reinprügeln, aber das leider nicht an dem ist und da massig verschachtelte Multiinstanzen im Spiel sind habe ich da Bauchschmerzen. Zumal der OPC ja mit absoluten Adressen hantiert und wenn ich das nicht selber verbrochen habe...

    Ich habe das erstmal so gelöst und den Hersteller informiert. So läuft das erstmal und wir schauen mal weiter.

    Trotzdem Danke für die Infos.
    Nüchtern betrachtet war es besoffen besser.

Ähnliche Themen

  1. Problem mit Referenzdaten
    Von 1984 im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 21.01.2012, 09:50
  2. Referenzdaten Online???????????????
    Von hbedir im Forum Simatic
    Antworten: 15
    Letzter Beitrag: 15.01.2011, 13:23
  3. Frage zu Referenzdaten
    Von webholle im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 11.11.2008, 08:34
  4. Referenzdaten bei S7
    Von AUDSUPERUSER im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 25.04.2008, 16:23
  5. SCL-Referenzdaten
    Von Onkel Dagobert im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 26.03.2004, 00:08

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •