Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 6 von 6

Thema: Eigenartige HW konfiguration an eine alten S7-400

  1. #1
    Registriert seit
    18.04.2005
    Ort
    Fast an der Schweiz
    Beiträge
    856
    Danke
    208
    Erhielt 108 Danke für 76 Beiträge

    Frage


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ich bin gerade dran eine Anlage umzurüsten. Es werden 4 ET200s Module hinzugefügt.
    Die 400er ist schon sehr alt (>=10 Jahre) muss bemerkt werden.
    Irgendwie finde ich es komisch, dass "ein" 8do oder 8di Modul in der ET200s 4 Byte belegt.
    Es ist irgendwie nicht möglich die HW Konfi so zu biegen, dass die Adressen nacheinander liegen
    Siehe screenshot. Es betrifft nur die ET200s Mx.x
    Bemerkung bei einer S7-300 liegen bei der selben HW die Adressen nebeneinander.

    Hat mir jemand eine Idee was das sein könnte ? Mein 400er wissen ist nicht gerade up to date...

    Danke

    Hardware :
    S7-400 : 6ES7-414-2XJ00-0AB0
    ET200s : 6ES7151-1CA00-0AB0
    Modul : 6ES7131-4BF00-0AA0

    S400-001.jpg

    S400-002.jpg
    Code:
     RTFM ! Read The F..ing Manual
    Arbeitet mit : Step7 V5.5 SPx / WinCC Flex 2008 SPx / Intouch / Winmod /TIA V14 (abgestürzt...Zitat der Hotline : "Sie dürfen nicht so viel rumdrücken....." TIA, so isses halt)

    ║▌║█║║▌║█║ Warnung! Falscher oder fehlender Kaffee - Benutzer angehalten --(◔̯◔)--
    1334566890111
    Zitieren Zitieren Eigenartige HW konfiguration an eine alten S7-400  

  2. #2
    Registriert seit
    06.10.2003
    Beiträge
    3.406
    Danke
    448
    Erhielt 502 Danke für 406 Beiträge

    Standard

    Das ist nicht S7400-spezifisch. Auch bei einigen älteren S7300 war es mal üblich, für jeden DI/DO-Steckplatz 32 Bit zu reservieren. Ich denke, es war damals ganz einfach eine Philosophie, um eine Erweiterung auf 16- oder 32-kanalige Baugruppen zu vereinfachen.
    Es gibt viel mehr Leute, die freiwillig aufgeben, als solche, die echt scheitern.
    Henry Ford

  3. Folgender Benutzer sagt Danke zu Onkel Dagobert für den nützlichen Beitrag:

    Waelder (02.01.2016)

  4. #3
    Registriert seit
    19.05.2008
    Beiträge
    648
    Danke
    117
    Erhielt 136 Danke für 105 Beiträge

    Standard

    Zitat Zitat von Onkel Dagobert Beitrag anzeigen
    Auch bei einigen älteren S7300 war es mal üblich, für jeden DI/DO-Steckplatz 32 Bit zu reservieren.
    Ich kenne das von einer alten 300’er so, dass bei 4DI halbe Byte vergeben werden konnten!
    Auf der Baustelle musste für eine Nachrüstung die Hardware erweitert werden.
    Leider ging die Adressvergabe mit dem „aktuellen“ S7 nur noch Byteweise.
    Da konnte ich mir nur mit „Umverdrahten“ helfen.

    Somit sind Lücken die bessere Wahl…

  5. Folgender Benutzer sagt Danke zu Chräshe für den nützlichen Beitrag:

    Waelder (02.01.2016)

  6. #4
    Avatar von Waelder
    Waelder ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    18.04.2005
    Ort
    Fast an der Schweiz
    Beiträge
    856
    Danke
    208
    Erhielt 108 Danke für 76 Beiträge

    Standard

    Ja leute, da habt ihr recht. Auf die Idee bin ich noch gar nicht gekommen.
    Oh jeh... Na ich werde die Ganzen EAs auf einen DB mapppen und so arbeiten.
    Wenn es mich dann Adressmässig nochmal ärgert dann kann ich schneller umverdrahten.
    Der bereich meiner EAs liegt eh auserhalb der direkt ansprechbaren Peripherie.

    Euch beiden Danke und noch ein gutes neues 2016
    Code:
     RTFM ! Read The F..ing Manual
    Arbeitet mit : Step7 V5.5 SPx / WinCC Flex 2008 SPx / Intouch / Winmod /TIA V14 (abgestürzt...Zitat der Hotline : "Sie dürfen nicht so viel rumdrücken....." TIA, so isses halt)

    ║▌║█║║▌║█║ Warnung! Falscher oder fehlender Kaffee - Benutzer angehalten --(◔̯◔)--
    1334566890111

  7. #5
    Registriert seit
    12.04.2005
    Ort
    Black Forest
    Beiträge
    1.335
    Danke
    27
    Erhielt 129 Danke für 116 Beiträge

    Standard

    Da gibts die Option "Adressen Packen" nicht?

    Das ist halt auch aktuell mit den ET200s so, daher gibts die Funktion Adressen packen und dann werden diese zu einem Byte (zB 8 DI-Module mit je 1 Bit) gepackt!


    Habe gerade noch nachgeschaut, https://support.industry.siemens.com...dti=0&lc=de-WW sollte dein Problem lösen ...
    Geändert von Boxy (03.01.2016 um 12:58 Uhr)

    „Eine Frage raubt mir den Verstand bin ich verrückt oder sind es die Anderen ?“

    Albert Einstein

  8. #6
    Registriert seit
    17.07.2009
    Ort
    Am Rande der Ostalb
    Beiträge
    5.476
    Danke
    1.140
    Erhielt 1.238 Danke für 971 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Also wenn du mit Operantenvorrang - Symbolisch arbeitest kannst dir das Mappen sparen.
    Einfach in der Symboltabelle die Adressen ändern und Bausteinkonsistenz prüfen lassen.
    Danach sind allen betroffenen Bausteinen die Adressen geändert.

    Gruß
    Dieter

Ähnliche Themen

  1. Ich suche eine Frontklappe S7 400 schmal
    Von Elektrikus im Forum Suche - Biete
    Antworten: 0
    Letzter Beitrag: 04.07.2014, 16:05
  2. eigenartige Erscheinungen
    Von Johänsen im Forum HMI
    Antworten: 2
    Letzter Beitrag: 24.09.2013, 14:43
  3. Eine Konfiguration für mehrere IPCs, NetID, Netzerkadapter
    Von twincatter im Forum CODESYS und IEC61131
    Antworten: 0
    Letzter Beitrag: 05.07.2013, 15:15
  4. Antworten: 9
    Letzter Beitrag: 19.11.2012, 14:47
  5. Antworten: 0
    Letzter Beitrag: 19.01.2011, 11:51

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •