Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 4 von 4

Thema: Funktionsbausteine und Merker

  1. #1
    Registriert seit
    18.01.2016
    Beiträge
    4
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    ich arbeite an einer einfachen Steuerung für einen Motor. Ich habe im Grundbild der HMI Buttons und E/A Felder angelegt. In der HMI Variablen Tabelle habe ich die Datenbausteine eingefügt und die HMI Variable anschließend mit den E/A Feldern verküpft. Jetzt meine Frage: Kann ich an dieser Stelle auch Merkerwerte einfügen oder MD Werte? Auf dem Screenshot ist ein Merkerwert zu sehen verbunden mit M0.1, dieser wechselt zwischen den Werten 0 und 1. Die 372 steht für einen Befehl der an den Motor gesendet wird. Ich möchte den MW Wert jetzt einfach in die HMI Variablentabelle einfügen, oder muss ich diesen erst einem Datenbaustein zuweisen? Mehr ist in diesem Funktionsbaustein nicht hinterlegt, er wird anschließend im OB1 aufgerufen.

    Gruß
    Geändert von StartCL (20.01.2016 um 12:11 Uhr)
    Zitieren Zitieren Funktionsbausteine und Merker  

  2. #2
    Registriert seit
    22.11.2006
    Ort
    CH
    Beiträge
    3.636
    Danke
    786
    Erhielt 654 Danke für 497 Beiträge

    Standard

    Du kannst aus der HMI auch auf Merker, Peripherie etc zugreifen. Ob es noch sinn macht mit Merkern zu arbeiten ist aber eher fraglich. Müllt einem halt nur die Symbolliste zu.

    mfG René

  3. #3
    StartCL ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    18.01.2016
    Beiträge
    4
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    danke, wie könnte ich das alternativ schreiben? Den Motor habe ich mit Starter konfiguriert, Erreichbare Teilnehmer gesucht, mich online verbunden, automatische Konfiguration gewählt und die Telegramme ausgewählt. Gewählt habe ich ein freies Telegramm E-Adressen 256 ... 271 (so stehts in TIA bei Geräte und Netze der CU). Dann gespeichert und "Laden ins Zielgerät" angeklickt. Sonst habe ich nichts gemacht mit Starter. Erklärt es mir bitte Schritt für Schritt, bin leider kein Profi im SPS programmieren.

    In meinem freien Telegramm gibt es bei dem Punkt 10 - p854 Führung durch PLC (im Starter bei Telegrammkonfiguration - Verschaltung/Diagnose). Ist es denn richtig dass mit den %IW Befehlen die Telegramm Befehle an Merker übergeben werden? Das würde doch heißen dass die Telegramm Befehle in der PCU gespeichert werden und so dann der Motor angesteuert wird. Bin leider noch Anfänger.


    Gruß
    Geändert von StartCL (18.01.2016 um 13:02 Uhr)

  4. #4
    Registriert seit
    30.08.2010
    Ort
    Östereich
    Beiträge
    1.470
    Danke
    506
    Erhielt 218 Danke für 193 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Dein M0.1 ist wahrscheinlich in der HW Config als Taktmerker deklariert darum springt der immer.

    Nimm mal einen anderen Merker, alternativ ein Bit in einem DB.

    Empfehlenswert ist auch in der HMI ein bei Tastendruck zu setzen und am Ende des Zyklus in der SPS rückzusetzen.
    Elektrotechnik und Elektronik funktioniert mit Rauch (Beweis: Tritt Rauch aus, funktioniert auch das Bauteil nicht mehr)

Ähnliche Themen

  1. Antworten: 6
    Letzter Beitrag: 29.01.2014, 19:53
  2. Instanzen und drei Funktionsbausteine
    Von Stefan31 im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 17.04.2012, 00:16
  3. Merker und speicherplatz
    Von hank12 im Forum Simatic
    Antworten: 12
    Letzter Beitrag: 14.05.2008, 13:08
  4. Merker gleichzeitig 1 und 0
    Von dresel im Forum Simatic
    Antworten: 15
    Letzter Beitrag: 04.04.2008, 19:15
  5. MW und Merker
    Von waldy im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 01.02.2004, 17:12

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •