Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 4 ErsteErste 1234 LetzteLetzte
Ergebnis 11 bis 20 von 31

Thema: Indirekte Adressierung Fehler

  1. #11
    Registriert seit
    05.06.2012
    Beiträge
    64
    Danke
    13
    Erhielt 10 Danke für 10 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ah, OK. Jetzt verstehe ich das auch, dann ziehe ich meinem vorherigen Beitrag zurück

  2. #12
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.189
    Danke
    923
    Erhielt 3.292 Danke für 2.661 Beiträge

    Standard

    Zitat Zitat von Gh0st90 Beitrag anzeigen
    Kann ich mir den Wert irgendwie anzeigen lassen?
    Es ist empfehlenswert, wenn Du beim Beobachten des AWL-Codes die Spalte "Adressregister 1" einblendest (Rechtsmausklick in die Beobachtungsspalten), evtl. auch "DB-Register 1" und ggf. weitere Spalten.

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  3. #13
    Gh0st90 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    18.01.2016
    Beiträge
    6
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo,

    danke für die Antworten. Der gesamte Code sieht so aus:

    NW1:
    L #Koppel_DBNR // Nummer des Koppel DB
    T #Koppel_DB
    AUF DB [#Koppel_DB] // Koppel DB aufrufen
    // Taktimpuls bilden
    U #Takt_1s
    FP DBX 314.1 // Flankenhilfsbit
    = DBX 314.0 // Taktimpuls in Koppel DB

    NW2:

    LAR1 P##Ziel
    L W#16#1002
    T W [AR1,P#0.0]


    Im AR1 steht die 16.0.

    Der Fehler lautet weiterhin:

    Bereichsfehler beim Schreiben
    Falsche Bereichskennung: 86
    FC-Nummer: 68
    Bausteinadresse: 34
    Angeforderter OB: Programmierfehler-OB (OB 121)
    Prioritätsklasse: 1
    interner Fehler, kommendes Ereignis

  4. #14
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.222
    Danke
    533
    Erhielt 2.698 Danke für 1.950 Beiträge

    Standard

    Hast du es mal so versucht?

    LAR1 P##Ziel
    L W#16#1002
    T LW [AR1,P#0.0]
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  5. #15
    Registriert seit
    11.05.2005
    Ort
    Baden-Württemberg
    Beiträge
    669
    Danke
    113
    Erhielt 153 Danke für 124 Beiträge

    Standard

    der Pointer steht doch schon auf Lokaldaten, oder?
    Ich denke, er will in einen DB kopieren, und der Fehler tritt auf, weil der Lokaldatenbereich des FC68 kleiner 18 Byte ist..
    "arbeite klug, nicht hart" - deutsches Sprichwort

  6. #16
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.222
    Danke
    533
    Erhielt 2.698 Danke für 1.950 Beiträge

    Standard

    @SPSKILLER
    Dachte ich auch zuerst, aber er hat das noch einmal hier #6 präzisiert.

    Wenn #Ziel also im Temp-Bereich liegt, dann kann man es zumindest mal mit LW testen.
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  7. Folgender Benutzer sagt Danke zu Ralle für den nützlichen Beitrag:

    SPSKILLER (19.01.2016)

  8. #17
    Registriert seit
    24.10.2007
    Ort
    Niederlande
    Beiträge
    673
    Danke
    22
    Erhielt 143 Danke für 135 Beiträge

    Standard

    Im AR1 steht die 16.0.
    Normal solte da L 16.0 stehn.

    LAR1.JPG

  9. #18
    Registriert seit
    11.05.2005
    Ort
    Baden-Württemberg
    Beiträge
    669
    Danke
    113
    Erhielt 153 Danke für 124 Beiträge

    Standard

    @Ralle

    danke, hatte ich überlesen.
    Es soll wohl ein Anypointer zusammengebaut werden...
    Der Fehler ist umso seltsamer.
    "arbeite klug, nicht hart" - deutsches Sprichwort

  10. #19
    Gh0st90 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    18.01.2016
    Beiträge
    6
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Zitat Zitat von Ralle Beitrag anzeigen
    Hast du es mal so versucht?

    LAR1 P##Ziel
    L W#16#1002
    T LW [AR1,P#0.0]
    Hallo,

    mit dem LW tritt der Fehler nicht auf. Aber wieso? Wo liegt der Unterschied?



    EDIT:
    Noch ein für mich nicht verständliches Problem. In einer 319-F funktioniert das Programm auch ohne LW. Warum in der 400er nur mit LW?

    Ist es von der Funktion überhaupt noch das selbe mit LW?
    Geändert von Gh0st90 (19.01.2016 um 13:32 Uhr)

  11. #20
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.222
    Danke
    533
    Erhielt 2.698 Danke für 1.950 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zwischen 300-er und 400-er gibt es definitiv ein paar Unterschiede, die beim "normaloprogrammieren" eher nicht zum tragen kommen. So hat die 400-er z.B. 4 Akkus, die 300-er 2.
    Damit hatte ich bisher noch nie ein Problem, aber hier könnte schon etwas anders laufen, wenn man indirekt adressiert etc. Vielleicht gibts ja im Forum ein paar 400-er-Kenner, da gehöre ich nicht unbedingt zu denen, die hier tiefer gehen könnten.
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

Ähnliche Themen

  1. Step 7 Indirekte Adressierung
    Von firefox711 im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 16.05.2013, 07:55
  2. Indirekte Adressierung
    Von Christian1984 im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 18.02.2012, 16:31
  3. Indirekte Adressierung
    Von PapaLeo im Forum Simatic
    Antworten: 19
    Letzter Beitrag: 11.05.2009, 17:52
  4. indirekte Adressierung
    Von Linowitch im Forum HMI
    Antworten: 13
    Letzter Beitrag: 06.12.2008, 19:43
  5. Indirekte Adressierung
    Von wusel220983 im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 18.05.2007, 18:19

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •