Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 13

Thema: Siemens Field PG M4 PG/PC Schnittstelle umschalten merkwürdiges verhalten

  1. #1
    Registriert seit
    12.09.2006
    Beiträge
    125
    Danke
    26
    Erhielt 4 Danke für 4 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo ,
    Ich nutze ein Simatic Field PG M4. Windows 7 Ultiamte 64 bit, Simatic Manager V5.5 SP3. Im Gerät sind zwei Netzwerkadapter. Intel(R)82579LM und Intel(R)82579L. Soweit so gut. Wenn ich nun ein Netzwerkkabel in die Intel(R)82579LM stecke ( IP etc sind richtig eingestellt ), sehe ich im Windows unter Netzwerkverbindungen das ein Kabel gesteckt ist. Bei der Intel(R)82579L sieht man Netzwerkkabel gezogen. Im Simatic Manager wähle ich dann die Schnittstelle Intel(R)82579LM Gigabit Network Connection .TCPIP ( kein TCPIP auto ). Und komme nicht Online. Wähle ich dann die Intel(R)82579L im Simatic Manager aus funktioniert die Verbindung. Obwohl auf der Intel(R)82579L eine ganz andere IP Adresse eingestellt ist. Ok dachte ich mir und hab mir das PG von meinem Kollegen geholt auch ein Field PG M4. Und siehe da genau das selbe verhalten wie bei mir. Dann habe ich die Netzwerkkarten deinstalliert neu gestartet und wieder getestet selbes verhalten, keine Änderung. Dann habe ich spass halber den W-Lan adapter im Simatic Manager ausgewählt und bin auch Online gekommen, obwohl an meiner CPU kein W-Lan existiert. D.h. irgendwie schaltet die Schnittstelle nicht um. Obwohl man im Simatic Manager sieht das eine andere Schnittstelle gewählt wurde. Diesen Test habe ich an drei verschiedenen Siemens Field PG M4 durchgeführt immer mit dem selben Ergebnis. Mich würde nun interessieren ob dieses Phänomen bekannt ist bzw. kann man das korrigieren. Das führt oft zur Verwirrungen und Problemen beim Fehler suchen. Ich bin gestern zum ersten mal darüber gestolpert. Ist entweder vorher noch nicht gewesen oder es ist mir nicht aufgefallen. Für Tips Lösungen oder Erklärungen wäre ich sehr dankbar.
    Zitieren Zitieren Siemens Field PG M4 PG/PC Schnittstelle umschalten merkwürdiges verhalten  

  2. #2
    Registriert seit
    04.10.2010
    Beiträge
    166
    Danke
    45
    Erhielt 34 Danke für 27 Beiträge

    Standard

    Hallo,

    ja das Phänomen hab ich bei meinem Field PG auch schon festgestellt... Ist aber nur im Simatic Manager der Fall. In Tia funktioniert alles wie es soll.

    Über eine Lösung oder Erklärung hab ich mir noch keine Gedanken gemacht, da ich hauptsächlich nur noch Tia verwende.

    Gruß, Micha

  3. #3
    Registriert seit
    15.10.2014
    Beiträge
    92
    Danke
    16
    Erhielt 18 Danke für 15 Beiträge

    Standard

    Ich vermute das liegt am Netzwerkcontroller/Chip. Es sind zwar 2 Schnittstellen allerdings laufen beide über einen Chip.

    Ich habe dieses "Problem" auch, bin aber ganz froh darüber. Als PG Schnittstelle habe ich die LAN Schnittstelle eingestellt.
    Bin ich im Büro und der Laptop steht im Dock komme ich über die LAN Schnittstelle online. Nehm ich den Laptop nun aber aus dem Dock, W-Lan schaltet sich automatisch ein, und geh online verbindet sich S7 auch mit der SPS ohne das ich die Schnittstelle umstelle.

    Stefan

  4. #4
    Registriert seit
    16.03.2006
    Ort
    Franken
    Beiträge
    3.843
    Danke
    30
    Erhielt 942 Danke für 819 Beiträge

    Standard

    Hi,

    schau mal unter PG/PC Schnittstelle einstellen ob an einem der Adapter ein kleines gelbes Ausrufezeichen zu sehen ist.

    Gruß
    Christoph

  5. #5
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.313
    Danke
    932
    Erhielt 3.323 Danke für 2.685 Beiträge

    Standard

    Bei TCP/IP ist es egal, welcher Adapter in PG/PC-Schnittstelle eingestellt ist. Die Auswahl des richtigen Adapters wird von Windows gesteuert (welcher Adapter ist aktiv, welche Routingregeln). Es kann allerdings Probleme geben, wenn mehr als 1 LAN-Adapter aktiv ist - das sollte Windows 7 aber im Griff haben.

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  6. Folgender Benutzer sagt Danke zu PN/DP für den nützlichen Beitrag:

    spqr76 (09.02.2016)

  7. #6
    spqr76 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    12.09.2006
    Beiträge
    125
    Danke
    26
    Erhielt 4 Danke für 4 Beiträge

    Standard

    Hallo Christoph,
    nein gelbe Ausrufezeichen sind nicht zu sehen .

    @Harald das wäre für mich ja ok. Aber es funktioniert ja nicht der aktive Adapter sonerdn der wo Netzwerkkabel gezogen angezeigt wird.

  8. #7
    Registriert seit
    09.11.2006
    Beiträge
    693
    Danke
    36
    Erhielt 31 Danke für 29 Beiträge

    Standard

    Das Verhalten habe ich beim M2 auch schon gehabt. Ich habe dann halt immer WLAN deaktiviert wenn ich es nicht benötige. Du kannst aber mal probieren die Reihenfolge der Netzwerkadapter in der Systemsteuerung zu ändern.
    Zeige nie deine Verblüffung, wenn dir etwas auf Anhieb gelingt.

    Praxis: Es funktioniert aber keiner weiß warum!

  9. #8
    spqr76 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    12.09.2006
    Beiträge
    125
    Danke
    26
    Erhielt 4 Danke für 4 Beiträge

    Standard

    Hallo ,
    nach Rücksprache mit dem Siemens Support habe ich das SP4 erhalten was aber keine Änderung gebracht hat. Es ist so wie von Harald beschrieben :
    Zitat :
    Bei TCP/IP ist es egal, welcher Adapter in PG/PC-Schnittstelle eingestellt ist. Die Auswahl des richtigen Adapters wird von Windows gesteuert (welcher Adapter ist aktiv, welche Routingregeln). Es kann allerdings Probleme geben, wenn mehr als 1 LAN-Adapter aktiv ist - das sollte Windows 7 aber im Griff haben.

    Harald

    Was ich dazu noch herraus finden konnte ist das dieses verhalten dann auftritt wenn meine IP Einstellung zur CPU passt und ich dann im Simatic Manager die Schnittstelle ändern möchte . Dann ist es egal welche Schnittstelle ich auswähle man kommt Online. Wenn meine IP nicht zur CPU passt und ich sie erst ändere nachdem ich versucht habe Online zu kommen , habe ich dieses verhalten nicht.

  10. #9
    Registriert seit
    16.06.2010
    Beiträge
    11
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo,

    wir haben auch Probleme mit TCP/IP Schnittstellen Einstellung an unseren 300er PN CPUs, mit Step 7 Classic.
    Bei der Inbetriebnahme wird sich über LAN-Kabel oder WLAN-Router mit der Maschine verbunden. Bislang haben wir auch immer brav die richtige Schnittstelle im S7 eingestellt.

    Soweit funktioniert auch alles. Wenn ich jetzt aber gleichzeitig mit der Maschine (LAN) und unserem Firmennetzwerk (WLAN) verbunden bin, wird es sehr problematisch.
    Da eigentlich immer eine Kundenanlage über VPN (Scalance S612) mit unserem Firmennetzwerk verbunden ist, kann es sehr schnell passieren, das man mit der falschen Anlage verbunden ist!

    Da kann auch kein Windows etwas "im Griff haben". Das weiss nämlich nicht in welches Netzwerk ich möchte. Es gibt dann einfach in beiden Netzwerken eine CPU mit der selben IP-Adresse. Es ist dann Glücksache zu welcher man verbunden wird.


    Wozu kann ich denn überhaupt verschiedene TCP/IP-Adapter in S7 auswählen?

    Es sollte doch möglich sein, das Step 7 nur auf den entsprechenden Adapter zugreift. Oder stelle ich es mir zu einfach vor, mit meinem gefährlichem Netzwerk-Halbwissen?

  11. #10
    Registriert seit
    16.06.2010
    Beiträge
    11
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Kann jemand bestätigen, das das gleiche Szenario mit dem TIA-Portal funktioniert?

    Gesendet von meinem LG-D855 mit Tapatalk

Ähnliche Themen

  1. Antworten: 4
    Letzter Beitrag: 30.11.2015, 09:40
  2. TIA merkwürdiges(?) Verhalten Schnittstelle OUT
    Von Lockenfrosch im Forum Simatic
    Antworten: 31
    Letzter Beitrag: 09.04.2015, 12:45
  3. Antworten: 1
    Letzter Beitrag: 01.04.2014, 20:12
  4. Antworten: 4
    Letzter Beitrag: 11.01.2010, 09:39
  5. Antworten: 2
    Letzter Beitrag: 21.12.2005, 14:29

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •