Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 9 von 9

Thema: Siemens LOGO! 0BA8 Kommunikation mit KP 300 Basic

  1. #1
    Registriert seit
    24.01.2016
    Beiträge
    4
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Ausrufezeichen


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    ich hab hier zwei Probleme bei denen ich nicht weiterkomme.

    Ich habe als Aufbau eine LOGO! 0BA8 und ein Siemens KP 300 Basic MONO HMI.

    Dieses habe ich im TIAP Parametriert und die Bilder erstellt, kommunikation mit LOGO geht auch, LOGO Programm ist auch soweit durch nur ich bekomme die Analogwertverarbeitung nicht in den Griff.

    Ich muss am KP ein Feld haben bei der ich eine Startfrequenz vorgebe, welche dann als Wert ins LOGO übertragen wird, um damit die Berechnung für die Grenzwerte der
    manuellen Nachjustierung per Tasten begrenzen kann damit mir meine Motore nicht zu hoch / Zu niedrig gestellt werden können um die Anlage nicht zu überreizen.

    Habe bisher keine Möglichkeit gefunden wie ich den Wert in die LOGO bekomme um ihn da zu verwursten.

    Die nächste Frage:

    Ich habe zusätzlich noch einen 04-20mA Eingang auf welchem ein Sensor verschalten ist.

    Dieser Wert muss eingelesen werden um dann je nach definiertem Delta die Frequenz hinauf oder hinunter regelt bis die Werte vom Sensor wieder im Eingegebenen Bereich (Eingabefeld) sind. Habs mit Analogkomperator versucht, bin da allerdings nicht wirklich erfolgreich gewesen. (Abgesehen davon dass ich den Wert genauso wie oben beschreiben nicht ins LOGO! bekomme.)

    Kann gerne das Programm / TIA Projekt per mail zukommen lassen für den Fall dass sich jemand dieses Verbrechen ansehen möchte

    Bin für jede Hilfe sehr dankbar da mir langsam aber sicher die Zeit ausgeht.
    Wurde verkauft mit der Aussage "wird schon irgendwie gehen".

    Vielen Dank im Vorraus
    Zitieren Zitieren Siemens LOGO! 0BA8 Kommunikation mit KP 300 Basic  

  2. #2
    Registriert seit
    02.01.2015
    Beiträge
    527
    Danke
    96
    Erhielt 109 Danke für 104 Beiträge

    Standard

    Nimm doch den PI-Regler.

    Auf dieser Siemens Seite gibt es Anwendungsbeispiele für Kommunikation zum HMI und auch für den PI-Regler.

    Anwendungsbeispiele

  3. Folgender Benutzer sagt Danke zu GUNSAMS für den nützlichen Beitrag:

    Luckyarrow (24.01.2016)

  4. #3
    Luckyarrow ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    24.01.2016
    Beiträge
    4
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Danke,

    ich hatte mich schon durch die Anwendungsbeispiele auf der SIEMENS-Seite gewühlt, alle Runtergeladen und angeschaut aber wie gesagt nix genau passendes Gefunden

    Das Ausgeben von Werten war da ja ersichtlich aber ich habe keine Ahnung wie ich einen Stellwert z.B. 60 ins Logo bekomme und dem mit der Arimethrik zu verrechnen.
    Mit der Regelung hab ich immo noch die Geringsten Kopfschmerzen (ja, ist ein Problem) aber solange ich nicht den EIngabewert vernünftig verarabeiten kann kann ich die Anlage nicht anfahren, da hilft mir dann auch eine Regelung nicht weiter

    Trotzdem danke für den Vorschlag, werds mal mit dem PI Regler versuchen

  5. #4
    Registriert seit
    02.01.2015
    Beiträge
    527
    Danke
    96
    Erhielt 109 Danke für 104 Beiträge

    Standard

    Ich kenn mich mit WinCC nicht aus, aber wenn ich mir das Beispiel anschaue, dann musst eine Variable anlegen, ein Ein-/Ausgabefeld Integer).
    Als Adresse gibst du ein freies Wort im VM-Bereich an, z.B. VW10.
    Das VW10 fragst du dann im Logoprogramm als analogen Netzwerkeingang ab.
    Angehängte Grafiken Angehängte Grafiken

  6. #5
    Luckyarrow ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    24.01.2016
    Beiträge
    4
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Wo genau hast du das gefunden?
    Schaut prinzipiell gut aus, allerdings hab ich noch das klitzekleine Problem dass ich in LAD (KOP) Programmieren MUSS weil mein Chef sich das einbildet.
    Ich mags nicht und find es Potentiell komplizierter.

    Danke nochmals

  7. #6
    Registriert seit
    02.01.2015
    Beiträge
    527
    Danke
    96
    Erhielt 109 Danke für 104 Beiträge

    Standard

    Zitat Zitat von Luckyarrow Beitrag anzeigen
    .....
    Schaut prinzipiell gut aus, allerdings hab ich noch das klitzekleine Problem dass ich in LAD (KOP) Programmieren MUSS weil mein Chef sich das einbildet.
    Ich mags nicht und find es Potentiell komplizierter.
    ......
    Da kann ich dir nur zu stimmen. Tipp das Ganze in FUP ein, dann kannst du das Ganze nach KOP übersetzen, um es dir dann in KOP anzuschauen.

    Edit:
    Vor allen Dingen ist KOP in der Logo Fehler behaftet. Es ist schon des Öfteren vorgekommen, dass tote Blöcke im Programm waren und das Programm nicht in die Logo geladen werden konnte. In KOP hast du keine Chance diese zu finden, sie werden dir nicht angezeigt. Dann musst du erst nach FUP konvertieren, die Blöcke dort suchen und löschen und anschließend wieder nach KOP zurück. Dann ist aber dein die Übersicht in KOP pfutsch, weil die Stromlaufpfade wahllos wieder angeordnet werden, nicht nach deiner ursprünglichen Eingabereihenfolge.
    Geändert von GUNSAMS (24.01.2016 um 19:00 Uhr)

  8. #7
    Luckyarrow ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    24.01.2016
    Beiträge
    4
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hab nur das Problem dass die Übersetzteri von KOP nach FUP nicht 100% funzt... hatte das problem bereits bei der Zähler und Sollwertverstellung.
    Hab ein funktionierendes Programm genommen und versucht das zu übersetzen -> Resultat: Programm in FUP ging, KOP ging nicht obwohl ich nichts verändert hab...

    Benutzt du IRC / TS o.ä? dann müssten wir hier nicht das Forum zumüllen

  9. #8
    Registriert seit
    02.01.2015
    Beiträge
    527
    Danke
    96
    Erhielt 109 Danke für 104 Beiträge

    Standard

    Das hat mit zumüllen nichts zu tun.
    Ich mag KOP bei Logo nicht und möchte damit auch nichts zu tun haben.
    Wenn es um rein digitale Grundfunktionen geht, kann man es noch akzeptieren. Sobald aber die Sonderfunktionen und/oder Analogverarbeitung ins Spiel kommt.... nein danke.

  10. #9
    Registriert seit
    27.06.2009
    Ort
    am Nordharz
    Beiträge
    3.738
    Danke
    444
    Erhielt 924 Danke für 744 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von Luckyarrow Beitrag anzeigen
    Benutzt du IRC / TS o.ä? dann müssten wir hier nicht das Forum zumüllen
    Zitat Zitat von GUNSAMS Beitrag anzeigen
    Das hat mit zumüllen nichts zu tun.
    Außerdem ist es ja der Sinn eines Forums, dass auch andere (und nicht nur der Ratsuchende) etwas durch die Probleme und der möglichen Abhilfe für sich mitnehmen können.

Ähnliche Themen

  1. Sonstiges LOGO 0BA8 an Siemens Display 6AV6 646-0BA21-2AX0
    Von thomsguy im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 25.11.2015, 21:59
  2. TIA Verbindung S-1212 mit LOGO 0BA8
    Von Chris1 im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 25.09.2015, 16:58
  3. Antworten: 8
    Letzter Beitrag: 05.08.2015, 14:20
  4. Sonstiges Siemens LOGO 0BA8 mit PC HMI über Wincc 2005
    Von thomsguy im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 14.05.2015, 21:49
  5. Logo 0BA8 mit TD und PC verbinden
    Von preuner_94 im Forum Sonstige Steuerungen
    Antworten: 6
    Letzter Beitrag: 17.04.2015, 08:36

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •