Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 10 von 10

Thema: CP 443-5 Ext und SFC14/15

  1. #1
    Registriert seit
    08.04.2008
    Ort
    Köln
    Beiträge
    844
    Danke
    39
    Erhielt 244 Danke für 199 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen!

    Ich muss bei einem Kunden mit nem uraltem CP 443-5 Ext (6ES7-5DX01-0XE0 Ausgabestand 1)
    eine Kommunikation zu ein paar Profibusteilnehmern aufbauen. Da ich die Daten konsistent auslesen
    will (muss), dachte ich an SFC 14/15. Es sollen 48 Worte gelesen und geschrieben werden.
    Leider meldet mir der SFC "80B0" (Slaveausfall an externer DP-Anschaltung).
    Über L / T PEW bzw. L / T PED kann ich die Daten aber lesen.
    Klar, ich kann eine Schleife einbauen, die mir die Daten ausliest, dann ist es aber nur noch
    konsistent über ein Doppelwort.
    Hat jemand eine andere Idee?
    (Ich hab' beim großen S auch nach nem Firmwareupdate geschaut, aber das lässt sich leider nicht entpacken.)

    Grüße
    Gebs
    Zitieren Zitieren CP 443-5 Ext und SFC14/15  

  2. #2
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.191
    Danke
    923
    Erhielt 3.292 Danke für 2.661 Beiträge

    Standard

    Bei mir entpackt sich die Firmware ohne Probleme. Die fw443-5e_2.exe ist 461341 Bytes groß.

    Firmwareupdate V1.21 für den CP 443-5 Extended (6GK7 443-5DX01-0XE0)

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  3. #3
    Avatar von Gebs
    Gebs ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    08.04.2008
    Ort
    Köln
    Beiträge
    844
    Danke
    39
    Erhielt 244 Danke für 199 Beiträge

    Standard

    Hallo Harald,

    welches Betriebssystem hast Du auf Deinem Rechner?
    Ich hab Win 7 Professionell. Da kommt leider immer die Fehlermeldung
    Die Version dieser Datei ist nicht kompatibel...

    Grüße
    Gebs

  4. #4
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.191
    Danke
    923
    Erhielt 3.292 Danke für 2.661 Beiträge

    Standard

    Hallo Gebs

    Ich habe Windows XP Prof - da geht es.
    Bei Windows 7 bekomme ich auch die Kompatibilitätsmeldung.

    Wenn Du mir Deine eMail-Adresse per PN mitteilst, dann kann ich Dir die ausgepackten Dateien mailen.

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  5. #5
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.191
    Danke
    923
    Erhielt 3.292 Danke für 2.661 Beiträge

    Standard

    Die exe ist ein selbst-extrahierendes zip-Archiv. Wenn Du WinZip oder WinRAR oder ... hast, dann müßtest Du die exe damit auspacken können.

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  6. Folgender Benutzer sagt Danke zu PN/DP für den nützlichen Beitrag:

    Gebs (29.01.2016)

  7. #6
    Avatar von Gebs
    Gebs ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    08.04.2008
    Ort
    Köln
    Beiträge
    844
    Danke
    39
    Erhielt 244 Danke für 199 Beiträge

    Standard

    Hallo Harald,

    das Entpacken hat jetzt funktioniert. Danke!
    Aber leider hab' ich nicht die HW um die Firmware zu laden.
    Mit meinen Adaptern funktioniert es nicht.So ein Sch...

    Grüße
    Guido

  8. #7
    Registriert seit
    06.10.2003
    Beiträge
    3.412
    Danke
    451
    Erhielt 506 Danke für 408 Beiträge

    Standard

    Hallo Gebs,

    Zitat Zitat von Gebs Beitrag anzeigen
    .. Es sollen 48 Worte gelesen und geschrieben werden..
    48 Worte sowohl geschrieben als auch gelesen? Dann wären das nach Adam Ries 192 Byte konsistente Daten. Der genannte CP kann jedoch nur 128 Byte je Slave. Ich habe nur flüchtig nachgelesen, aber das Firmwareupdate ändert daran wohl auch nichts? Entweder nach neuer Hardware umsehen, oder mit den Slave-Erschaffern auf nichtkonsistente Daten einigen, falls es denn technisch möglich ist.

    Gruß, Onkel
    Es gibt viel mehr Leute, die freiwillig aufgeben, als solche, die echt scheitern.
    Henry Ford

  9. #8
    Avatar von Gebs
    Gebs ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    08.04.2008
    Ort
    Köln
    Beiträge
    844
    Danke
    39
    Erhielt 244 Danke für 199 Beiträge

    Standard

    Hallo Onkel,

    ich habs auch schon umparametriert, so daß nur 16 Worte konsistent geschrieben und gelesen werden.
    Funktioniert aber auch nicht.
    Ich werde es jetzt wohl von Hand machen und die Daten mit L PED / PAD in der Reihenfolge einlesen/schreiben,
    wie ich sie baruche.

    Grüße
    Gebs

  10. #9
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.191
    Danke
    923
    Erhielt 3.292 Danke für 2.661 Beiträge

    Standard

    Zitat Zitat von Gebs Beitrag anzeigen
    Ich werde es jetzt wohl von Hand machen und die Daten mit L PED / PAD in der Reihenfolge einlesen/schreiben,
    wie ich sie baruche.
    Du könntest die E/A-Adressen des Slave ins Prozessabbild OB1-PA legen, dann sorgt die CPU für konsistente Daten. Dann kannst Du mit L ED/EW/EB beliebig zugreifen.


    Zitat Zitat von Gebs Beitrag anzeigen
    Leider meldet mir der SFC "80B0" (Slaveausfall an externer DP-Anschaltung).
    Ist der Slave denn tatsächlich gestört? Wenn nicht (und sonst ist alles richtig gemacht), dann ist wohl die Fehlernummer falsch, was an der Firmware liegen könnte.

    An LADDR hast Du die korrekte E-Adresse des Slave-Moduls angegeben?
    Der Zielbereich am Ausgang RECORD ist genau so lang wie das Slave-Modul projektiert ist? Der ANY zeigt auf eine Struktur oder ein Array of BYTE? (schreibe mal den ANY absolut: P#DB1.DBX0.0 BYTE 96)

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  11. #10
    Avatar von Gebs
    Gebs ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    08.04.2008
    Ort
    Köln
    Beiträge
    844
    Danke
    39
    Erhielt 244 Danke für 199 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Harald,

    Zitat Zitat von PN/DP Beitrag anzeigen
    Du könntest die E/A-Adressen des Slave ins Prozessabbild OB1-PA legen, dann sorgt die CPU für konsistente Daten. Dann kannst Du mit L ED/EW/EB beliebig zugreifen.
    Da wird mir das PAE/PAA zu groß. Die Adressen liegen im Bereich 3000 bis 5000. (Ist vom Kunden so vorgegeben.)

    Zitat Zitat von PN/DP Beitrag anzeigen
    Ist der Slave denn tatsächlich gestört? Wenn nicht (und sonst ist alles richtig gemacht), dann ist wohl die Fehlernummer falsch, was an der Firmware liegen könnte.
    Der Slave ist nicht gestört.

    Zitat Zitat von PN/DP Beitrag anzeigen
    An LADDR hast Du die korrekte E-Adresse des Slave-Moduls angegeben?
    Der Zielbereich am Ausgang RECORD ist genau so lang wie das Slave-Modul projektiert ist? Der ANY zeigt auf eine Struktur oder ein Array of BYTE? (schreibe mal den ANY absolut: P#DB1.DBX0.0 BYTE 96)
    Wenn ich die Slaves an die Schnittstelle der CPU hänge funktioniert alles.
    Da hängt aber auch schon ein PB-Strang mit den gleichen Slaves dran.
    Und ich brauche leider 4 Stränge wg. 4 Gebäuden.

    Grüße
    Gebs

Ähnliche Themen

  1. Antworten: 0
    Letzter Beitrag: 31.03.2012, 05:09
  2. SM 334 - ext. Spannung und Poti - wie?
    Von Grmpf im Forum Simatic
    Antworten: 12
    Letzter Beitrag: 29.10.2008, 12:16
  3. CP 443-5 ext.
    Von mitchih im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 03.07.2008, 18:37
  4. Verbindung CP343-1 und CP-443-1
    Von Kuffel im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 11.10.2006, 08:50
  5. CP 443-5 Ext als zusätzliche DP-Schnittstelle
    Von Bernd27 im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 02.04.2005, 21:59

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •