Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 9 von 9

Thema: Softwarestand S7-315-2DP 2AG10

  1. #1
    Registriert seit
    26.02.2016
    Beiträge
    2
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Frage


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Forum,
    wieder ein Neuer und wieder einer der gleich mit seinem ersten Eintrag sich mit den Problemen die das Thema SPS so mit sich bringen könnte sich an euch wendet, womit ich alle Beteiligten die hier mithelfen dann erst einmal begrüße.

    Bin jetzt fast 59 Jahre und seit etwas über 20 Jahren als Elektrotechniker vorher Elektroinstallateur, glücklicherweise immer in mehr oder weniger leitender Positionen Bau- und Projektleitung Anlagenbau unterwegs in der Welt. SPS interessierte mich dabei zwar immer, aber der Alltag hatte mehr damit zu tun das böse Wort Effizienz zu befriedigen und gepflegt ausgedrückt so manche sich anbahnende Projekt-Katastrophen abzuwenden.

    Aus den Zeiten als Betriebselektriker und der Technikerschule (Abendschulform) sind, ohne mich selbst über den grünen Klee zu loben, gute S5 und Mikroprozessor Kenntnisse 8080, diese und jene Weiterbildung z.B. System-Engineering zumindest Grundlagen C# und WINCC , sowie PC und Netzwerkkenntnisse vorhanden.

    Das Thema SPS und PLC hat mich immer fasziniert, berührte mich beruflich Leider eher peripher. Bis vor einiger Zeit waren die SPS-en immer noch außerhalb meines Hobbybudget, geschweige denn das ich Zeit oder wegen der mit dem Job verbunden Reisetätigkeit viel Spielraum gelassen hätten. Nun aber, bin ich dabei mal ein wenig zurückzuschalten und weil mir das Thema SPS immer ein wenig am Herzen lag mich damit auseinandersetzen und es wäre schön wenn ihr dabei behilflich sein könnt. Das alles wirklich vor dem Hintergrund, dass es ein Hobby sein soll, ich glaube kaum das es beruflich mal eine Rolle spielen wird. (Leider)
    ================================================================================ ==============


    Nachdem ich alles zusammengeschraubt und soweit in Betrieb nehmen konnte, tut sich das erste Problem auf, ich habe eine S7 315-2DP 2AG10 Ausgabe 1 mit einer 4 MB Karte (6ES7953-8LM11-0AA0) und einem Release Stand 2.0.0. Das heißt Online nichts zu upgraden und ohne Prommer keine Chance das Image für das Update auf die Karte zu kriegen.

    Die CPU ohne MMC zeigt in der Diagnose keine Fehler, es werden auch sämtliche parametrierte DI/DO/AI Karten fehlerfrei akzeptiert, erst ich die MMC einschiebe, dauert es nicht lange schon ist „Alarmstufe Rot“ auf SF nach dem Urlöschen/ Neustart? Zusätzlich auch BF (Die MMC und die CPU kamen auf unterschiedlichen Wegen)

    Ich vermute mal dass ich schon ein Stückchen weiter käme wenn die CPU ein aktuelles Upgrade bekäme und in der Diagnose sehen könnte, was da los ist? Aber so wie das aufgestellt ist, ist irgendwie wie mit der Frage Huhn oder Ei, was war zuerst da?

    Hat jemand eine Idee wo ich als privat Mensch, wenn möglich für kleines Geld, ein Upgrade bekomme?

    Vielen Dank!

    -------------------------------------
    (Hardware Inventur: CPU 315-2DP 2AG10/ 4MB MMC/ 3 Stück 16 x 0,5 DO/ 3 Stück 16 x DI/ 1 Stück AI mit PT100 Simulator/ SITOP 24V/5A/ Simatic TIA 12/ WINCC (Student)/ PC-Adapter USB-MPI)/ ein wenig DP Zubehör (für später
    Zitieren Zitieren Softwarestand S7-315-2DP 2AG10  

  2. #2
    Registriert seit
    06.01.2005
    Ort
    im schönen Lipperland
    Beiträge
    4.472
    Danke
    498
    Erhielt 1.143 Danke für 736 Beiträge

    Standard

    Hallo.

    Ich vermute eher das die MMC-Karte es nicht so tut wie sie soll. Ist das eine gebrauchte Karte ? Hast du die Karte mal urgelöscht ?
    Früher gab es Peitschen .... heute Terminkalender

  3. #3
    2Meter ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    26.02.2016
    Beiträge
    2
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Auch Hallo, vielen Dank für die schnelle Rückmeldung,

    wie schon beschrieben, im STOP die MMC eingeschoben, geht die CPU auf SF,
    nach dem Urlöschen wird zusätzlich zu SF auch noch BF signalisiert.
    In der Software lässt sich das unter Diagnose auch nicht auslesen.
    Habe hier gelesen dass wenn die MMC aus einer anderen CPU stammt, es da schon mal zu Problemen kommen kann?
    Habe kurzfristig leider auch nicht die Möglichkeit auf ein PG oder auf einen Prommer zuzugreifen um die MMC zu überprüfen.
    Könnte ja auch sein das die MMC dulle ist?

  4. #4
    Registriert seit
    06.01.2005
    Ort
    im schönen Lipperland
    Beiträge
    4.472
    Danke
    498
    Erhielt 1.143 Danke für 736 Beiträge

    Standard

    Wenn die MMC vorher in einer F-CPU war gibt es Probleme. Ebenfalls kann es Probleme geben wenn die Karte in einem "normalen" Kartenleser war.
    Früher gab es Peitschen .... heute Terminkalender

  5. #5
    Registriert seit
    19.02.2016
    Beiträge
    462
    Danke
    8
    Erhielt 54 Danke für 49 Beiträge

    Standard

    @2Meter: Wenn gewünscht, kann ich dir die MMC gerne überprüfen und ggf. komplett leeren (falls da mal F-Zeugs o.ä. drauf war)

    Ein Firmware-Upgrade über die 4MB MMC ist nur bedingt zu empfehlen... Denn dann müssten wir die 2 mal hin und her schicken
    Siehe:
    https://support.industry.siemens.com...dti=0&lc=de-WW

    Versand-Daten usw gibt per PM auf Wunsch.

    MfG Fabsi

  6. #6
    Registriert seit
    08.08.2008
    Ort
    Köln
    Beiträge
    354
    Danke
    57
    Erhielt 88 Danke für 69 Beiträge

    Standard

    Die Karte muss, sofern vormals ein anderes Programm drauf war gelöscht werden. Die CPU versucht nach dem anlegen der Betriebsspannung das Projekt von der Karte zu laden. War dort eine Hardwarekonfiguration drauf die nicht zu deiner Hardware passt gibts nen SF Fehler.


    Gesendet von iPhone mit Tapatalk

  7. #7
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.725
    Danke
    314
    Erhielt 1.519 Danke für 1.282 Beiträge

    Standard

    Also eigentlich 2 Kardinalfehler:
    Die MMC zieht bzw. steckt man NIE wenn die CPU Spannung hat.
    Nach Spannung Ein kommt es darauf an, wie sich die Stop-LED verhält ...

    Blinkt diese dauerhaft Langsam, dann gibt es 2 Möglichkeiten:
    - Die MMC ist Schrott, weil Sie z.B. in Windows formatiert wurde (gibt aber wohl Image Programme, welche mal mehr mal weniger gut funktionieren)
    - Auf der MMC ist ein Projekt bzw. HW-Konfig mit der die CPU nichts anfangen kann, dieses ist bei dem FW-Stand leider wohl nicht mit Bordmitteln lösbar.

    Sollte die Stop-LED nach einer gewissen Zeit dauerhaft leuchten, ist eigentlich alles gut.
    Kann dann nur noch sein, das die CPU eine andere MPI und/oder DP-Adresse hat, was aber im Grunde genommen kein wirkliches Problem darstellt.
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  8. #8
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.163
    Danke
    921
    Erhielt 3.286 Danke für 2.655 Beiträge

    Standard

    Zitat Zitat von 2Meter Beitrag anzeigen
    nach dem Urlöschen wird zusätzlich zu SF auch noch BF signalisiert.
    Das Blinken der STOP-LED hat aber aufgehört?
    Ist die CPU unter "Erreichbare Teilnehmer" bei MPI zu sehen (notfalls mal per Profibus versuchen)?

    BF - für mich klingt das so als ob die CPU die MMC akzeptiert hat. Du müßtest einfach nur eine neue Hardware Konfiguration erstellen und auf die CPU laden (also auf die MMC in der CPU), also:
    - im Simatic Manager ein neues Projekt anlegen
    - eine SIMATIC 300 Station einfügen
    - im Projektbaum unterhalb der Station das Hardware-Objekt doppelklicken --> HW Konfig öffnet sich
    - in HW Konfig zuerst eine Profilschiene einfügen aus dem Katalog: SIMATIC 300 / RACK-300 / Profilschiene
    - in Steckplatz 2 Deine CPU einfügen: SIMATIC 300 / CPU-300 / CPU 315-2 DP / 6ES7 315-2AG10-0AB0 / V2.0
    - ab Steckplatz 4 Deine Baugruppen so wie Du sie tatsächlich hast (oder erstmal komplett freilassen)
    - die Steckplätze 1 und 3 bleiben leer
    - Station > Speichern und übersetzen
    - Zielsystem > Laden in Baugruppe, am besten per MPI

    Das Firmware-Update brauchst Du erstmal nicht. Das kannst Du auch später machen. Oder machen lassen - dazu ist es vermutlich am einfachsten die CPU samt MMC an jemanden zu schicken der das nötige Equipment hat.

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  9. #9
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.725
    Danke
    314
    Erhielt 1.519 Danke für 1.282 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Das mit der neuen HW-Konfig könnte natürlich dann in Bezug auf die alte FW-Version, falls der TE wirklich "nur", wie in der Signatur angegeben, TIA V12 hat, auch noch problematisch werden.
    Die 315-2AG10 wird zwar von TIA prinzipiell unterstützt, aber erst ab V2.6.X
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

Ähnliche Themen

  1. Step 7 Update firmware 315-2DP 2AG10
    Von haroeris im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 18.12.2013, 04:22
  2. Antworten: 0
    Letzter Beitrag: 22.07.2012, 18:56
  3. Vipa CPU 315-2AG10
    Von Mark4you im Forum Simatic
    Antworten: 19
    Letzter Beitrag: 08.05.2012, 11:29
  4. Biete: Cpu315-2dp (315-2ag10-0ab0) + mmc
    Von Der Bubbes im Forum Suche - Biete
    Antworten: 3
    Letzter Beitrag: 29.07.2011, 20:22
  5. Biete:CPU 315-2 DP 6ES7 315-2AG10-0AB0
    Von Simaticfuzzy im Forum Suche - Biete
    Antworten: 2
    Letzter Beitrag: 30.04.2009, 16:08

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •