Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 2 ErsteErste 12
Ergebnis 11 bis 19 von 19

Thema: ET200S, Kuka-Roboter

  1. #11
    Sebastian_TIA ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    16.01.2015
    Beiträge
    25
    Danke
    7
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Matze001,

    ja, die GSDML-File vom Kuka ist kein Problem. Da weiß ich auch was ich zu tun habe...
    Was meinst du mit
    Wenn der Roboter PN Master sein kann, kann er immer Slave sein (Master kostet mehr als reiner Slave).
    ?? Du meinst, dass ich gar nichts Umbauen muss?? Ich bin der Meinung, dass durchaus ein Umbau notwendig sein wird. Warum? Weil die Robi-Steuerung nur ein ProfiNet-Anschluss hat... Ein Slave hat immer zwei, um durchschleifen zu können. Ich habe diesbezüglich schon eine Anfrage an Kuka geschrieben, was alles zu machen ist.

    Ja, den EA-Bereich versuche ich schon möglichst groß zu halten.
    Wie willst du mir eine EA-Verschaltung erstellen? Du kennst doch gar nicht meine exakten Gegebenheiten und Anforderungen??

    Grüße

  2. #12
    Registriert seit
    12.06.2013
    Beiträge
    30
    Danke
    3
    Erhielt 7 Danke für 7 Beiträge

    Standard

    Was hast du denn überhaupt für einen Roboter bzw welche Steuerung?
    KRC4 oder KRC4 compact?
    Bei beiden gibt es das KEB-Interface wo Ethercat verfügbar ist. Da gibts dann die Ethercat-Buskoppler (zB: EK1100) mit frei wählbaren Steckkarten (DI, DO, AI, AO, Kommu. usw...) Das geht sehr einfach zu integrieren. Im Workvisual den BK einfügen und die EAs dranhängen.
    Wenns unbedingt Profinet sein muss, dann würde ich da auch die ET200S IM153-1 dranhängen - selbes Prinzip wie mit Ethercat.

    Ansonsten kann ich den vorherigen Ratschlägen auch nur beipflichten, wenn unbedingt ET200S-CPU (IM151-8 ?) dann soll die den PN-Master machen und nicht der Robo - erspart dir Ärger und Zeit.
    Wenns wirklich nur um eine EA-ERweiterung des Robis geht, dann setz nur einen "dummen" Buskoppler mit EAs dran und keine weitere CPU. So teuer sind die BK´s nicht im Gegensatz zum Stundensatz für Konfiguration und Ärger&Warterei

  3. #13
    Sebastian_TIA ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    16.01.2015
    Beiträge
    25
    Danke
    7
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Wir haben die KRC4-Roboter-Steuerung mit ProfiNet-Ausbau. Wir haben uns für eine ET200S (IM151-8 PN/DP CPU) entschieden, da diese unseren Anforderungen völlig genügt. Ein paar digitale und Analoge Ein- und Ausgänge. Außerdem hatte ich damit auch schon Erfahrungen gesammelt, was auch dafür gesprochen hat. Den Kuka konnte man nicht mit ProfiNet und der gewünschten Anzahl an digitalen und analogen Ein- Ausgängen bestellen... Daher die Idee mit der ET200S.

    Ich werde es nun wie oben vorgeschlagen machen. Robi wird Slave und ET200S übernimmt die Aufgaben des Masters.

    Habe auch schon eine erfreuliche Nachricht vom Kuka-Service erhalten:

    ****

    Sehr geehrter Herr XXX,

    der Aufwand für die Umparametrierung ist überschaubar.
    Sie benötigen keine neuen Teile, da Profinet ein Ethernet-basiertes Protokoll ist und über die KLI Schnittstelle angebunden wird.

    Sie müssen im WorkVisual bei der Steuerung den Device-Stack aktivieren. Ist dieser aktiviert, ist die Steuerung Device, wenn nicht aktiviert Master.
    Zudem müssen Sie in Ihrer SPS die richtige GSDML-Datei importieren. Diese Gerätebeschreibungsdatei finden Sie im Installationsverzeichnis von
    WorkVisual im Ordner DeviceDiscriptions.

    ***

    Somit wären alle Probleme theoretisch gelöst. Jetzt noch die Umsetzung vorantreiben.

    An alle: Vielen Dank für eure Hilfe!!!!

    Grüße
    Sebastian

  4. #14
    Registriert seit
    12.06.2013
    Beiträge
    30
    Danke
    3
    Erhielt 7 Danke für 7 Beiträge

    Standard

    Zitat Zitat von Sebastian_TIA Beitrag anzeigen

    ...

    Somit wären alle Probleme theoretisch gelöst. Jetzt noch die Umsetzung vorantreiben.
    .....
    Theoretisch...

    Profinetanbindung ist ja in der Systemintegratoren-Manual recht gut beschrieben

  5. #15
    Registriert seit
    11.12.2009
    Beiträge
    2.115
    Danke
    388
    Erhielt 390 Danke für 271 Beiträge

    Standard

    Ja du brauchst keine weitere Hardware!

    Wenn Du Fragen hast immer her damit, ist eigtl. nicht so kompliziert.

    E/A Verschaltung: Ist recht simpel: Ich würde dir z.B. 1024 Eingänge vom Bus auf die ersten 1024 Robotereingänge mappen... und Ausgänge genau so.
    Was es dann später wird (BOOL; BYTE; ETC) entscheidest du über die Signalvereinbarung.

    Grüße

    Marcel
    Stell Dir vor es geht, und keiner kriegts hin!

  6. #16
    Sebastian_TIA ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    16.01.2015
    Beiträge
    25
    Danke
    7
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo Matze001,

    würde gerne auf deine Hilfe zurückkommen...

    Kannst du mir bitte je 2048 Ein- und Ausgänge mappen? Und auch bitte erklären, wie man dies macht...

    Momentan habe ich ein Kommunikationsproblem zwischen der ET200 und dem Kuka... (IP-Adresse und Gerätename ist korrekt) Der Kuka ist aktuell auch nicht mehr als Master konfiguriert.

    Wenn man diese E/A Verschaltung im Kuka gemacht hat, muss man dann in der SPS eine GSDML-Datei nachladen?? ich habe momentan die Standard-GDSML Dateien von Kuka benutzt... Bin mir aber gerade alles andere als sicher...

    Grüße
    Sebastian

  7. #17
    Registriert seit
    12.06.2013
    Beiträge
    30
    Danke
    3
    Erhielt 7 Danke für 7 Beiträge

    Standard

    Das Mappen der Signale machst du in der EA-Verschaltung oder dem Signal-Editor -> WorkVisual Installations-CD, dort nach Ordner DOC suchen, Datei: KST_Work_Visual_de.pdf -> S.66
    Profinet-Anleitung gibts auf der Parts&Docs DVD ->KUKA_ProfiNet_31_de.pdf -> du musst die KRC4 als Device konfigurieren

    Das mühsehlige Zusammenklauben der Manuals ist nervig & nicht alle relevanten Dokus sind auf der DVD -> Stichwort: Systemvariablen

  8. #18
    Registriert seit
    11.12.2009
    Beiträge
    2.115
    Danke
    388
    Erhielt 390 Danke für 271 Beiträge

    Standard

    Hallo Sebastian,

    gerne helfe ich Dir weiter!

    Prüfen wir doch mal von vorn:

    IP-Adressen sind korrekt und Pingbar?
    Gerätenamen sind korrekt und enthalten keine Sonderzeichen oder Leerzeichen?
    Es ist die richtige GSDML Datei ausgewählt ? (In Workvisual findest Du unter Profinet die Version die unterstützt wird (V8.3, V8.2.1 o.ä, eine entsprechende GSDML-Datei benötigst Du)
    Was genau heißt Kommunikationsfehler?
    Hast Du den Slave mit 2048 EA aktiviert?
    Hast Du in der GSDML-Datei 256 Eingangs- und Ausgangsbytes eingefügt?
    Benutzt Du nur Profinet oder auch Profisafe? Wenn Profisafe: Sind die 64 sicheren EA in der GSDML Datei verschaltet, wenn nein -> sind sie entfernt?
    Die Verschaltung der EA ist sehr simpel.

    Workvisual, erster Reiter, Rechtsklick auf die Steuerung -> Als aktive Steuerung setzen
    Dann erscheint automatisch der EA-Verschaltungseditor
    Da wählst du im linken oberen Fenster z.B. Eingänge
    und im Rechten oberen Fenster Profinet aus
    Dann erscheinen unten Links die Roboter Eingänge, und Rechts die Profinet-Eingänge
    Rechts Strg+A und auf Eingang 1 Links per Drag-and Drop ziehen
    Das gleiche mit den Ausgängen.

    Grüße

    Marcel
    Stell Dir vor es geht, und keiner kriegts hin!

  9. #19
    Sebastian_TIA ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    16.01.2015
    Beiträge
    25
    Danke
    7
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Matze001,

    danke für deine Antwort.

    Wir konnten unser Problem lösen.

    Unser Kommunikationsproblem lag an einem falschen ProfiNet-Gerätenamen... (Unterschiedlicher Name des Gerätes und des projektierten Gerätes). Danach hat alles funktioniert!

    Die EA-Verschaltung war auch kein Problem. Bisschen lesen und man schafft es!


    Nun haben wir herausgefunden, dass man die Master - Slave Geschichte etwas aufteilen kann... Das bringt uns auch einen Schritt weiter!
    Der Kuka kann so konfiguriert werden, dass er für einen Teil der Teilnehmer Master ist und für die ET200 ist er Slave.

    Nun kann ich die GSDML Dateien innerhalb des Kukas installieren und gut ist. Dazu noch eine Frage...
    Bei dem Konfigurieren der Inputs und Outputs kann man zum einen In und Out einzeln hineinziehen und zum anderen als gemeinsamen Input und Output-Modul. Warum ist das so? Und woher weiß man, welches man nehmen muss??

    Viele Grüße
    Sebastian

Ähnliche Themen

  1. S7 und Kuka Roboter
    Von Norton im Forum Simatic
    Antworten: 35
    Letzter Beitrag: 30.03.2014, 23:26
  2. Kosten für gebrauchten KUKA Roboter??
    Von MeisterLampe81 im Forum Stammtisch
    Antworten: 1
    Letzter Beitrag: 13.10.2010, 22:42
  3. Beginnerinfo zu Kuka-Roboter!?
    Von Rafa im Forum Sonstige Steuerungen
    Antworten: 3
    Letzter Beitrag: 25.06.2009, 21:29
  4. Kuka Roboter Lernunterlagen
    Von Bossi im Forum Suche - Biete
    Antworten: 10
    Letzter Beitrag: 26.11.2007, 16:04
  5. Anbindung KUKA Roboter an S7
    Von lefrog im Forum Feldbusse
    Antworten: 2
    Letzter Beitrag: 04.06.2006, 20:17

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •