Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 8 von 8 ErsteErste ... 678
Ergebnis 71 bis 75 von 75

Thema: AG_RECV (FC6) für Modbus TCP Verbindung

  1. #71
    DerMatze ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    24.01.2012
    Beiträge
    511
    Danke
    92
    Erhielt 21 Danke für 20 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Mit powerconfig konnte nicht auf den PAC zugegriffen werden, da der CP eine Verbindung (Send/Receive) aufgebaut hatte. Nachdem die Verbindung in der Projektierung entfernt wurde, konnte ich auch mit powerconfig den PAC erreichen.
    Das Gerät kann leider immer nur eine Verbindung aufbauen.
    Warum der Verbindungsaufbau zum PAC dirket nicht möglich war, ist mir unklar.

    In der HW-Konfig wurde nun "ohne Router" ausgewählt, obwohl das Anlagennetzwerk einen Router enthält...
    Alles in die CPU, Neustart = Werte kommen korrekt.

    Gruß
    Matze
    Geändert von DerMatze (14.05.2016 um 06:56 Uhr)
    -----------------------------------------------------------------------------------------
    Programmierumgebung: Step 7 V5.5 + SP3
    WinCC flexible 2008 Advanced + SP3
    -----------------------------------------------------------------------------------------

  2. #72
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.172
    Danke
    922
    Erhielt 3.287 Danke für 2.656 Beiträge

    Standard

    Zitat Zitat von DerMatze Beitrag anzeigen
    In der HW-Konfig wurde nun "ohne Router" ausgewählt, obwohl das Anlagennetzwerk einen Router enthält...
    Ob man einen Router einträgt oder nicht hängt weniger davon ab, ob da ein Router vorhanden ist, sondern ob der Teilnehmer mit Teilnehmern aus anderen IP-Netzwerken kommunizieren soll/darf.

    Wenn man beim CP343-1 oder beim PAC keinen Router/Gateway einträgt, dann können diese Geräte nur mit Teilnehmern aus dem selben IP-Range (IP-Adresse AND Subnetmask) kommunizieren. Verbindungen von/zu Netzwerkteilnehmern außerhalb der IP-Range sind dann nicht möglich. Wenn der CP343-1 und der PAC in verschiedenen IP-Ranges liegen und sie sollen miteinander kommunizieren, dann muß bei beiden ein Router/Gateway eingetragen werden.

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  3. #73
    Registriert seit
    18.01.2007
    Beiträge
    26
    Danke
    2
    Erhielt 9 Danke für 9 Beiträge

    Standard

    Hallo Matze

    Endlich lauft dann der Kommunikation uber modbus zwichen PAC und SPS gut und kommen die daten wie erwartet?

    Mit router oder gateway adres ist es so wie Harald schreibt, aber das heißt dann ach dass wen zwei teilnehmer ins gleiche Subnetz sind und Mann tragt doch ein gateway Adresse ein in ein diese teilnehmer (in diese fall CP) das dann der Kommunikation zwichen diesen teilnehmers ach nicht mehr lauft?

    Aber am ende lauft alles und hofentlich hat ihr davon gelernt .

    Mit freundlichen Gruß
    Henny

  4. #74
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.172
    Danke
    922
    Erhielt 3.287 Danke für 2.656 Beiträge

    Standard

    Zitat Zitat von Henny Beitrag anzeigen
    das heißt dann ach dass wen zwei teilnehmer ins gleiche Subnetz sind und Mann tragt doch ein gateway Adresse ein in ein diese teilnehmer (in diese fall CP) das dann der Kommunikation zwichen diesen teilnehmers ach nicht mehr lauft?
    Nein, heißt es nicht. Kommunikation im selben Subnetz ist immer möglich, egal ob ein Gateway eingetragen ist oder nicht. Nur wenn mit Teilnehmern außerhalb des Subnetz kommuniziert werden soll, dann muß ein Gateway eingetragen werden, weil an dieses Gateway muß der Teilnehmer seine Nachrichten schicken, damit das Gateway die Nachrichten weiterleitet (routet).

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  5. Folgender Benutzer sagt Danke zu PN/DP für den nützlichen Beitrag:

    DerMatze (15.05.2016)

  6. #75
    Registriert seit
    18.01.2007
    Beiträge
    26
    Danke
    2
    Erhielt 9 Danke für 9 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Harald

    Danke für ihre Erklärung.

    Hat mir verwirrt will Matze erklärt in seine Letze beitrage dass wen er die gateway adresse entfernt hatte in HW config, Hw config neu laden und herstart cp alles richtig lauft.
    Ursache war dann wahrscheinlich nicht diese gateway adresse aber etwas anders?

    Aber end gut all gut Kommunikation lauft und Daten kommen richtig an.

    Mit freundlichen Gruß
    Henny

Ähnliche Themen

  1. CP343-1 Lean, Version von AG_RECV (FC6)
    Von BoxHead im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 05.12.2012, 21:28
  2. FC6 AG_RECV Probleme beim Datenempfang
    Von danielplp im Forum Simatic
    Antworten: 11
    Letzter Beitrag: 16.02.2011, 07:59
  3. Simatic Net, AG_CNTRL (FC10) und AG_RECV (FC6)
    Von Hansruedi im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 12.03.2010, 08:56
  4. Konflikt durch FC6 : AG_RECV <--> DT_DATE
    Von biertrinker im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 05.03.2010, 12:32
  5. Datenübernahme beim FC6 AG_RECV
    Von Florian_Niedermaier im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 11.11.2007, 13:37

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •