Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 3 von 3 ErsteErste 123
Ergebnis 21 bis 26 von 26

Thema: S5 Timer defekt?

  1. #21
    Registriert seit
    02.01.2015
    Beiträge
    524
    Danke
    95
    Erhielt 109 Danke für 104 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Mir ist der Fehler mit den S5-Timern auch noch vage bekannt. Das wurde damals, wenn ich mit recht entsinne, mit einem Firmwareupdate behoben. Man nusste die ebtsprechende CPU zur Reparatur einschicken. Oder warten, bis die entsprechende CPU mit einem neueren Erzeugnisstand bereitstand, welche die neue Firmware schon eingesetzt wurde.

  2. #22
    Registriert seit
    01.02.2011
    Ort
    Baesweiler bei Aachen
    Beiträge
    51
    Danke
    9
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Zitat Zitat von Larry Laffer Beitrag anzeigen
    - der Timer wird noch einmal im Programm verwendet (das müßte dann aber erst neuerdings so sein)
    Nein, der Timer wird nicht noch einmal im Programm verwendet.

    Zitat Zitat von Larry Laffer Beitrag anzeigen
    - die Speicherstelle in der SPS, die die Timer-Funktionalität abbildet, wird durch eine indirekte Adressierung möglicherweise manipuliert.
    - indirekte Adressierung gibt es in der Anlage nicht.

    Zitat Zitat von Larry Laffer Beitrag anzeigen
    - der Timer selbst wird durch eine indirekte Adressierung (indirekten Zugriff) möglicherweise manipuliert.
    siehe Punkt 2



    Mal eine andere Frage:
    Wieviele Timer hat eine S5 115 CPU 943 denn zur Verfügung?
    Das Programm wurde vor kurzem erweitert und der Timer T130 eingefügt/verwendet.
    Nicht das dieser Timer über der Anzahl der verfügbaren Timern liegt ?!
    Geändert von Holle-52499 (27.04.2016 um 13:57 Uhr)

  3. #23
    Registriert seit
    07.09.2006
    Ort
    nördl. Ruhrgebiet
    Beiträge
    46
    Danke
    37
    Erhielt 14 Danke für 7 Beiträge

    Standard

    Hallo Holle-52499,

    die CPUs der S5-115U (CPU941..CPU944) haben 128 Timer, also T0..T127.
    Nur die CPU945 hat meines Wissens 256 Timer, also zusätzlich T128..T255.

    siehe auch hier:
    S5-Timer-CPU943.jpg

    Gruß Willi
    Wenn du denkst es geht nichts mehr, wünscht du dir einen Reset-Knopf her.

  4. #24
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.200
    Danke
    926
    Erhielt 3.292 Danke für 2.661 Beiträge

    Standard

    Zitat Zitat von Holle-52499 Beitrag anzeigen
    Das Programm wurde vor kurzem erweitert und der Timer T130 eingefügt/verwendet.
    Nicht das dieser Timer über der Anzahl der verfügbaren Timern liegt ?!
    Nicht daß die Adresse "T130" statt dem nicht vorhandenen T130 den T2 anspricht ... würde zum Problem passen.

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  5. #25
    Registriert seit
    02.01.2015
    Beiträge
    524
    Danke
    95
    Erhielt 109 Danke für 104 Beiträge

    Standard

    Nein.
    Die 943(A) hat 128 Timer, davon wahlweise remanent 64 (T0-T63) und 64 nicht remanente (T64-T127).
    Die 943B hat 128 Timer, davon wahlweise:
    - alle remanent.
    - 50% remanent.
    - alle nicht remanent.

  6. #26
    Registriert seit
    01.02.2011
    Ort
    Baesweiler bei Aachen
    Beiträge
    51
    Danke
    9
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hab den T130 auf einen anderen Timer umgelegt und den T2 wieder eingefügt, jetzt läuft wieder alles.
    Scheint wirklich so als hätte er durch den T130 auf dem T2 rumgetrampelt.

    War dann wohl ein Fehler von mir, da ich davon ausgegangen bin, das die CPU 256 Timer zur verfügung hat.
    Hätte ich das früher erwähnt, wäre die Sache wahrscheinlich schneller erledigt gewesen.


    Vielen Dank an alle die Mitgeholfen haben!

Ähnliche Themen

  1. Antworten: 14
    Letzter Beitrag: 25.11.2013, 16:45
  2. Retentetive Timer On delay (Allen Bradley Timer RTO)
    Von Andy Latte im Forum Programmierstrategien
    Antworten: 2
    Letzter Beitrag: 15.07.2012, 19:23
  3. Oszi defekt
    Von FKJ im Forum Elektronik
    Antworten: 1
    Letzter Beitrag: 13.07.2010, 08:54
  4. s7 Defekt?!
    Von Jaykops im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 09.05.2010, 18:29
  5. Suche Ersatz für IFM TIMER LG ( Logik Timer)
    Von GrafLaugenkotz im Forum Sonstige Steuerungen
    Antworten: 1
    Letzter Beitrag: 16.01.2007, 17:02

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •