Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 8 von 8

Thema: BlkMov bei optimiertem Baustein im TIA Portal

  1. #1
    Registriert seit
    01.06.2015
    Beiträge
    22
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Frage


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,

    ich hab mal ne Frage bzw. ein Problem beim Umstieg auf Tia Portal.

    Und zwar haben wir an unseren kleinen HMI´s (OP73, OP77B) die Bedienung der Handfunktionen über eine Funktionsnummer gelöst. Sprich, ich habe zwei Tasten mit denen ich die Funktionsnummer erhöhe oder verringere. Je nach gewählter Funktionsnummer wurde mit den Tasten F1 bzw F4 die Funktion gesteuert. Die passende Anzeige am Display wurde über BlkMov gelöst indem anhand der Funktionsnummer die "Arbeitsdaten" in ein Struct geladen wurde.

    Wir haben mehrere Funktionen definiert die einen eigenen Datentypen nutzen. Funktionen.jpg
    Der Datentyp "Fkt" ist 16Bit lang.

    So sieht bisher der Handfunktionen Aufruf in Step7 V5.5 aus.BlkMov.png

    Nun hab ich das Problem das ich mit BlkMov immer die Meldung bekomme das ich damit keinen optimierten Baustein verschieben kann.
    Wie muss ich denn im Tia vorgehen um die gleiche Funktionalität zu erreichen?

    Ich arbeite mich ins SPS programmieren gerade erst ein und hab erst seit paar Tagen das TIA Portal.

    Vielleicht könnt Ihr mir ja weiterhelfen.

    Vielen Dank
    Edi
    Zitieren Zitieren BlkMov bei optimiertem Baustein im TIA Portal  

  2. #2
    Registriert seit
    12.12.2013
    Ort
    Kaiserslautern
    Beiträge
    1.337
    Danke
    386
    Erhielt 218 Danke für 173 Beiträge

    Standard

    Das einfachste und schnellste ist der optimierung des bausteins deaktivieren im eigenschaft des bausteins.
    Mann muss nicht optimiert arbeiten.

    Bram
    Wenn es nicht auf STRAVA ist, ist es nicht passiert !!

  3. #3
    Registriert seit
    09.01.2012
    Beiträge
    466
    Danke
    25
    Erhielt 38 Danke für 35 Beiträge

    Standard

    Zitat Zitat von de vliegende hollander Beitrag anzeigen
    Das einfachste und schnellste ist der optimierung des bausteins deaktivieren im eigenschaft des bausteins.
    Mann muss nicht optimiert arbeiten.

    Bram
    Super tipp...

    Welche Steuerung verwendest du?

  4. #4
    Eduard Schleich ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    01.06.2015
    Beiträge
    22
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ich nutze eine ET200sp mit CPU 1510sp-1PN.

  5. #5
    Registriert seit
    06.08.2014
    Beiträge
    6
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Man kann den DB ja auch selbst optimieren

    Wieso fragst du nach der Steuerung? Wenn ich mich recht erinnere spielt das ja keine Rolle, oder irre ich mich hier?

  6. #6
    Registriert seit
    23.07.2009
    Ort
    Österreich
    Beiträge
    2.339
    Danke
    449
    Erhielt 688 Danke für 513 Beiträge

    Standard

    Da er optimierte Bausteine hat wird es wohl eine 1200/1500 sein.
    Solange du den gleichen Datentyp auf den gleichen Datentyp (auch UDT und STRUCT) kopieren willst, geht das bei der 1500 jetzt mit dem normalen MOVE.
    Bei Struct muss eben die Quell und Zielstruktur gleich aufgebaut sein....

    UDT "FKT" -> MOVE -> UDT "FKT"

    Blockmove geht bei optimierten DBs nicht, obwohl strukturierte Daten in opt. Datenbausteinen auch als Block liegen.
    Geändert von RONIN (29.04.2016 um 07:23 Uhr)
    If at first you don't succeed, you're not Van Damme!
    ... or maybe using TIA!

  7. #7
    Eduard Schleich ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    01.06.2015
    Beiträge
    22
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ja Quelle und Ziel ist gleich aufgebaut.

    Ok dann probier ich mal den normalen MOVE aus.

    Danke

  8. #8
    Eduard Schleich ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    01.06.2015
    Beiträge
    22
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Also er meckert mal nicht das er damit nichts anfangen kann. Hm es kann doch so einfach sein.

    Danke für die Hilfe.

Ähnliche Themen

  1. Antworten: 9
    Letzter Beitrag: 05.12.2017, 12:42
  2. TIA Problem (U)BLKMOV bei SCL und TIA v13 SP1
    Von misu68 im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 06.03.2015, 17:07
  3. Antworten: 18
    Letzter Beitrag: 29.10.2012, 13:49
  4. Antworten: 0
    Letzter Beitrag: 22.01.2012, 18:59
  5. Frage zu BLKMOV in SCL TIA PORTAL
    Von MarkusP im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 18.01.2012, 18:30

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •