Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 11

Thema: IO-Link Ausfall erkennen & melden

  1. #1
    Registriert seit
    12.09.2012
    Beiträge
    961
    Danke
    183
    Erhielt 23 Danke für 22 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Zusammen,

    ich habe einen FESTO Motorcontroller an einem ET 200SP (IO-Link Master) angeschlossen.

    Nun gibt es ja für Profibus/Profinet die Möglichkeit, beispielsweise über den Baustein OB86 einen Ausfall zu erkennen und zu melden.


    Gibt es Ähnliches auch für einen IO-Ausfall?
    Denn hier habe ich ja keine direkte Adresse, die ich auswerten könnte ...


    Vielen Dank!
    LG
    spirit
    Zitieren Zitieren IO-Link Ausfall erkennen & melden  

  2. #2
    Registriert seit
    09.12.2011
    Ort
    Tor zum Harz
    Beiträge
    202
    Danke
    32
    Erhielt 28 Danke für 27 Beiträge

    Standard

    Moin Spirit,

    da IO Link eine Point to Point Kommunikation ist, ist es nicht notwendig. Der Master und das Device kommunizieren ständig. Ein Ausfall wird sofort am Master angezeigt,

    Raik

  3. #3
    Avatar von spirit
    spirit ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    12.09.2012
    Beiträge
    961
    Danke
    183
    Erhielt 23 Danke für 22 Beiträge

    Standard

    Vielen Dank Raik,

    ok - aber welche Möglichkeit hätte ich dann, einen Aufall des Controllers auf dem Display zu melden?

    Muss ich dazu die ET 200SP auslesen?
    LG
    spirit

  4. #4
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.752
    Danke
    323
    Erhielt 1.526 Danke für 1.286 Beiträge

    Standard

    a) Du kannst den Port-Qualifier in PCT aktivieren, und erhältst dann 4 Bit im Prozessabbild, 1 ist Gut, 0 ist Schlecht
    b) In Step7/TIA kannst du bei den Modulparametern Portselektiv die Diagnose aktivieren und so mehr oder weniger gewohnt mit den OBs arbeiten vermutlich dann OB82.

    Mgh
    Msnurl
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  5. #5
    Avatar von spirit
    spirit ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    12.09.2012
    Beiträge
    961
    Danke
    183
    Erhielt 23 Danke für 22 Beiträge

    Standard

    Zitat Zitat von MSB Beitrag anzeigen
    a) Du kannst den Port-Qualifier in PCT aktivieren, und erhältst dann 4 Bit im Prozessabbild, 1 ist Gut, 0 ist Schlecht
    b) In Step7/TIA kannst du bei den Modulparametern Portselektiv die Diagnose aktivieren und so mehr oder weniger gewohnt mit den OBs arbeiten vermutlich dann OB82.

    Mgh
    Msnurl
    Lieben Dank schon mal!

    Habe jetzt den Port-Qualifier aktiviert und erhalte damit vier Bits (E16.0, E16.1, E16.2, E16.3).


    Port Qualifier.JPG


    Jetzt ist mir nur noch nicht klar, wie ich das im OB82 auswerten kann ...

    - welches dieser vier Bits ist TRUE, wenn alles ok ist?
    - welches dieser vier Bits ist FALSE, wenn ein Fehler aufgetreten ist?

    Muss ich dann diese vier Bits im OB82 auswerten?
    LG
    spirit

  6. #6
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.752
    Danke
    323
    Erhielt 1.526 Danke für 1.286 Beiträge

    Standard

    Zitat Zitat von spirit Beitrag anzeigen
    Lieben Dank schon mal!

    Habe jetzt den Port-Qualifier aktiviert und erhalte damit vier Bits (E16.0, E16.1, E16.2, E16.3).


    Port Qualifier.JPG

    - welches dieser vier Bits ist TRUE, wenn alles ok ist?
    - welches dieser vier Bits ist FALSE, wenn ein Fehler aufgetreten ist?
    Das sind ganz normale Eingänge, dafür brauchst du keine OBs.

    Bit 0 bei Port 1, Bit 1 bei Port 2 ...


    OB82 ist was völlig anderes ... und du kannst wie gesagt in der HW-Konfig Diagnosen für fehlende Lastspannung sowie Ausfall der Ports ankreuzen.
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  7. Folgender Benutzer sagt Danke zu MSB für den nützlichen Beitrag:

    spirit (20.05.2016)

  8. #7
    Avatar von spirit
    spirit ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    12.09.2012
    Beiträge
    961
    Danke
    183
    Erhielt 23 Danke für 22 Beiträge

    Standard

    Zitat Zitat von MSB Beitrag anzeigen
    Das sind ganz normale Eingänge, dafür brauchst du keine OBs.

    Bit 0 bei Port 1, Bit 1 bei Port 2 ...


    OB82 ist was völlig anderes ... und du kannst wie gesagt in der HW-Konfig Diagnosen für fehlende Lastspannung sowie Ausfall der Ports ankreuzen.
    Danke!

    Also wenn ich den Weg über den Port-Qualifier gehe, dann brauche ich zur Auswertung auch keinen OB82, richtig?


    Angenommen es ist ein Device an Port 1 angeschlossen:

    --> dann muss ich nur das Bit E16.0 auf TRUE bzw. FALSE auswerten - ist das korrekt?
    LG
    spirit

  9. #8
    Avatar von spirit
    spirit ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    12.09.2012
    Beiträge
    961
    Danke
    183
    Erhielt 23 Danke für 22 Beiträge

    Standard

    Zitat Zitat von MSB Beitrag anzeigen

    Bit 0 bei Port 1, Bit 1 bei Port 2 ...

    Sorry, für die doofen Nachfragen ...


    Ich habe jetzt im PCT-Tool diese vier Bits (Eingänge) aktiviert und alles in die IO-Link-BG geladen.

    Warum bekomme ich jetzt den Eingang E16.0 in der Beobachtungsliste nicht als TRUE angezeigt, wenn doch eigentlich mit dem Device alles OK ist?


    Und noch etwas:
    Wenn ich z.B. die Spannungsversorgung zur ET 200SP abziehe, dann geht die CPU auf Stop und die beiden LED's leuchten Rot. Aber wenn der OB82 implementiert ist, dann dürfte doch die CPU eigentlich nicht auf Stop gehen, oder?


    Lieben Dank!
    LG
    spirit

  10. #9
    Registriert seit
    29.03.2004
    Beiträge
    5.793
    Danke
    144
    Erhielt 1.706 Danke für 1.238 Beiträge

    Standard

    Zitat Zitat von spirit Beitrag anzeigen
    Und noch etwas: [/B]Wenn ich z.B. die Spannungsversorgung zur ET 200SP abziehe, dann geht die CPU auf Stop und die beiden LED's leuchten Rot. Aber wenn der OB82 implementiert ist, dann dürfte doch die CPU eigentlich nicht auf Stop gehen, oder?
    Und du weißt wirklich nicht, wie sich bei einer S7 feststellen lässt warum die SPS in Stop-Zustand geht? Programmiest du erst seit einer Woche, oder nur in der Schule?
    Die Genialität einer Konstruktion liegt in ihrer Einfachheit – Kompliziert bauen kann jeder.

    (Sergei Pawlowitsch Koroljow, sowjetischer Konstrukteur von Raketen und Weltraumpionier)

  11. #10
    Avatar von spirit
    spirit ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    12.09.2012
    Beiträge
    961
    Danke
    183
    Erhielt 23 Danke für 22 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von Thomas_v2.1 Beitrag anzeigen
    Und du weißt wirklich nicht, wie sich bei einer S7 feststellen lässt warum die SPS in Stop-Zustand geht? Programmiest du erst seit einer Woche, oder nur in der Schule?
    Hi Thomas,

    nein ich programmiere schon etwas länger ...

    Aber sicherlich meinst du, ob ich weiß wo ich nachschauen muss - ja das weiß ich. Diagnosepuffer.

    Meine Aussage war nicht korrekt; CPU geht nicht in Stop - somit alles OK.


    ABER:

    Ich habe jetzt mal in den Eigenschaften folgende zwei Parameter aktiviert:

    Parametet.JPG

    Wenn ich nun die Kommunikationsverbindung kappe, dann erhalte ich im Diagnosepuffer der CPU folgende Meldung: "Baugruppe gestört oder Wartung erforderlich".

    Im Diagnosepuffer des IO-Link Masters wird gemeldet: "Fehler Drahtbruch"


    Nun weiß ich nicht, welchem Ereignis ich diesen Fehler im OB82 zuordnen muss?

    ... hätte vermutet, dass es OB82_COMM_FAULT ist - klappt aber nicht!

    Wollte einfach mit dem entspr. Ereignis einen Merker setzen, der mir dann im Display eine Meldung bringt.
    LG
    spirit

Ähnliche Themen

  1. Zuverlässig Profibus Ausfall erkennen
    Von bike im Forum Feldbusse
    Antworten: 59
    Letzter Beitrag: 29.05.2014, 17:16
  2. Step 7 MP377 ausfall am Profibus erkennen
    Von matchef im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 25.07.2013, 10:33
  3. Ausfall Profinetteilnehmer erkennen
    Von mjoedi im Forum Simatic
    Antworten: 32
    Letzter Beitrag: 15.10.2012, 09:41
  4. CP342-5 Ausfall erkennen und Neustart
    Von klauserl im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 19.03.2009, 10:37
  5. Antworten: 16
    Letzter Beitrag: 03.08.2006, 14:27

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •