Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 9 von 9

Thema: 315T, S120, Externer Geber, Fehler quittieren

  1. #1
    Registriert seit
    07.05.2013
    Beiträge
    41
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Moin zusammen,

    ich weiß nicht ob ich gerade nen grosses Brett vor dem Kopf habe, aber ich komme nicht auf die Lösung.

    Habe an einer CPU 315T zwei CU320 mit jeweils 3 Antrieben.
    An der ersten CU sind zusätzlich noch 2 externe Geber.
    Alle Antriebe und die Geber sind auch in der Technologie als Achsen bzw. Geber angelegt, ich habe somit auch die TechObj-DBs.

    Nun möchte ich die Fehler der externen Geber quittieren.
    Angelegt ist ein Telegramm 370, EA-Bereich 368 und 380. Somit fällt eine Kommunikation über MC_WritePeriphery ja schonmal aus (geht nur bis 63)

    Wie zum Teufel bekomme ich die Fehler nun resettet? Aktuell stehen Fehler 1910 und 1912 an, die CPU war in Stop.
    Ein Reset über MC_Reset funktioniert auch nicht, die Fehler bleiben wo sie sind.

    Kann mal bitte jemand das Brett vor meinem Kopf entfernen, das kann doch eigentlich nicht so schwer sein.

    Danke!
    Zitieren Zitieren Gelöst: 315T, S120, Externer Geber, Fehler quittieren  

  2. "Hi,

    ja die sollten auch von der Steuerung quittierbar sein, auch mit dem MC_Reset.
    Die Fehler kommen bei allen Achsen/Gebern wenn Du die CPU in Stop schaltest, nur scheinbar werden sie beim Geber nicht automatisch quittiert.

    Du kannst mal folgenden Workaround probieren:
    In der Expertenliste des externen Gebers im Sinamics beim Parameter 2104 per BICO mit dem Parameter 2090.7 eines Antriebs verbinden.
    Dann werden die Alarms des Gebers zusätzlich über das Quittierbit des Antriebs zurückgesetzt.

    Per default wird beim Geber über den parameter 2103 quittiert, der sollte mir 2090.7 des Gebers vorbelegt sein und scheinbar wird da nix von der Steuerung übertragen.
    Du kannst ja mal tracen ob das bit 7 im parameter 2090 auf high geht wenn du den MC_reset auf den Geber machst.

    Gruß
    Christoph"


  3. #2
    Registriert seit
    05.04.2012
    Beiträge
    963
    Danke
    97
    Erhielt 218 Danke für 193 Beiträge

    Standard

    Telegramm 370 ist doch gar kein Geber telegramm... geht zur Einspeisung oder? Sitze gerade nicht vor meinen Laptop...
    Geändert von zako (24.05.2016 um 11:11 Uhr)

  4. Folgender Benutzer sagt Danke zu zako für den nützlichen Beitrag:

    Karabullo (24.05.2016)

  5. #3
    Registriert seit
    16.03.2006
    Ort
    Franken
    Beiträge
    3.844
    Danke
    30
    Erhielt 942 Danke für 819 Beiträge

    Standard

    richtig, 370 ist ein ALM Telegram.
    Geber haben in der Regel Telegramtyp 8x

    Wenn du die Geber als Technologie Objekt hast dann geht doch auch _MC_RESET um den Fehler zu quittieren.

  6. #4
    Registriert seit
    07.05.2013
    Beiträge
    41
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Tag,
    ihr habt natürlich Recht, 370 war von dem SLM, ich hab für die Geber das Telegramm 81.
    Ich hätte auch erwartet das mit MC_Reset die Fehler verschwinden. Tun sie aber nicht!
    Habe mir das auch nochmal angeschaut, die Geber dürfen für den MC_Reset nicht freigegeben sein, das sind sie aber auch nicht.
    Alle anderen Fehler verschwinden, nur die Geberfehler nicht... ich bin verwirrt...

  7. #5
    Registriert seit
    07.05.2013
    Beiträge
    41
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Meine Fehler in der Technology
    Technology Fehler.jpg


    Testhalber ein MC-Reset. Die DB-Nummer des TechObj vom Geber_Takt ist 11.
    Steuer ich nun den Merker M9.4 auf True dann kommt nen Done, die Fehler verschwinden aber nicht.
    Bausteinaufruf.jpg

    Irgendwo muss der Fehler doch bei mir liegen, das kann doch garnicht anders...

  8. #6
    Registriert seit
    16.03.2006
    Ort
    Franken
    Beiträge
    3.844
    Danke
    30
    Erhielt 942 Danke für 819 Beiträge

    Standard

    Hi,

    das sind Fehler auf der Protokollebene und keine Geberfehler.
    Da stimmt was mit der Projektierung und dem Datenaustausch zwischen Geber und TO nicht ganz.

    Verschwinden dann die Alarme wenn du im Alarmfenster auf quittieren klickst?

    Gruß
    Christoph

  9. #7
    Registriert seit
    07.05.2013
    Beiträge
    41
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Moin,

    ja die Fehler kann ich alle in der Technology selbst quittieren, die tauchen dann auch nicht mehr auf.
    Die Fehler kommen wieder wenn meine Steuerung mal in Stop geht, passiert halt mal beim programmieren (natürlich im Betrieb nicht mehr)

    Klar das das somit nur Fehler sind die im Betrieb eigentlich nie auftauchen, trotzdem müssen die doch quittierbar sein aus der Steuerung?

  10. #8
    Registriert seit
    16.03.2006
    Ort
    Franken
    Beiträge
    3.844
    Danke
    30
    Erhielt 942 Danke für 819 Beiträge

    Standard

    Hi,

    ja die sollten auch von der Steuerung quittierbar sein, auch mit dem MC_Reset.
    Die Fehler kommen bei allen Achsen/Gebern wenn Du die CPU in Stop schaltest, nur scheinbar werden sie beim Geber nicht automatisch quittiert.

    Du kannst mal folgenden Workaround probieren:
    In der Expertenliste des externen Gebers im Sinamics beim Parameter 2104 per BICO mit dem Parameter 2090.7 eines Antriebs verbinden.
    Dann werden die Alarms des Gebers zusätzlich über das Quittierbit des Antriebs zurückgesetzt.

    Per default wird beim Geber über den parameter 2103 quittiert, der sollte mir 2090.7 des Gebers vorbelegt sein und scheinbar wird da nix von der Steuerung übertragen.
    Du kannst ja mal tracen ob das bit 7 im parameter 2090 auf high geht wenn du den MC_reset auf den Geber machst.

    Gruß
    Christoph

  11. #9
    Registriert seit
    07.05.2013
    Beiträge
    41
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Jo,

    mit dem 2090.7 von einem Antrieb auf dem 2104 funktioniert so wie ich es erwartet habe.
    Gute Frage warum das nicht direkt mit dem MC_Reset funktioniert.
    Naja, die Geber müssen eh immer parallel zu dem entsprechenden Antrieb laufen, somit kann das nun erstmal so bleiben bis ich wieder Zeit für die Fehlersuche finde.

    Danke erstmal, hat mir gut geholfen

Ähnliche Themen

  1. TIA WinAC RTX-F Microbox 427D - Externer Fehler
    Von Pico1184 im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 29.12.2014, 22:24
  2. Step 7 PDIAG Fehler quittieren
    Von Oest im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 20.05.2014, 10:11
  3. Fehler quittieren
    Von settelma im Forum Simatic
    Antworten: 12
    Letzter Beitrag: 27.01.2013, 19:15
  4. 315T / S120 T4.1 mit Messtasterproblem
    Von NBerger im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 04.11.2010, 11:45
  5. 315T mit IM174 und externem Geber
    Von jabba im Forum Antriebstechnik
    Antworten: 6
    Letzter Beitrag: 14.08.2007, 11:11

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •