Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 7 von 7

Thema: S7-200 nachträgliches einbauen eines CP243-1 IT

  1. #1
    Registriert seit
    28.12.2006
    Ort
    München
    Beiträge
    18
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    ich möchte in eine bestehende S7-200-Konfiguration ein CP243-1 IT einbauen und bin dabei auf folgendes Problem gestossen.
    Die fragliche SPS verfügt über die Bausteine CPU224, EM223, EM235
    Laut Handbuch muss das CP243-1 IT (Firmware 1.0) an die Modulposition 0, also gleich rechts nach der CPU.


    An anderer Stelle im Systemhandbuch wir die Adressierung der einzelnen Moduler erläutert, also dass ein folgendes Modul in etwa beim nächsten freien Ein- oder Ausgangsblock startet. Wenn der vorangegange Baustein bis A1.7 kommt, startet der nächste bei A2.0.
    Das heisst, dass die vorangegangen Bausteine die Adressen der nachfolgenden definieren. Das würde bedeuten, wenn man ein zusätzliches Modul einfügt, dass sich dann die ganzen Adressen verschieben und ich das Programm entsprechend anpassen müsste.

    Gilt das jetzt auch die den CP2431- IT ? Immerhin verfügt der über 8 Ausgänge, wenn auch nur zur internen Anwendung.

    VG
    Norbert
    Zitieren Zitieren S7-200 nachträgliches einbauen eines CP243-1 IT  

  2. #2
    Registriert seit
    21.02.2014
    Ort
    Sachsen-Anhalt
    Beiträge
    1.095
    Danke
    156
    Erhielt 167 Danke für 154 Beiträge

    Standard

    Die Einbau Position ist abhängig von der FW-Version der S7-200-CPU.
    Ich habe jetzt noch kein CP243 verwendet, und fand beim Überfliegen des Handbuchs auch keinen Hinweis auf die Anzahl der Adressen, die vom CP belegt werden.
    Jedoch: Wenn Ausgangsadressen zur Kommunikation verwendet werden UND das Modul vor anderen plaziert wird, verschieben sich die Ausgangsadressen nachfolgender Module.
    Jedoch sollte eine ggf. erforderliche Programmänderung bei Deiner HW-Konfig via Suchen/Ersetzen recht schnell gehen.

    Die Adressen solltest Du über Information/Zielsystem in Step7Mikro herausbekommen.

  3. Folgender Benutzer sagt Danke zu weißnix_ für den nützlichen Beitrag:

    Norbert (05.07.2016)

  4. #3
    Registriert seit
    23.03.2006
    Ort
    Thüringen
    Beiträge
    1.969
    Danke
    159
    Erhielt 276 Danke für 197 Beiträge

  5. Folgender Benutzer sagt Danke zu mariob für den nützlichen Beitrag:

    Norbert (05.07.2016)

  6. #4
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    9.546
    Danke
    820
    Erhielt 2.819 Danke für 2.271 Beiträge

    Standard

    Adressänderungen im Programm: es genügt, bei Ansicht "Symbolische Adressierung" einfach in der Symboltabelle die neuen Adressen einzutragen.
    (wenn das Programm durchgehend Symbole verwendet und keine Adressberechnungen für indirekte Adressierung verwendet)

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  7. #5
    Norbert ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    28.12.2006
    Ort
    München
    Beiträge
    18
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Im CP-Handbuch steht dazu foglendes:

    S. 49, Kap 3

    Die Position in einem S7-200-System, auf der ein CP 243-1 IT betrieben werden
    kann, ist abhängig von der Firmware-Version der verwendeten S7-200-CPU.

    Mit einer Firmware-Version größer oder gleich 1.2 kann der CP 243-1 IT an jeder
    von 7 Positionen in einem S7-200-System eingesetzt werden. Mit einer Firmware-
    Version kleiner 1.2 muss der CP 243-1 IT in Position 0 eingesetzt werden, es sei
    denn, ein anderer intelligenter Modul besetzt die Position 0 – dann darf der CP
    243-1 IT auf Position 1 installiert werden.

    D.h. das Modul muss bei meiner Konfiguration auf jeden Fall zwischen rein.
    Ich kann leider nicht mehr sagen, wo ich das mit den belegten Adressen gelesen habe. Es sind sicher keine Aressen im Sinne eines I/O-Moduls, sondern eher interne Adressen über die die Kommunikaiton abgewickelt wird.

    Ich werde dem Tipp von weissnix_ mal nachgehen und sehen was die SPS-Info dazu sagt.

    Auf jeden Fall schon mal Danke für die schnellen Anworten!

  8. #6
    Registriert seit
    23.03.2006
    Ort
    Thüringen
    Beiträge
    1.969
    Danke
    159
    Erhielt 276 Danke für 197 Beiträge

    Standard

    Naja,
    und wo ist jetzt das Problem? Wenn Du das machst was Harald schreibt hast Du null Probleme. Modul an die zweite Position und vorher alle E/A Adressen symbolisch definieren. Dann auf symbolisch umschalten und in der Symboltabelle einfach alle betroffenen E/A ein Byte höher umschreiben. Fertsch und geht unabhängig von irgendwelchen Firmwareständen. Also reine Fleißarbeit.

    Gruß
    Mario

  9. #7
    Norbert ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    28.12.2006
    Ort
    München
    Beiträge
    18
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hi,

    also, hat funktioniert. Hab die paar Adressen von Hand umgeschrieben. Ging relatv schnell.
    Löst allerdings mein Problem nicht ganz, kann das Ding nicht parametrieren, mach dafür einen eigenen Thread auf.

    Danke für Eure Hilfe
    Norbert

Ähnliche Themen

  1. S7-200 + CP243-1 Ethernet Modul
    Von nUgg3t im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 06.06.2012, 10:24
  2. S7-200 CP243-1 it
    Von Wilhelm im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 25.08.2010, 09:25
  3. S-200 CP243-1 it
    Von Wilhelm im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 21.08.2010, 21:20
  4. Webanbindung S7-200 und CP243-IT
    Von Xilukarim im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 12.11.2008, 20:34
  5. S7-200 und CP243-1 IT
    Von Unreal im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 28.11.2007, 20:03

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •