Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 4 von 4

Thema: S7-1500 in Step7 - Netpro einbinden?

  1. #1
    Registriert seit
    23.04.2008
    Beiträge
    75
    Danke
    16
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    In einem Step 7 Projekt (V5.5) brauche ich Daten von einer S7-1500 über Ethernet.

    In der Netzwerkprojektierung (NetPro) kann man aber nur 300er und 400er Stationen wählen. Gibt es da eine Art Update oder funktioniert die Kommunikation (Put/Get) auch, wenn man eine x-beliebige 300er CPU mit PN Schnittstelle einträgt?
    Nieder mit der Schwerkraft. Freien Fall für freie Bürger !
    Zitieren Zitieren S7-1500 in Step7 - Netpro einbinden?  

  2. #2
    Registriert seit
    07.06.2006
    Ort
    Bayern
    Beiträge
    623
    Danke
    27
    Erhielt 156 Danke für 139 Beiträge

    Standard

    Das sollte mit einer unspezifizierten S7-Verbindung möglich sein.
    Einfach die IP-Adresse der 1500er angeben und Rack 0 sowie Steckplatz 1.
    Die Put/Get Kommunikation muss aber in der 1500er freigegeben sein (Haken in den CPU-Einstellungen) - ist standardmäßig deaktiviert.

    Evtl. hilft dieser Thread weiter:
    Verbindung S7 1500 zu S7 300

  3. Folgender Benutzer sagt Danke zu uncle_tom für den nützlichen Beitrag:

    Machtnix (15.06.2016)

  4. #3
    Registriert seit
    22.11.2006
    Ort
    CH
    Beiträge
    3.620
    Danke
    777
    Erhielt 647 Danke für 493 Beiträge

    Standard

    Die Verbindung muss unspezifiziert angelegt werden. Du ziehst also nicht wirklich eine Station rein.
    Wenn PUT/GET auf die 1500er angewendet werden soll, dann muss auf dieser PUT/GET in der Hardware erlaubt werden.

    BSEND/BRECV und Konsorten funktioniert ebenfalls. Dann muss auf der 1500er ebenfalls ein unspezifizierter Partner angelegt werden. Und die Verbindungen sowohl in Netpro wie auch im Verbindungsmanager von TIA entsprechend angelegt werden.

    Bei Step7 wenn du ein älteres Projekt verwendest. Unbedingt aktuelle BSEND/RECV AGSEND/RECV laden (vorhandene ersetzen). Und die vorhandenen Verbindungen damit testen.
    Ich habe schon stundenlang geübt bis ich eine AGSEND Version 1.11 gegen 4.2 ersetzt hatte. Und es endlich funktionierte (hab unbedachterweise einfach den CP ersetzt).


    mfG René
    Geändert von vollmi (14.06.2016 um 22:39 Uhr)

  5. Folgender Benutzer sagt Danke zu vollmi für den nützlichen Beitrag:

    Machtnix (15.06.2016)

  6. #4
    Registriert seit
    23.07.2009
    Ort
    Österreich
    Beiträge
    2.351
    Danke
    452
    Erhielt 692 Danke für 517 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Womöglich muss man noch die Subnetz-IDs der beiden PN-Stränge in den Projekten angleichen.
    If at first you don't succeed, you're not Van Damme!
    ... or maybe using TIA!

Ähnliche Themen

  1. TIA S7-1500 RT Kommunikation mit zweiter S7-1500
    Von HelixX23 im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 19.02.2016, 14:46
  2. Antworten: 6
    Letzter Beitrag: 07.07.2015, 09:10
  3. Antworten: 3
    Letzter Beitrag: 03.08.2012, 21:30
  4. PG/PC in NetPro einrichten?
    Von baalrok im Forum Feldbusse
    Antworten: 4
    Letzter Beitrag: 30.08.2008, 22:15
  5. Siwarex M in Step7 einbinden
    Von buffi4711 im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 05.03.2006, 12:48

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •