Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 2 ErsteErste 12
Ergebnis 11 bis 20 von 20

Thema: OB21 Und Merker setzen

  1. #11
    Registriert seit
    27.10.2005
    Ort
    Schwäbisch Gmünd
    Beiträge
    5.224
    Danke
    630
    Erhielt 955 Danke für 769 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von argv_user
    Mag sein, aber ich denke der SPS-Programmierer hat das absichtlich so gemacht.
    Bestimmt gibt es irgendwo einen Taster wo AUTOMATIK draufsteht.
    Aber auch Handbetrieb ist die SPS doch im Run, oder?
    Rainer Hönle
    DELTA LOGIC GmbH

    Ein Computer kann das menschliche Gehirn nicht ersetzen. Engstirnigkeit kann unmöglich simuliert werden. (Gerd W. Heyse)

  2. #12
    Registriert seit
    28.10.2005
    Ort
    Ottweiler, Saar
    Beiträge
    940
    Danke
    259
    Erhielt 124 Danke für 109 Beiträge

    Standard

    Ich meinte nur dass es nicht immer erwünscht ist, dass nach dem Einschalten alles automatisch in die Hose geht.

    Wenn sich kein extra Automatik-Taster findet steht sogar sehr zu vermuten, dass er in den RUN-STOP-Schalter verlagert wurde.
    Geändert von argv_user (08.06.2006 um 16:47 Uhr)

  3. #13
    Registriert seit
    12.10.2005
    Beiträge
    93
    Danke
    0
    Erhielt 5 Danke für 5 Beiträge

    Standard

    Also das Ding ist so der Merker wird nur im OB21 gesetzt nirgendswo anders im Programm. Und auch nicht mit Automatik sondern einfach nur mit der Anweisung:
    UN M 125.0
    S M125.0

    Das nächste Problem ist das ich die SPS nicht so ohne weiteres von Run in Stop nehmen kann, Produktionsausfall etc. pp.
    Ich habe meinen Kollegen noch mal gefragt also die haben die SPS nach dem Stromausfall definitiv in STOP und dann auf RUN gesetzt. Nur warum sich dabei der Merker nicht gesetzt hat bleibt mir einfach Schleierhaft. Allerdings einem anderem Kollegen auch.
    Leider kann ich den Programmierer nicht mehr nach der Sinnhaftigkeit fragen da es ihn bzw. die Firma nicht mehr gibt.

    Naja also diese Automatik funktion wird allerdings immer benötigt zwar nur zum Ende der Charge damit die Ventile öffnen und die Kiste das Produkt in die Pufferpresse drückt.
    Geändert von Falcon4 (08.06.2006 um 18:42 Uhr)

  4. #14
    Registriert seit
    28.10.2005
    Ort
    Ottweiler, Saar
    Beiträge
    940
    Danke
    259
    Erhielt 124 Danke für 109 Beiträge

    Standard

    Willst Du das jetzt nach jedem Stromausfall so machen ?
    Sicherlich nicht.


    Dann empfiehlt es sich vielleicht, die zwei Anweisungen in den OB1 zu kopieren.
    Damit umschiffst Du auch Irrtümer der Bediener, die Ein/Aus mit Stop/Run verwechseln.
    Sei gnädig mit mir, wenn es nicht so ist.

  5. #15
    Registriert seit
    20.06.2003
    Ort
    Sauerland.NRW.Deutschland
    Beiträge
    4.850
    Danke
    78
    Erhielt 800 Danke für 543 Beiträge

    Standard

    also für mich ist so eine funktion die mit dem hochlauf quasi die automatik startet ehr gefährlich.
    vorbelegungen im anlauf-ob sollten ehr dazu dienen einen sicheren zustand der anlage herbeizuführen oder diverse initialisierungen von speziellen baugruppen einzuleiten etc.

    ich sehe da mal grob 2 möglichkeiten.
    1. du entfernst den merker komplett aus dem programm.
    2. du setzt den merker mit dem taster 'automatik start' und setzt diesen mit 'automatik stop' wieder zurück.
    .
    mfg Volker .......... .. alles wird gut ..

    =>Meine Homepage .. direkt zum Download

    Meine Definition von TIA: Total Inakzeptable Applikation

  6. #16
    Registriert seit
    12.10.2005
    Beiträge
    93
    Danke
    0
    Erhielt 5 Danke für 5 Beiträge

    Standard

    Halt Stop der Merker setzt nicht wirklich die Automatik in Gang , da hab ich mich wohl gestern etwas schlecht ausgedrückt.
    Er ist eine von 5 BEdingungen die gesetzt sein muss damit dann das Rüberdrücken im Automatik betrieb auch automatisch läuft. Mit der BEdingung wird nur indirekt die Automatik funktion funktionstüchtig gemacht, denn ohne die Bedingung konnte ein Ventil nicht geöffnet werden und die Inis von dem Ventil sind dann eine Weiterschaltbedingung.......
    Die Automatik anwahl geschieht in den Undurchsichtigen Tiefen des Programms.

  7. #17
    Registriert seit
    06.10.2003
    Beiträge
    3.405
    Danke
    447
    Erhielt 502 Danke für 406 Beiträge

    Standard

    Hallo,

    wahrscheinlich stellt der Merker ganz einfach nur ein VKE=1 zur Verfügung. Die Bildung eines solchen Merkers ist nicht nur in S5-Programmen allgemein üblich.


    Gruß, Onkel
    Es gibt viel mehr Leute, die freiwillig aufgeben, als solche, die echt scheitern.
    Henry Ford

  8. #18
    Registriert seit
    20.06.2003
    Ort
    Sauerland.NRW.Deutschland
    Beiträge
    4.850
    Danke
    78
    Erhielt 800 Danke für 543 Beiträge

    Standard

    ein vke=1 bzw vke=0 generiere ich grundsätzlich am anfang des ob1
    das im anlauf ob zu machen halte ich für nicht 100% sicher.

    ich würde den m125.0 in diesem fall im kompletten programm entfernen.
    .
    mfg Volker .......... .. alles wird gut ..

    =>Meine Homepage .. direkt zum Download

    Meine Definition von TIA: Total Inakzeptable Applikation

  9. #19
    Registriert seit
    27.10.2005
    Ort
    Schwäbisch Gmünd
    Beiträge
    5.224
    Danke
    630
    Erhielt 955 Danke für 769 Beiträge

    Standard

    Zitat Zitat von volker
    ein vke=1 bzw vke=0 generiere ich grundsätzlich am anfang des ob1
    das im anlauf ob zu machen halte ich für nicht 100% sicher.

    ich würde den m125.0 in diesem fall im kompletten programm entfernen.
    Da stimme ich zu. Wenn ein Operand mit einem festen Wert initialisiert und sonst nur abgefragt wird, ist das Ganze für die normale Bearbeitung eigentlich nicht relevant. Kann vielleicht von verschiedenen Optionen einer Anlage kommen, die im konkreten Fall nicht vorhanden sind bzw. nur geplant waren.
    Rainer Hönle
    DELTA LOGIC GmbH

    Ein Computer kann das menschliche Gehirn nicht ersetzen. Engstirnigkeit kann unmöglich simuliert werden. (Gerd W. Heyse)

  10. #20
    Registriert seit
    12.10.2005
    Beiträge
    93
    Danke
    0
    Erhielt 5 Danke für 5 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Leider habe ich in meiner Firma nicht die Zeit dieses Programm mal manierlich schritt für schritt durchzuarbeiten um mal wirklich zu sehen warum der Merker dort und nicht woanders gesetzt wird. Auf jedenfall läuft die Anlage jetzt seit 24 Chargen und 24h zufriedenstellend und einwandfrei durch. Das der Merker nachträglich gesetzt wurde scheint keine weiteren Auswirkungen als die Beabsichtigte WIrkung verursacht zu haben. Ich finde das setzen gerade an dieser Stelle recht unsinnig! Aber naja gut ...........................
    Vielleicht gibt es aber in Österreich ja auch einen anderen Programmier- standard da kommt nämlich die Kiste her.

Ähnliche Themen

  1. Antworten: 6
    Letzter Beitrag: 19.04.2009, 12:52
  2. S7-200 CPU 224 - Merker setzen, geht nicht
    Von elektrofuchs2 im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 24.03.2009, 10:01
  3. bei SPS Stop merker setzen, wie?
    Von thorsten im Forum Simatic
    Antworten: 25
    Letzter Beitrag: 16.01.2008, 08:40
  4. Merker setzen, wenn CPU in RUN!
    Von KartoffeL im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 30.11.2006, 09:40
  5. Step 7 Merker & Ausgänge auf 0 setzen
    Von webinspirit im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 22.09.2005, 17:12

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •