Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 20

Thema: OB21 Und Merker setzen

  1. #1
    Registriert seit
    12.10.2005
    Beiträge
    93
    Danke
    0
    Erhielt 5 Danke für 5 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hi bei uns ist eine S5 135U eingesetzt.
    Nun habe ich folgendes Problem das nach einem Stromausfall eine automatik funktion net mehr funktioniert. Was mich allerdings wundert ist eine Bedingung die im OB21 gesetzt wird und zwar wie folgt:
    UN M125.0
    S M125.0
    So nun sagt mir meine schlaue Test funktion im PG der Baustein wird nicht bearbeitet.
    Was mich allerdings wundert ist das der OB21 ja wohl ein Anlaufbaustein ist, und der Merker zum ende jeder Charge benötigt wird.
    Kann mir einer helfen??
    Zitieren Zitieren OB21 Und Merker setzen  

  2. #2
    Registriert seit
    20.06.2003
    Ort
    Sauerland.NRW.Deutschland
    Beiträge
    4.850
    Danke
    78
    Erhielt 800 Danke für 543 Beiträge

    Standard

    genau das ist ein anlauf-ob der nur 1 mal bearbeitet wird. eben beim hochlauf der cpu.

    der merker wird evtl dort gesetzt, damit dein programm eine definierte vorbelegung hat wenn der ob1 die organisation übernimmt.
    ab da wird der m125.0 durch den normalen programmablauf bestimmt.
    .
    mfg Volker .......... .. alles wird gut ..

    =>Meine Homepage .. direkt zum Download

    Meine Definition von TIA: Total Inakzeptable Applikation

  3. #3
    Registriert seit
    12.10.2005
    Beiträge
    93
    Danke
    0
    Erhielt 5 Danke für 5 Beiträge

    Standard

    Hm nur mein Problem ist das der Merker ja leider nicht mehr gesetzt wird.
    Und der Programmablauf ja eigentlich sagt wenn der Merker 0 ist soll er ja 1 gesetzt werden.
    UN M125.0
    S M125.0
    oder sehe ich das so falsch??

  4. #4
    Registriert seit
    28.10.2005
    Ort
    Ottweiler, Saar
    Beiträge
    940
    Danke
    259
    Erhielt 124 Danke für 109 Beiträge

    Standard

    a)
    Wenn der Merker schon gesetzt ist, braucht er nicht gesetzt zu werden.

    b)
    Behandlung von Anlaufverhalten (aus dem 100U Handbuch)
    OB21: bei STOP --> RUN
    OB22: bei Spannungswiederkehr

    Du könntest also auf die Idee kommen nachzuschauen, was in Deinem OB22 steht, da Du ja von Stromausfall geschrieben hast.

    Beste Grüße.

  5. #5
    Registriert seit
    12.10.2005
    Beiträge
    93
    Danke
    0
    Erhielt 5 Danke für 5 Beiträge

    Standard

    Ja werde ich morgen mal drangehen.
    Erstmal Danke an euch beide.
    Vielleicht werd ich dann morgen noch mal "nerven"

  6. #6
    Registriert seit
    20.06.2003
    Ort
    Sauerland.NRW.Deutschland
    Beiträge
    4.850
    Danke
    78
    Erhielt 800 Danke für 543 Beiträge

    Standard

    sollte der merker im normalen programm nicht verwendet/gesetzt werden, dann kannst du davon ausgehen, dass der merker immer gesetzt ist.
    .
    mfg Volker .......... .. alles wird gut ..

    =>Meine Homepage .. direkt zum Download

    Meine Definition von TIA: Total Inakzeptable Applikation

  7. #7
    Registriert seit
    12.10.2005
    Beiträge
    93
    Danke
    0
    Erhielt 5 Danke für 5 Beiträge

    Standard

    So habe mein Problem gelöst habe den Merker nach abwägung aller für und wieder mit steuern variablen gesetzt.Nun läuft die Automatikkette wieder ganz normal.
    Das einzige was mich echt wundert ist das der Merker beim Anlauf/Neustart nicht gesetzt wurde. Naja ist halt ne SPS..................................
    Danke allen.

  8. #8
    Registriert seit
    27.10.2005
    Ort
    Schwäbisch Gmünd
    Beiträge
    5.224
    Danke
    630
    Erhielt 955 Danke für 769 Beiträge

    Standard

    Kann das vielleicht daran liegen, dass bei der 135er der OB 22 bei Spannungswiederkehr aufgerufen wird und nicht der OB 21? Der OB 21 wird bei manuellem Wiederanlauf und der OB 20 bei Neustart aufgerufen. Siehe Berger "Automatisieren mit SINATIC S5-135U" Seite 203.
    Rainer Hönle
    DELTA LOGIC GmbH

    Ein Computer kann das menschliche Gehirn nicht ersetzen. Engstirnigkeit kann unmöglich simuliert werden. (Gerd W. Heyse)

  9. #9
    Registriert seit
    30.03.2005
    Beiträge
    2.096
    Danke
    0
    Erhielt 673 Danke für 541 Beiträge

    Standard

    Zitat Zitat von Falcon4
    Das einzige was mich echt wundert ist das der Merker beim Anlauf/Neustart nicht gesetzt wurde.
    Noch einmal zur Erinnerung:

    Du hattest einen Spannungsausfall. Nach dem Wiederkehren der Spannung läuft die SPS automatisch wieder an und es wird nur der OB22 abgearbeitet, nicht aber der OB21.

    Der OB21 wird nur abgearbeitet, wenn der Betriebsartenwahlschalter der SPS von STOP nach RUN geschaltet wird, die SPS also von Hand neu gestartet wird. Dann wird aber nur der OB21 abgearbeitet und nicht der OB22.

    In Deinem Fall wurde also der OB22 abgearbeitet und nicht der OB21. Du müsstest also nachsehen, ob der Merker M125.0 auch im OB22 gesetzt wird.

    Gruß Kai

  10. #10
    Registriert seit
    28.10.2005
    Ort
    Ottweiler, Saar
    Beiträge
    940
    Danke
    259
    Erhielt 124 Danke für 109 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Mag sein, aber ich denke der SPS-Programmierer hat das absichtlich so gemacht.
    Bestimmt gibt es irgendwo einen Taster wo AUTOMATIK draufsteht.

Ähnliche Themen

  1. Antworten: 6
    Letzter Beitrag: 19.04.2009, 12:52
  2. S7-200 CPU 224 - Merker setzen, geht nicht
    Von elektrofuchs2 im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 24.03.2009, 10:01
  3. bei SPS Stop merker setzen, wie?
    Von thorsten im Forum Simatic
    Antworten: 25
    Letzter Beitrag: 16.01.2008, 08:40
  4. Merker setzen, wenn CPU in RUN!
    Von KartoffeL im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 30.11.2006, 09:40
  5. Step 7 Merker & Ausgänge auf 0 setzen
    Von webinspirit im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 22.09.2005, 17:12

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •