Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 4 von 4

Thema: Hardware Config CPU314 IFM OK, IOs in Störung

  1. #1
    Registriert seit
    22.10.2007
    Beiträge
    5
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    aufgrund eines Hardwaredefektes (Analoge IOs auf der CPU werden nicht gelesen) musste ich eine CPU314 IFM gegen einen leicht anderen Typ tauschen.

    Nach der Änderungen (Hardware Config angepasst, übersetzt und übertragen) habe ich das Problem, dass die CPU zwar alles OK anzeigt, ich aber nach ein- zweimal Online gehen,
    alle angehängten Karten als fehlerhaft angezeigt werden.

    Fehler bei allen Karten:
    Baugruppe nicht verfügbar (Peripheriezugriffs oder Parameterfehler)

    Die Anlage scheint fehlerfrei zu laufen. Eingänge werden korrekt eingelesen und Ausgänge geschrieben, so wie es soll.
    An der CPU wird auch kein Fehler angezeigt, ist in RUN.

    Ich sehe den Fehler nur in der Hardware Config.

    Die Bereiche für Merker, Ein-Ausgänge, Zeiten, Zähler sind in Ordnung.

    Ich habe auch versucht die überwachungszeiten für die Parametrierung und das Erkennen der IOs zu erhöhen, ohne Erfolg (Erkennung stand bereits auf max 650ms).

    Da ich alle Karten kurz lösen und neu einstecken müsste beim Austausch, (wir hatten eine externe Analogklemme verbaut um den Fehler kurzfristig zu umgehen) habe ich alle Karten nochmal
    gelöst und neu eingesteckt, alle Pins waren OK.

    Die erste Karte hinter der CPU habe ich noch getauscht, da einer der oberen Halter angeknackst war. Beide Busverbindungen dieser Karte ebenfalls. (Ohne Erkennbaren defekt, mir gehen nur die Ideen aus).

    Wäre für jeden Tip dankbar.

    Wobei ich einen Defekt an der neuen CPU vermute....

    Gruss Stefan
    Angehängte Grafiken Angehängte Grafiken
    Zitieren Zitieren Hardware Config CPU314 IFM OK, IOs in Störung  

  2. #2
    Katzengesicht ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    22.10.2007
    Beiträge
    5
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    WIr haben die CPU getauscht, nachdem der Fehler mit jeder beliebiger Karte am Bus der CPU aufgetreten ist.

    Urlöschen funktionierte auch nicht, egal welche Variante.

    Programm konnte mit Urlöschen auch nicht gelöscht werden.

    Gruss Stefan

  3. #3
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    10.083
    Danke
    838
    Erhielt 2.969 Danke für 2.393 Beiträge

    Standard

    Zitat Zitat von Katzengesicht Beitrag anzeigen
    musste ich eine CPU314 IFM gegen einen leicht anderen Typ tauschen.
    Hallo Stefan,

    was ist ein "leicht anderer Typ"?
    Welche Bestellnummer hatte die CPU vorher (6ES7 314-5AE10 ?), welche hat die jetzige CPU (6ES7 314-5AE02 ?) Dein Bild zeigt, daß nun anscheinend die 314-5AE02 projektiert ist?


    Zitat Zitat von Katzengesicht Beitrag anzeigen
    Urlöschen funktionierte auch nicht, egal welche Variante.

    Programm konnte mit Urlöschen auch nicht gelöscht werden.
    Urlöschen löscht nicht das Programm, es löscht nur den Arbeitsspeicher und lädt danach das im Ladespeicher vorhandene Programm in den Arbeitsspeicher. Was heißt "Urlöschen funktionierte nicht"? Was hast Du erwartet, was Urlöschen tun würde? Was für verschiedene "Varianten" Urlöschen meinst Du?

    Kann es sein, daß Du nun eine gebrauchte 314IFM ohne Schacht für Memory Card hast (314-5AE0.) und auf der CPU noch ein Programm im integrierten Ladespeicher ist?
    Das vorhandene Programm löschen und das neue Programm urlöschfest in den Ladespeicher kopieren macht man mit RAM-nach-ROM-kopieren.

    Handbücher und Hinweise zum speziellen Handling der CPU 314 IFM

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  4. #4
    Katzengesicht ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    22.10.2007
    Beiträge
    5
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    danke für die Hilfe.

    Mit verschiedenen Varianten, meinte ich die Standart Variante über Software und die Variante:

    Spannung aus-> MRES->Einschalten.... usw. um die CPU in den Auslieferzustand zu setzen.

    Oder betrifft das nicht Programm?

    Es waren beides CPUs ohne Memory Card.

    Ursprung:
    314-5AE03-0AB0 Problem : es werden Analogwerte an den CPU Eingängen nicht gelesen, bzw Ausgänge teilweise nicht geschrieben, obwohl
    die Spannung (0-10V) am Eingang, bzw. der Wert im Programm für den Ausgang in Ordnung waren.
    Spannung aus/ein für einige male , dann klappt es wieder. Fehler tritt alle paar Tage auf.

    Zwischendurch:
    314-5AE02-0AB0
    Alle Karten am Ausgang gestört- Fehler siehe oben.

    Gruss Stefan

Ähnliche Themen

  1. Wer kann s7-300 cpu314 ifm reparieren??
    Von Lars123 im Forum Suche - Biete
    Antworten: 10
    Letzter Beitrag: 31.08.2012, 12:17
  2. Maximale Anzahl Merker CPU314 IFM
    Von hank12 im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 08.11.2011, 09:17
  3. Problem CPU314 IFM mit SM322
    Von eXistenz im Forum Simatic
    Antworten: 11
    Letzter Beitrag: 08.01.2008, 16:24
  4. CPU314 IFM MPI-Schnittstelle defekt
    Von Stephan22 im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 30.07.2007, 09:03
  5. Verhalten von CPU314-IFM bei Spannungseinbruch
    Von Anonymous im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 29.10.2005, 18:41

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •