Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 7 von 7

Thema: DP Fehlerdiagnose mit OB86 ????

  1. #1
    Elektriktribbi Gast

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo hab da ein Problem das ich selbst nicht knacken kann hoffe ihr könnt mir helfen!

    Also ich habe eine 315-2DP CPU als Master an der 10 DP-Slaves über Profibus angeschlossen sind. Ich lese im Störfall eines Slaves mit dem OB86 die Profibus und Diagnoseadresse des betroffenen Slaves aus. Das klappt auch alles ganz gut.
    Problem:
    Es sind z.b 3 Slaves ausgefallen und einer von denen geht wieder in Betrieb.
    zeigt der OB86 als Eventclass eine Stationswiederkehr mit den dazugehörigen Adressen an. Ist ja auch ok aber dummer weise krieg ich jetzt keine Info mehr über die Adressen der beiden fehlenden Slaves mehr. Erst wenn ich die CPU neustarte und sie die 2 fehlenden Slaves bemerkt zeigt mir der OB86 wieder eine
    Adresse eines fehlenden Slaves an. Kennt da jemand was wie ich den Neustart umgehen kann ? Oder gar ne ganz andern Weg zur Fehlerdiagnose ? Mir sind eigentlich nur Diagadresse und PBadresse der fehlenden Slaves wichtig.
    Hoffentlich hab ich einigermaße Verständlich erklärt.
    Danke
    Zitieren Zitieren Gelöst: DP Fehlerdiagnose mit OB86 ????  

  2. "
    Zitat Zitat von Unregistriert_xyz
    nach dem anlauf der cpu meldet ein (immer noch) gestörter busteilnehmer
    "FEHLER", d.h. das kommende ereignis wird erneut abgefeuert...
    Bei "Exoten-Slaves" diverser Hersteller habe ich da leider schon andere Erfahrung gemacht. Die melden sich alle unterschiedlich nach Anlauf der CPU. Es sah so aus, als wenn der OB86 manchmal vor und manchmal nach dem OB100-Aufruf kommt. Könnt Ihr das bestätigen?

    Gruß
    ~MAIK~"


  3. #2
    Registriert seit
    17.09.2003
    Ort
    Zell bei Dietfurt a.d. Altmühl
    Beiträge
    357
    Danke
    8
    Erhielt 27 Danke für 25 Beiträge

    Standard

    Hallo.

    Ich würde dir mal die beiden Diagnossebausteine von Siemens empfehlen. Einmal den FC125 (nur eine Fehlerdiagnosse welcher Slave gestört ist). Oder den FB125 (mit ihm ist auch eine genauere Fehlerdiagnosse des gestörten Slaves möglich). Beide Bausteine sind von Siemens kostenlos zu haben. Suche einfach bei Siemens nach "FC125" bzw. "FB125". Habe den FC125 schon bei einer Anlage mit 30 Slaves eingesetzt und er funktionierte tadellos. Solltest du noch fragen haben, so melde dich einfach ich kann dir gerne auch ein Beispielprojekt schicken.
    MfG

    Hubert

    \"Never change a running system. \"

  4. #3
    Registriert seit
    15.11.2005
    Beiträge
    89
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    habe das bisher so gemacht:

    das kommende ereignis (ich glaube Eventklasse B#16#3 verglichen mit
    der Diagnoseadresse eines Teilnehmers setzt mir einen Hilsmerker
    für diesen Slave (XYZ_BUS_ERROR). Tritt nun an mehreren Slaves ein Fehler auf, habe ich dementsprechend verschiedene Hilfsmerker gesetzt bekommen.

    Das gehende Störungsereignis (glaube B#16#39) verglichen mit der Diagnoseadresse setzt den Stör-Hilfsmerker des Slaves zurück.

    Im OB100 habe ich diese Hilsmerker zwingend gelöscht.

    AUf diese Weise konnte eine einfache Bus-Diagnose erfolgen.

    Klar, deutlich aussagekräftiger und komfortabler sind die von Siemens bereitgestellten Funktionen zur Bus-Diagnose (gibt's auch HMI-Bilder dazu).

    Schönen Abend,
    _________________________________________
    Solls funktionieren, oder darfs auch Siemens sein?

  5. #4
    ~MAIK~ Gast

    Ausrufezeichen

    Zitat Zitat von nairolf
    Im OB100 habe ich diese Hilsmerker zwingend gelöscht.
    Dann wird aber ein Slave, der dauerhaft gestört ist, nach Starten der CPU als "ok" gemeldet, oder? Dies wäre für den Operator irreführend...

    Gruß
    ~MAIK~
    Zitieren Zitieren Irreführend ?  

  6. #5
    Unregistriert_xyz Gast

    Standard

    nach dem anlauf der cpu meldet ein (immer noch) gestörter busteilnehmer
    "FEHLER", d.h. das kommende ereignis wird erneut abgefeuert...

  7. #6
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.218
    Danke
    533
    Erhielt 2.696 Danke für 1.948 Beiträge

    Standard

    Nimm den FC/FB125, die sind gut zu handeln und funktionieren sehr gut.

    PS: Vom Downloadbereich meine Homepage kannst du die ZIP laden.

    http://www.sps-prog.de/Download/download.html
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  8. #7
    ~MAIK~ Gast

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von Unregistriert_xyz
    nach dem anlauf der cpu meldet ein (immer noch) gestörter busteilnehmer
    "FEHLER", d.h. das kommende ereignis wird erneut abgefeuert...
    Bei "Exoten-Slaves" diverser Hersteller habe ich da leider schon andere Erfahrung gemacht. Die melden sich alle unterschiedlich nach Anlauf der CPU. Es sah so aus, als wenn der OB86 manchmal vor und manchmal nach dem OB100-Aufruf kommt. Könnt Ihr das bestätigen?

    Gruß
    ~MAIK~
    Zitieren Zitieren Immer?  

Ähnliche Themen

  1. Transline Fehlerdiagnose
    Von Zippel im Forum HMI
    Antworten: 0
    Letzter Beitrag: 24.11.2010, 11:00
  2. WinCC Fehlerdiagnose
    Von tomatschek im Forum HMI
    Antworten: 2
    Letzter Beitrag: 11.02.2010, 12:19
  3. Fehlerdiagnose SafetyBus
    Von ElRackadusch im Forum Feldbusse
    Antworten: 0
    Letzter Beitrag: 04.12.2007, 14:33
  4. Fehlerdiagnose Profibus mit dem PBT-3
    Von olitheis im Forum Simatic
    Antworten: 9
    Letzter Beitrag: 15.08.2007, 09:24
  5. Fehlerdiagnose bei CPU 315 2-DP?
    Von olitheis im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 26.05.2007, 09:40

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •