Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 4 von 4

Thema: S7 CPU 314 C-2 PN/DP Pfrogramm läuft nicht mehr

  1. #1
    Registriert seit
    12.07.2016
    Beiträge
    12
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    ich habe ein Problem. Bei einer Siemens Simatic 300 Station wurde die CPU getauscht. Es wurde eine CPU 314 C-2 PN/DP installiert. Vorher war eine CPU 314 installiert.
    Jetzt läuft ein Programm, was mit der alten CPU einwandfrei lief, nicht mehr. Beim Starten der Station leuchtet die rote SF LED der CPU auf und es passiert nichts mehr.
    Dabei steht SF für Sammelfehler

    Geht man in den Diagnosepuffer der CPU erhält man folgende letzte Meldungen.
    Betriebszustandsübergang von Anlauf nach RUN

    Bereichslängenfehler beim Lesen

    Stop durch Programmierfehler ( O.B. nicht geladen oder nicht möglich bzw, kein FRB vorhanden.

    Die Details zur zweiten Meldung sind:

    Ursachen:
    · Der durch die Zugriffsadresse adressierte Wert liegt außerhalb oder nicht vollständig innerhalb des zulässigen Operandenbereiches (CPU-spezifische Größe).

    · Durch eine fehlerhafte Adressberechnung ist der adressierte Wert > 65535. Bei indirekter Adressierung kann durch fehlerhafte Berechnung ein Adresswert größer 65535 auftreten. Dieser Wert ist in der Detailinformation des Ereignisses nicht mehr korrekt eintragbar. Als Zugriffsadresse wird dann bei S7-300 eine 0 und bei S7-400 der berechnete Wert modulo 65535 eingetragen und angezeigt

    Behebung:

    · Wählen Sie die Zugriffsadresse so, dass der adressierte Wert vollständig im jeweils zulässigen Operandenbereich liegt.

    · Überprüfen Sie Ihr Anwenderprogramm.

    Die Details zur dritten Meldung sind:
    Ursache:
    Es ist ein Programmierfehler aufgetreten, der zugehörige OB (OB121) oder FRB ist jedoch nicht geladen bzw. aktiviert.

    Behebung:
    Laden Sie einen OB121 oder aktivieren Sie einen FRB, um den Programmierfehler zu bearbeiten, oder vermeiden Sie dessen Auftreten.

    FRB = Function Request Block; betrifft M7

    Wie bereits erwähnt, handelt es sich um ein Programm, was mit der alten CPU einwandfrei lief.
    Es ist mir noch aufgefallen, dass das Programm läuft, sobald man in dem FB1 alle Alternativen Verzweigungen hinausnimmt. Das ist natürlich für den echten Betrieb nicht durchführbar.

    Vielleicht kann mir jemand sagen, wodurch die Meldungen verursacht werden und was ich tun muss, um das Problem zu beheben.

    Ich bin für jeden Hinweis im Voraus dankbar.

    Mit freundlichen Grüßen

    Johannes.

    Screenshots Diagnosepuffer
    Screenshots_Diagnosepuffer.pdf
    Zitieren Zitieren S7 CPU 314 C-2 PN/DP Pfrogramm läuft nicht mehr  

  2. #2
    Registriert seit
    08.02.2007
    Ort
    A-2320
    Beiträge
    2.251
    Danke
    244
    Erhielt 332 Danke für 303 Beiträge

    Standard

    Steht da nicht dort in welchem Baustein der Bereichslängenfehler entstanden ist?

    Edit:
    Im Screenshot steht es eh.... na drück mal auf "Gehe zu" in der Zeile Nr.1. (FC70)
    Geändert von borromeus (27.07.2016 um 16:29 Uhr)

  3. #3
    Registriert seit
    27.07.2007
    Beiträge
    223
    Danke
    17
    Erhielt 42 Danke für 40 Beiträge

    Standard

    Im Programm wird von einer DB Adresse gelesen, die es auf der CPU nicht gibt. Laut Fehlerspeicher Wortzugriff im Instanz-DB auf DW1044.
    Schau mal im Baugruppenzustand die Stacks an. Dort wird der Baustein in dem der Fehler auftritt und die offenen DB angezeigt.

  4. #4
    Registriert seit
    06.01.2005
    Ort
    im schönen Lipperland
    Beiträge
    4.446
    Danke
    493
    Erhielt 1.140 Danke für 734 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Woher habt ihr das Programm das ihr in die neue CPU geladen habt ? Vor dem Laden ein On-Offlinevergleich gemacht ?
    Vielleicht ist das Leben ja ein Integer. Wenn man negativ genug denkt, wird's irgendwann positiv.

Ähnliche Themen

  1. Step5 läuft nach XP-Update nicht mehr
    Von rile im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 09.10.2012, 23:16
  2. S5-CPU103 läuft nicht mehr...
    Von Jörg_24 im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 19.07.2008, 18:59
  3. Step5 läuft nicht mehr! Warum?
    Von Tobbi18 im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 25.01.2008, 22:46
  4. MM440 läuft nicht mehr an, bitte um Hilfe
    Von TH5 im Forum Antriebstechnik
    Antworten: 7
    Letzter Beitrag: 29.06.2006, 20:27
  5. WinnCC Projekt läuft nicht mehr
    Von frenzel im Forum HMI
    Antworten: 5
    Letzter Beitrag: 27.02.2006, 14:01

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •