Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 6 von 6

Thema: TIA: TRCV Baustein Status 80C3

  1. #1
    Registriert seit
    18.09.2004
    Ort
    Münsterland/NRW
    Beiträge
    4.715
    Danke
    728
    Erhielt 1.154 Danke für 967 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    ich habe in einer S7-1516F zwei statische Verbindungen zum selben PC angelegt. (zwei verschiedene Ports)
    Eine der Verbindungen fällt mir regelmässig weg mit Status
    80C3 A block with this ID is already being processed in a different priority group.


    Internal lack of resources.
    Ressources sind genug frei und die ID wird pro Verbindung auch nur einmal für den TSEND und einmal für den TRCV Baustein benutzt.
    Das ganze Projekt liegt auch Siemens vor und die können auch keinen Fehler in der Konfiguration finden.
    Der TSEND und TRCV liegen als Instanz in einem FB. Ich habe die Instanz schon mal neu angelegt, Alles neu kompiliert.
    Ich habe Adhoc Modus 0 und 1 probiert.
    Ich habe auch schon einen separaten DB angelegt und die T-Bausteine damit aufgerufen (Nicht mehr in der Instanz)

    Alles nichts geholfen:
    Fehler kommt immer wieder. Hat jemand noch eine Idee??
    Zitieren Zitieren TIA: TRCV Baustein Status 80C3  

  2. #2
    Registriert seit
    15.03.2013
    Beiträge
    187
    Danke
    6
    Erhielt 35 Danke für 30 Beiträge

    Standard

    Rufst Du die Instanzen vielleicht aus verschiedenen Prioritäten heraus auf?

    Falls nein: hast Du Instanzdatenbausteine im RUN der CPU überladen, d.h. wurden die DB-Inhalte reinitialisiert während Aufträge aktiv waren?

  3. Folgender Benutzer sagt Danke zu Mediator für den nützlichen Beitrag:

    marlob (23.08.2016)

  4. #3
    Registriert seit
    18.09.2004
    Ort
    Münsterland/NRW
    Beiträge
    4.715
    Danke
    728
    Erhielt 1.154 Danke für 967 Beiträge

    Standard

    TSEND und TRCV werden beide aus dem selbem FB aufgerufen.

    Ab und zu werden die DBs reinitialisiert. Der Instanzdatenbaustein vom FB mit den T-Bausteinen ist aber schon länger nicht geändert worden.
    Ich werde das aber noch mal beobachten ob es daran liegen kann
    Geändert von marlob (23.08.2016 um 09:49 Uhr)

  5. #4
    Registriert seit
    15.03.2013
    Beiträge
    187
    Danke
    6
    Erhielt 35 Danke für 30 Beiträge

    Standard

    Vermutlich liegt die Ursache im Reinitialisieren. Das Reinitialisieren im RUN solltest Du unbedingt vermeiden und stattdessen Laden ohne Reinitialisierung verwenden!

  6. #5
    Registriert seit
    18.11.2010
    Beiträge
    2
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo Marlob

    hast schon eine Lösung für dein Problem gefunden? Kommt er Fehler in der Kommunikaiton immer noch?
    Danke für ein Feedback

  7. #6
    Registriert seit
    18.09.2004
    Ort
    Münsterland/NRW
    Beiträge
    4.715
    Danke
    728
    Erhielt 1.154 Danke für 967 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Fehler tritt nicht mehr auf. Genaue Ursache kann ich nicht nennen.
    Wir haben aber eine Zeit lang mit zwei Programmierern im selben Projekt gearbeitet. Ab dem Zeitpunkt an dem ich alleine daran gearbeitet habe trat der Fehler nicht mehr auf.

Ähnliche Themen

  1. Status Baustein bei WinSPS-S5
    Von Anfänger 2010 im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 12.10.2011, 19:44
  2. Status Baustein mit VIPA CPU
    Von Jochen Kühner im Forum Hochsprachen - OPC
    Antworten: 0
    Letzter Beitrag: 25.10.2010, 17:37
  3. Falscher Status im Baustein
    Von mitchih im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 11.05.2009, 18:25
  4. Status Baustein -> Triggerereignis belegt
    Von Anonymous im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 09.05.2005, 11:45
  5. Step 5 Operanden suchen im "Status Baustein"
    Von E-Marco im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 04.02.2005, 09:22

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •