Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 13

Thema: S7-1215 V3 "vergisst" remanente Daten

  1. #1
    Registriert seit
    10.07.2014
    Beiträge
    209
    Danke
    88
    Erhielt 5 Danke für 5 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    seit einigen Tagen "vergisst" die Maschine remanente Daten. Diese Daten wurden über HMI eingetragen. Schaltet der Kunde die Maschine nun aus und wieder ein nachdem er die Änderungen vorgenommen hat, stehen die urprünglich programmierten Ausgangswerte wieder da, aber nicht die soeben geänderten.
    Aus einem anderen Thread habe ich gelesen, das es mal Remanenzprobleme gab, dies sollte aber nur CPU unter V3 betreffen, und der Thread ist von 2012. Deshalb habe ich mal einen neuen angefangen.

    es ist eine S7-1215C V3 mit einem KTP 600 basic HMI. Wie gesagt, bis vor einigen tagen funktionierte das noch einwandfrei laut Kunde.

    hat jemand eine Idee oder weis woran es liegen könnte? Ist vielleicht der Pufferkondensator hinüber?
    TIA Portal basic up to date
    TIA Portal safety basic up to date
    S7-1200
    Zitieren Zitieren S7-1215 V3 "vergisst" remanente Daten  

  2. #2
    Registriert seit
    04.11.2013
    Beiträge
    116
    Danke
    10
    Erhielt 21 Danke für 17 Beiträge

    Standard

    Der Remanenzspeicher wird ein EEPROM sein, der Pufferkondensator ist nur für die CPU-Uhr. Das Programm ist ja auch noch da.

    Im Programmierleitfaden S.57 stehts etwas genauer.

  3. #3
    Registriert seit
    25.09.2013
    Beiträge
    154
    Danke
    6
    Erhielt 19 Danke für 19 Beiträge

    Standard

    Hallo,

    hatte so ein Verhalten wenn ich die DB Werte auch im Panel in einer Rezeptur habe und diese Syncronisiert werden.
    Ich nehme bei der Rezeptur Synchronisation immer alle "Haken" raus dann wird nur auf Bedieneranforderung in die SPS geschrieben oder aus der SPS geladen.

    Gruß

    Jens

  4. #4
    Credofire ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    10.07.2014
    Beiträge
    209
    Danke
    88
    Erhielt 5 Danke für 5 Beiträge

    Standard

    Hallo

    die Sache ist ja, das ich eigentlich nichts synchronisiere (denke ich). Ich schreibe ja direkt die Werte in den DB.
    Also sobald ich Enter gedrückt habe müssten sie doch im DB remanent gespeichert sein. Oder sehe ich das falsch?

    Gruß
    Mathias
    TIA Portal basic up to date
    TIA Portal safety basic up to date
    S7-1200

  5. #5
    Registriert seit
    04.11.2013
    Ort
    Salzburg
    Beiträge
    14
    Danke
    13
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Das Häkchen bei Remanenz ist gesetzt für die jeweilige Variable?

  6. #6
    Credofire ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    10.07.2014
    Beiträge
    209
    Danke
    88
    Erhielt 5 Danke für 5 Beiträge

    Standard

    Hallo
    ja, das Remanenz-Häkchen ist drin. Ich hab es extra im Zusammenhang mit diesem Fehler noch mal überprüft, da das ursprüngliche Programm nicht von mir stammt.

    Trichter Grenzen.png
    TIA Portal basic up to date
    TIA Portal safety basic up to date
    S7-1200

  7. #7
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    9.547
    Danke
    820
    Erhielt 2.820 Danke für 2.272 Beiträge

    Standard

    Stehen im Diagnosepuffer der S7-1215C Einträge, welche was mit Remanenzverlust oder Urlöschen zu tun haben könnten?
    Gibt es außer dem HMI-Panel noch andere Schreibzugriffe auf die Variablen? Wann genau schreibt die HMI in die Variablen, könnte das Schreiben auch unbeabsichtigt passieren? Schreibt die HMI direkt in die Variablen oder ist da noch etwas SPS-Programm dazwischen?
    Ist das Fehlverhalen "von alleine" gekommen oder wurde was am Programm der S7-1215C oder KTP600 geändert?

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  8. #8
    Credofire ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    10.07.2014
    Beiträge
    209
    Danke
    88
    Erhielt 5 Danke für 5 Beiträge

    Standard

    Hallo Harald,

    habe leider keinen Zugriff auf den Diagnosepuffer aus der ferne. Unsere Kunden haben auch keinen Zugriff darauf. Die Kunden haben auch keinen Zugriff auf die Steuerung, sodass sie ein Urlöschen forcieren könnten. Damit wäre dann aber auch das ganze Programm hinüber.
    Es schreibt nur das HMI diese Variable. Es wird vom Servicetechniker im Servicemenü eingegeben. Es handelt sich bei den Werten um Schaltgrenze für das Zuführband. Der Techniker kann es nach Bedarf nur im Servicemenü anpassen. Es kann nicht unbeabsichtigt passieren.
    Die HMI schreibt direkt die Variable im DB.
    Das Fehlverhalten sollte von allein gekommen sein. Eine Programmänderung oder HMI Änderung ist nach der Auslieferung an den Kunden nicht erfolgt.
    Komplett ausschließen kann ich aber nicht, ob der Kunde sich nicht auch ein TIA Portal geholt hat und am Display was "rumgefummelt" hat. Das ist aber bei unseren Kunden nicht üblich. Selbst unsere großen Kunden scheuen die Investition.
    TIA Portal basic up to date
    TIA Portal safety basic up to date
    S7-1200

  9. #9
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    9.547
    Danke
    820
    Erhielt 2.820 Danke für 2.272 Beiträge

    Standard

    Ist in der S7-1215C der Webserver aktiviert? Dann kann man darüber in den Diagnosepuffer schauen.

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  10. #10
    Credofire ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    10.07.2014
    Beiträge
    209
    Danke
    88
    Erhielt 5 Danke für 5 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Nein, dummerweise nicht. Ich habe mich erst bei der Folgemaschine dazu entschieden Webserver einzuschalten.

    Gruß
    Mathias
    TIA Portal basic up to date
    TIA Portal safety basic up to date
    S7-1200

Ähnliche Themen

  1. TIA Daten "Byte" aus einem Profinet Gerät lesen
    Von KaiserA im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 08.10.2015, 14:49
  2. Antworten: 0
    Letzter Beitrag: 05.03.2015, 09:05
  3. "Anzahl der Daten ist zu groß für die Steuerung"
    Von Beck im Forum CODESYS und IEC61131
    Antworten: 16
    Letzter Beitrag: 28.11.2014, 00:43
  4. Antworten: 14
    Letzter Beitrag: 22.07.2011, 08:26
  5. "Index Pulse", "Home Switch" und "Position Limit Switch"
    Von senmeis im Forum Antriebstechnik
    Antworten: 3
    Letzter Beitrag: 07.03.2011, 11:21

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •