Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 13

Thema: 315 2DP geht in Stop

  1. #1
    Registriert seit
    12.05.2006
    Beiträge
    21
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Ausrufezeichen


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    ich habe ein kleines Problem, ich habe eine 315 2 DP und betreibe über Profibus 2 * Et200S und ein Exor Bedienpanel. Der Profibus steht einwandfrei. Mein Problem ist nur, wenn ich die Seiten im Exor ändere und das Programm reinspiele,geht die SPS in STOP. Der Fehler ist ja auch logisch, der Bus wird unterbrochen. Wie oder was schreibt man in den OB 86, dass die SPS weiterlaufen kann (exor teilnehmer 11, Diagnose Adresse 2044)? Ich muss es aber so schreiben, dass nur das Exor aussteigen darf und keine der anderen Baugruppen.
    Ich weiß es steht schon viel über das Thema hier, doch eine genaue Erklärung konnte ich noch nicht finden.

    Ach ja sollte ich mal erwähnen, ich habe schon den FB125 und FC125 getestet, aber auch mit diesen Bausteinen komme ich zu keinem Ergebnis
    Zitieren Zitieren 315 2DP geht in Stop  

  2. #2
    Registriert seit
    07.05.2004
    Ort
    Campbelltown
    Beiträge
    2.437
    Danke
    131
    Erhielt 276 Danke für 86 Beiträge

    Standard

    Die erwähnten Bausteine sind eigentlich die richtigen. Du kannst damit die Adresse ermitteln, die den Fehler verursacht hat und entsprechend reagieren.

    Was steht denn im Diagnosepuffer, wenn die SPS in Stop gegangen ist?

    pt
    Gegen Schwachsinn, Schwachköpfe und armselige Trittbrettfahrer kann man nicht argumentieren.

    Gott sieht alles, auch Signaturen in Geheimschrift,,... aber er petzt nicht.

  3. #3
    Registriert seit
    12.05.2006
    Beiträge
    21
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Als ich habe das Exor jetzt gestoppt und folgendes steht im Buffer der CPU:

    1. Uhrzeit --- Stop durch Baugruppenträgerausfall (OB nicht geladen oder...
    2.dezentrale Peripherie Stationsausfall

    ________________________________________________________
    Details zum Ereignis:1 16# 456F

    Stop durch Baugruppenträgerausfall (OB nicht geladen oder nicht möglich, bzw kein FRB vorhanden)
    Unterbrechngsstelle im Anwenderprogramm: Zyklisches Programm (OB1)

    Prioritätsklasse: 1
    FB-Nummer: 2
    Bausteinadresse: 100
    Bisheriger Betriebszustand: RUN
    Angeforderter Betriebszustand: STOP
    interner Fehler, kommendes Ereignis
    ____________________________________________________________

    Ereignis 2 16# 39C4
    Dezentrale Peripherie: Station Ausfall
    Adresse des betroffenen DP Slaves: 11
    Log. Basisadresse des DP Slaves: Eingangsadresse 2044
    Log. Basisadresse des DP Masters: Eingangsadresse 2047
    Angeforderter OB: Baugruppenträgerausfall (OB86)
    OB nicht vorhanden oder gesperrt...

    ___________________________________________________________

    habe noch keinen OB86 aufgerufen, da ich ihn nicht programmieren konnte
    Zitieren Zitieren Danke für die schnelle Unterstützung  

  4. #4
    Registriert seit
    28.06.2006
    Ort
    Königreich Neuseeland
    Beiträge
    2.027
    Danke
    133
    Erhielt 96 Danke für 76 Beiträge

    Standard

    Zitat Zitat von Christian Schröder
    habe noch keinen OB86 aufgerufen, da ich ihn nicht programmieren konnte

    Hier, der erste Link:

    http://support.automation.siemens.co...02367&x=16&y=9

    Direkter Download:
    http://support.automation.siemens.co...DP_DIA_49.zip?

    Da findest du ein Beispielprojekt, in dem der OB86 und OB82 programmiert sind!

    Benutze den FC125, nicht den FB.
    Der FC genügt deinen Ansprüchen.

    Du kannst OB82 und OB86 auch mit NOP 0 programmieren, dann geht die CPU auch nicht in Stop.

  5. #5
    Registriert seit
    12.05.2006
    Beiträge
    21
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ich habe denn FC125 mit allen Bausteinen und Instanzen übernommen (Ausnahme die Bausteine für FB 125), habe auch den Eintrag in OB 1 wie beschrieben vorgenommen. Aber hat noch nicht funktioniert. Ich nehme das Exor raus und die SPS geht in Stop. Man hat auch nicht viele Parameter, die man beim FC 125 einstellen könnte. Was mache ich falsch.
    Zitieren Zitieren Fc125  

  6. #6
    Registriert seit
    28.06.2006
    Ort
    Königreich Neuseeland
    Beiträge
    2.027
    Danke
    133
    Erhielt 96 Danke für 76 Beiträge

    Standard

    hast du auch den OB86 und OB82 programmiert, wie im Beispiel gezeigt ?

    Ach ja, wenn du über Peripherie mit dem OP sprichst, kann als STOP - Ursache dann noch der QVZ - Fehler hinzukommen, dann noch den OB122 einspielen, auch wenn nur mit NOP 0.
    Geändert von Unregistrierter gast (04.07.2006 um 10:45 Uhr)

  7. #7
    Registriert seit
    28.06.2006
    Ort
    Königreich Neuseeland
    Beiträge
    2.027
    Danke
    133
    Erhielt 96 Danke für 76 Beiträge

    Standard

    Zitat Zitat von Christian Schröder
    Was mache ich falsch.

    Hmmm.. du gibts dir nicht genug Mühe... ?

  8. #8
    Registriert seit
    12.05.2006
    Beiträge
    21
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ich denke schon das ich mir Mühe gebe. Das ist meine erste Steuerung und ich habe ohne Kurs nach vier Wochen schon ziemlich unter Kontrolle.
    Egal. Ich habe OB86 und 82 nicht aufgerufen, dass sie im Beispiel nur für FB125 verwendet werden. Für Fc125 wird lediglich der OB1 Verwendet...
    du bist dran
    Zitieren Zitieren Ich glaube da liegst du falsch  

  9. #9
    Registriert seit
    28.06.2006
    Ort
    Königreich Neuseeland
    Beiträge
    2.027
    Danke
    133
    Erhielt 96 Danke für 76 Beiträge

    Böse

    Ich zitiere mich mal selber:

    Zitat Zitat von Unregistrierter gast
    Du kannst OB82 und OB86 auch mit NOP 0 programmieren, dann geht die CPU auch nicht in Stop.
    Was war daran unverständlich ?

    Du bist drann.
    Zitieren Zitieren Wer nicht will, der hat schon  

  10. #10
    Registriert seit
    07.05.2004
    Ort
    Campbelltown
    Beiträge
    2.437
    Danke
    131
    Erhielt 276 Danke für 86 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von Christian Schröder
    Ich denke schon das ich mir Mühe gebe. Das ist meine erste Steuerung und ich habe ohne Kurs nach vier Wochen schon ziemlich unter Kontrolle.
    Egal. Ich habe OB86 und 82 nicht aufgerufen, dass sie im Beispiel nur für FB125 verwendet werden. Für Fc125 wird lediglich der OB1 Verwendet...
    du bist dran
    Füge in dein Projekt die OB´s ein und übertrage sie in die Steuerung, dann geht diese nicht mehr in Stopp.

    Der Aufruf von dem FC sollte eigentlich im OB100,82,86 stehen, bei einer 318 musste ich ihn auch noch mit in den 121 nehemen.

    pt
    Gegen Schwachsinn, Schwachköpfe und armselige Trittbrettfahrer kann man nicht argumentieren.

    Gott sieht alles, auch Signaturen in Geheimschrift,,... aber er petzt nicht.

Ähnliche Themen

  1. SPS geht in Stop
    Von Fidibus im Forum Simatic
    Antworten: 9
    Letzter Beitrag: 25.08.2011, 18:22
  2. CPU geht bei Programmwechsel in Stop
    Von nonguru im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 21.05.2010, 09:23
  3. CPU geht in Stop
    Von JoJo17 im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 26.05.2008, 11:06
  4. S5 geht des öfteren in Stop
    Von Andreas.W im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 13.01.2006, 11:59
  5. CPU315-2 DP geht in STOP
    Von Schmiegel im Forum Simatic
    Antworten: 19
    Letzter Beitrag: 04.08.2005, 14:35

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •