Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 6 von 6

Thema: cp523

  1. #1
    Registriert seit
    20.06.2003
    Ort
    Sauerland.NRW.Deutschland
    Beiträge
    4.850
    Danke
    78
    Erhielt 800 Danke für 543 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    hab hier ein problem mit einer cp523 und einem entfernungmesser sem2000 von sick. diese sendet permanent daten, zumindest sollte sie das.

    die rcv-led an der cp ist immer dauerhaft am leuchten. bei empfang sollte die ja eigentlich flackern.
    tut sie das nur, wenn die daten 'vernünftig' kommen oder wenn überhaupt daten kommen?

    bin nicht sicher ob die sick überhaupt sendet.

    folgendes will ich morgen mal testen (hatte heute nicht die passenden kabel bei.
    pc über nullmodem- und/oder seriellem kabel mit der cp verbinden.
    terminalprog starten. z.b. term98 vom nortoncommander.

    würde ich im terminal sehen wenn daten von der cp gesendet werden?
    kann ich daten vom terminal an den cp senden? würde die rcv-led flackern?

    die cp habe ich auf 3964 transparent gestellt.
    uhr kann ich mit A000 lesen
    ein sendeauftrag A001 funktioniert (zumindest flackert die snd-led).
    empfang mit A080 geht nicht
    Code:
                    Status
    L KH A080 
    T PW 144
    L KH 0080
    L PW 144        5000
    <>F
    spb=m001
    usw......auslesen
    m001:
    L PW 146        0000
    L PW 148        0000
    L PW 150        0000
    also mir scheint es so, das der empfangspuffer leer ist
    .
    mfg Volker .......... .. alles wird gut ..

    =>Meine Homepage .. direkt zum Download

    Meine Definition von TIA: Total Inakzeptable Applikation
    Zitieren Zitieren cp523  

  2. #2
    Registriert seit
    28.10.2005
    Ort
    Ottweiler, Saar
    Beiträge
    940
    Danke
    259
    Erhielt 124 Danke für 109 Beiträge

    Standard

    Vielleicht liegt's nur am Kabel. Ich hab mal einen 523 verkabelt und dabei über die eigenwillige Pinbelegung der Schnittstelle gestaunt. Ist aber schon lange her.

  3. #3
    Registriert seit
    20.06.2003
    Ort
    Sauerland.NRW.Deutschland
    Beiträge
    4.850
    Danke
    78
    Erhielt 800 Danke für 543 Beiträge

    Standard

    durchaus möglich, das das falsch verdrahtet ist. habe einiges ausprobiert. nix ging
    .
    mfg Volker .......... .. alles wird gut ..

    =>Meine Homepage .. direkt zum Download

    Meine Definition von TIA: Total Inakzeptable Applikation

  4. #4
    Registriert seit
    20.06.2003
    Ort
    Sauerland.NRW.Deutschland
    Beiträge
    4.850
    Danke
    78
    Erhielt 800 Danke für 543 Beiträge

    Standard

    die sick ist keine sme2000 sondern heisst dme2000
    verdrahtung bis zum stecker der cp ist def. ok.

    habe mal einen adpter gebaut.
    Code:
    CP523            9-pol
    5        RXD     2
    7        DSR     6
    9        CTS     8
    11       TXD     3
    13       RTS     7
    15       DTR     4
    2,21,23  Masse   5
    24,25    Schirm  1
    wenn ich nun den stecker von der sick an den adapter cp-seite stecke und den 9-pol in den pc bekomme mit einem terminal sauber die werte geliefert.
    dort kann also kein fehler sein.

    schliesse ich den adapter an den cp an und sende von dort daten, kommt im pc nix an obwohl die send-led auf der cp am flackern ist.

    sende ich mit dem pc daten über den adapter, passiert auch nix auf dem cp.

    selbst wenn ich die cp falsch parametriert habe, sollten doch werte in den empfangspuffer gelange. oder sehe ich das falsch?

    bin mit meinem latein im moment am ende.
    Geändert von volker (07.07.2006 um 14:04 Uhr)
    .
    mfg Volker .......... .. alles wird gut ..

    =>Meine Homepage .. direkt zum Download

    Meine Definition von TIA: Total Inakzeptable Applikation

  5. #5
    Registriert seit
    28.10.2005
    Ort
    Ottweiler, Saar
    Beiträge
    940
    Danke
    259
    Erhielt 124 Danke für 109 Beiträge

    Standard

    Ich bin mir zwar nicht sicher, aber ich glaube der CP hat intern Steckbrücken, mit denen man zwischen v24 und TTY auswählt.
    Die Leitungen liegen ja alle auf dem selben Stecker. Ich hab kein Handbuch vom 523, nur vom 525, da gibt es die Brücken.

    Korrektur: Und in genau dieses Handbuch hab ich eben reingeschaut. Die Brücken schalten die V24 Handshakeleitungen...

    Gruß Gerry.
    Geändert von argv_user (07.07.2006 um 14:55 Uhr)

  6. #6
    Registriert seit
    20.06.2003
    Ort
    Sauerland.NRW.Deutschland
    Beiträge
    4.850
    Danke
    78
    Erhielt 800 Danke für 543 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    die schnittstelle wird bei der 523 über parameterblock0 parametriert. (seite13
    sieht bei mir so aus (wird nur 1 mal zum initialisieren durchlaufen)
    L KH 0300 //10bit rahmen 7n / handshake off
    T PW 150
    L KH 0001 //busy / v24
    T PW 148
    L KH 0800 //baud 9600 / parität gerade
    T PW 146
    L KH 9000 //auftrag senden
    T PW 144

    betriebsart über block7 (seite 140)
    sieht bei mir so aus (wird nur 1 mal zum initialisieren durchlaufen)
    L KH 0000 //urrelevant
    T PW 150
    L KH 0005 //telegrammlänge 5 byte
    T PW 148
    L KH 001E //verzugszeit 3sek
    T PW 146
    L KH 9071 //auftrag senden / betriebsart kopplung transparent
    T PW 144

    habe aber auch andere konigurationen probiert.

    was mich auch noch wundert ist folgendes.

    L KH A000 //Auftrag status lesen
    T PW 144
    L PW 144 // hier steht jetzt 5001
    5001 = cpu kann senden
    5080 = cpu kann empfangen
    5081 = kann senden und empfangen

    eigentlich erwarte ich hier eine 5081. oder?

    hier das handbuch zur cp523
    http://support.automation.siemens.co...edownload=true

    so habe ich den stecker der cp belegt
    cp ---- sick
    2,21,23 --- gnd --- blau
    24,25 --- schirm --- noch nicht aufgelegt
    5 - rxd --- txd --- grau-pink
    11 - txd --- rxd --- schwarz
    9,13 brücke - rts/cts
    Angehängte Grafiken Angehängte Grafiken
    .
    mfg Volker .......... .. alles wird gut ..

    =>Meine Homepage .. direkt zum Download

    Meine Definition von TIA: Total Inakzeptable Applikation

Ähnliche Themen

  1. Antworten: 0
    Letzter Beitrag: 06.08.2005, 13:38

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •