Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 14

Thema: Simatic 3T-Steuerung mit Eingangs-Prob

  1. #1
    Registriert seit
    06.07.2006
    Beiträge
    37
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,
    ich habe ein Prob an einer Drehbank. Diese MA hat eine Simatic 3T Steuerung, worin sich eine STEP5 befindet.
    Laut der STEP5-Software hat mein E15.1 immer 1-Signal, obwohl keine 24V anliegen, ich habe jetzt auch schon mal 24V drauf gegeben, doch es bleibt immer beim 1-Signal.

    Da ging ich von einem Defekt der Eingagskarte aus, diese habe ich gewechselt, doch mein E15.1 bleibt immer auf 1-Signal.

    Hatte schon jemand so ein Prob und kann mir die Lösung sagen?

    Thx, Oeffi
    Zitieren Zitieren Simatic 3T-Steuerung mit Eingangs-Prob  

  2. #2
    Registriert seit
    05.10.2005
    Beiträge
    2.373
    Danke
    321
    Erhielt 296 Danke für 266 Beiträge

    Standard

    Hallo,
    was für eine S5 Steuerung läuft da?
    Kann es sein, das der Eingang softwaremäßig gesetzt wird im Programm?
    Grüße Thomas

  3. #3
    Registriert seit
    10.05.2005
    Beiträge
    1.996
    Danke
    220
    Erhielt 233 Danke für 204 Beiträge

    Standard

    Hi

    Wie Thomas gesagt hat !


    z.b.

    U M 0.0
    = E 15.1


    Mach doch mal eine Querverweisliste.


    Schau mal nach

    U E 15.1 NUR Abfrage
    O M 15.1 NUR Abfrage
    = M15.1 --> Eingang wird gesetzt
    S M15.1 --> Eingang wird gesetzt

    Lese den Baustein-Nummer aus.
    Gehe in den Baustein, unter Status sieht du ob er gesetzt wird.


    P.S. Natürlich auch möglich L MB5
    T EB 15



    Karl

  4. #4
    Registriert seit
    10.05.2005
    Beiträge
    1.996
    Danke
    220
    Erhielt 233 Danke für 204 Beiträge

    Standard

    Hi


    Gehe doch mal in den OB1 ...


    Setze nach ein paar Zeilen mal den Befehl

    "BE"

    Alle Bausteinaufrufe kannst du hiermit ausklammern, somit auch das "setzen".

    Beachte, es gibt auch noch ander OBs die Bausteine aufrufen ( OB35 ...)



    Karl

  5. #5
    Registriert seit
    06.10.2004
    Beiträge
    278
    Danke
    17
    Erhielt 34 Danke für 30 Beiträge

    Standard

    Hallo
    man kann nicht mit einer Anweisung ein Eingang setzen. Die SPS-Eingänge sind nicht anderes als Merker. Im OB1 (PAE) werden alle Eingänge (realistische) auf Zwischenspeicher gesetzt (man würde schreiben L PEW 0 ....T EW 0). Ab dem Moment fragt man alle Eingänge ab z.B. U E 0.0 In S5 Steuerung habe ich oft AW und EW (die nicht vorhandene) als Zischenspeicher für mein Programm benutzt. z.B. L MW 200 --> T EW 120 Eingänge als Periferie sind am meinstens durch Optokoppler gesteuert. Optokopller kann man nicht "von hinten" steuert. Es gibt in dem Fall nur eine Richtung.
    Eingang leuchtet immer......die digitale Eingangskarte ist defekt. Vielleicht von Helmholz ?...die hatten oft solche Wunder.

  6. #6
    Registriert seit
    28.06.2006
    Ort
    Königreich Neuseeland
    Beiträge
    2.027
    Danke
    133
    Erhielt 96 Danke für 76 Beiträge

    Standard

    Zitat Zitat von gravieren
    Hi


    Gehe doch mal in den OB1 ...
    Setze nach ein paar Zeilen mal den Befehl
    "BE"

    Karl

    Das sollte er tunlichst bleiben lassen, es sein denn, er weiss genau, was er tut.

    Wäre schon schade, wenn die Maschine aufeinmal nicht mehr stoppt .....

    tztztz....
    Geändert von Unregistrierter gast (14.07.2006 um 11:43 Uhr)

  7. #7
    Registriert seit
    28.06.2006
    Ort
    Königreich Neuseeland
    Beiträge
    2.027
    Danke
    133
    Erhielt 96 Danke für 76 Beiträge

    Standard

    Zitat Zitat von Taddy
    Eingang leuchtet immer......die digitale Eingangskarte ist defekt.
    Bisher war nur die rede davon, dass das Signal immer 1 ist.

    Warum sollte jetzt die LED leuchten ?

  8. #8
    Registriert seit
    14.09.2005
    Beiträge
    40
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Zitat Zitat von Taddy
    Hallo
    man kann nicht mit einer Anweisung ein Eingang setzen. Die SPS-Eingänge sind nicht anderes als Merker. Im OB1 (PAE) werden alle Eingänge (realistische) auf Zwischenspeicher gesetzt (man würde schreiben L PEW 0 ....T EW 0). Ab dem Moment fragt man alle Eingänge ab z.B. U E 0.0 In S5 Steuerung habe ich oft AW und EW (die nicht vorhandene) als Zischenspeicher für mein Programm benutzt. z.B. L MW 200 --> T EW 120 Eingänge als Periferie sind am meinstens durch Optokoppler gesteuert. Optokopller kann man nicht "von hinten" steuert. Es gibt in dem Fall nur eine Richtung.
    Eingang leuchtet immer......die digitale Eingangskarte ist defekt. Vielleicht von Helmholz ?...die hatten oft solche Wunder.
    An der S5 kann man sehr wohl Eingänge setzen sie werden zwar am Anfang vom Programm zurückgesetzt .

    Grüßle
    Peter

  9. #9
    Registriert seit
    28.06.2006
    Ort
    Königreich Neuseeland
    Beiträge
    2.027
    Danke
    133
    Erhielt 96 Danke für 76 Beiträge

    Standard

    Zitat Zitat von Piter
    An der S5 kann man sehr wohl Eingänge setzen sie werden zwar am Anfang vom Programm zurückgesetzt .

    Grüßle
    Peter
    Nicht grundsätzlich.
    das ist abhängig von der jeweiligen (Step5-) SPS.

    Es ist durchaus möglich, EW auch als Schmiermerker zu benutzen.
    Aber ansonsten hat Taddy viel Blödsinn geschrieben, das ist schon wahr.

  10. #10
    Registriert seit
    14.09.2005
    Beiträge
    40
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo

    Es ist richtig am sollte Setzen von Eingänge unterlassen es ist aber
    möglich.
    Wir hatten mal eine Maschine bei der es so gemacht wurde anscheined kannten sie nicht die Funktion Umverdrahten .
    Ich hab es auch schon machen müßen beim auswechsel eines Absolutgebers fehlte Hardeware mäßig eine Spur.
    Die fehlende Spur war invertiert zur Spur 16

    UN E8.6
    = E8.7

    Diesen Code hab ich am Anfang vom OB 1 eingefügt


    Grüßle Peter

Ähnliche Themen

  1. Direkte Flankenauswertung eines Eingangs
    Von Paule im Forum Simatic
    Antworten: 15
    Letzter Beitrag: 11.10.2011, 00:12
  2. AWL Prob
    Von Blanky04 im Forum Simatic
    Antworten: 24
    Letzter Beitrag: 21.07.2010, 22:03
  3. Prob mit Motor der einfach los fährt.
    Von maxi im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 24.03.2009, 21:33
  4. Prob. mit meiner Schrittkette
    Von Klappi im Forum Simatic
    Antworten: 19
    Letzter Beitrag: 09.11.2008, 21:36
  5. Befehl für Eingangs- bzw. Ausgangsspieglung
    Von Syntaxfehler im Forum Simatic
    Antworten: 23
    Letzter Beitrag: 13.06.2007, 23:26

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •