Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 15

Thema: Temperaturen interpolieren

  1. #1
    Registriert seit
    12.05.2006
    Beiträge
    21
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Pfeil


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo ihr da draußen,

    kann mir jemand verraten, wie man zu einer bestimmten Spannung die Temp.-Fühler einstellen kann? Ich suche einen Baustein, mit dem man Temperaturen Interpolieren kann, hat Siemens so was?

    Ich gebe mit einem Gerät 10mV vor und ich weiß,dass diese Spannung einen Temperaturwert von 183°C entspricht. Angezeigt werden aber
    663°C....

    BITTE HELFT MIR!!!
    Zitieren Zitieren Temperaturen interpolieren  

  2. #2
    Registriert seit
    27.10.2005
    Ort
    Schwäbisch Gmünd
    Beiträge
    5.235
    Danke
    642
    Erhielt 955 Danke für 769 Beiträge

    Standard

    Welche SPS? Welche Baugruppe? Welche Einstellung der Baugruppe? Welcher Thermoelementetyp?
    Rainer Hönle
    DELTA LOGIC GmbH

    Ein Computer kann das menschliche Gehirn nicht ersetzen. Engstirnigkeit kann unmöglich simuliert werden. (Gerd W. Heyse)

  3. #3
    Registriert seit
    22.07.2004
    Beiträge
    749
    Danke
    41
    Erhielt 66 Danke für 47 Beiträge

    Standard

    Ist dieser Fehler den Linear???
    Also ich meine z.B. das bei 91,5°C echt dann 331,5°C angezeigt werden, weil dann könntest du ja praktisch mit dem Verhältnis arbeiten, geht aber nicht wenn es halt nicht linear wäre

  4. #4
    Registriert seit
    12.05.2006
    Beiträge
    21
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Beitrag

    Die Haupt-SPS ist eine CPU315 2 DP, an dieser sind über Profibus 2* ET 200S angeschlossen.
    Bei einer dieser ET200S möchte ich die Temperatursteuerung realisieren.
    Dazu verwende ich 2 AI TC HF Module, die auf einem Sockel sitzen mit einem integrierten PT 100 (6ES7 193-4CL20 0AA0).
    Ich habe jetzt eine Spanungsquelle an den Fühlereingang angeschlossen, die eine Spannung von 10 mV vorgibt.

    Die Module 2 AI TC HF habe ich wie folgt eingestellt
    Vergelichstellennummer INTERN
    Temperatureinheit CELCIUS
    Messart/bereich TC EL TYP J Fe-CuNi
    Glaettung schwach
    Vergleichstelle RTD

    Also ich gebe nun die 10 mV vor und erhalte als Wert 673 laut einer Tabelle muessten das aber 183 Grad sein. Ob der Verlauf einer Heizung linear ist kann ich nicht sagen, dazu fehlt mir die Erfahrung
    Zitieren Zitieren Mein System  

  5. #5
    Registriert seit
    20.06.2003
    Ort
    Sauerland.NRW.Deutschland
    Beiträge
    4.866
    Danke
    78
    Erhielt 806 Danke für 549 Beiträge

    Standard

    gelöscht weil falsch gelesen
    Geändert von volker (19.07.2006 um 11:18 Uhr)
    .
    mfg Volker .......... .. alles wird gut ..

    =>Meine Homepage .. direkt zum Download

    Meine Definition von TIA: Total Inakzeptable Applikation

  6. #6
    Registriert seit
    02.02.2006
    Ort
    Hessen
    Beiträge
    429
    Danke
    16
    Erhielt 28 Danke für 22 Beiträge

    Standard

    Hallo,
    beim Testen ohne echtes Thermoelement muss die Vergleichsstelle natürlich ausgeschaltet sein. Welche Temperaturanzeige ergibt sich denn, wenn nur eine Drahtbrücke am Meßeingang geklemmt ist?
    mfG Werner
    Hoch lebe die Suchfunktion!
    Zitieren Zitieren Vergleichsstellentemperatur bei Spannungsmessung  

  7. #7
    Registriert seit
    12.05.2006
    Beiträge
    21
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hi ihr,

    also ich habe die Spannungsversorgung abgeklemmt und eine Drahtbrücke eingebaut. Jetzt erscheint auf meinem Display der Wert 96.
    Naja nach meinem Gefühl, ist es heute an meinem Arbeitsplatz echt so heiß, der Wert könnte also stimmen !
    Ok objektiv bleiben, es müssten hier so circa 25°C sein. Wie stelle ich die Werte jetzt noch ein das die Werte passen!
    Zitieren Zitieren Habe ich gemacht  

  8. #8
    Registriert seit
    03.10.2005
    Beiträge
    160
    Danke
    17
    Erhielt 7 Danke für 7 Beiträge

    Standard

    Ohne die Module jetzt zu kennen, aber warum ist bei Messart ein Thermoelement eingestellt wenn du mit nem PT100 messen willst?

  9. #9
    Registriert seit
    20.06.2003
    Ort
    Sauerland.NRW.Deutschland
    Beiträge
    4.866
    Danke
    78
    Erhielt 806 Danke für 549 Beiträge

    Standard

    weil ich genauso falsch gelesen hatte, hatt ich meinen senf sofort wieder gelöscht
    das element ist typ j. lies nochmal genau.

    jedenfalls sehe ich das so. sollte er wirklich pt100 verwenden kann das nicht klappen.
    Geändert von volker (20.07.2006 um 12:40 Uhr)
    .
    mfg Volker .......... .. alles wird gut ..

    =>Meine Homepage .. direkt zum Download

    Meine Definition von TIA: Total Inakzeptable Applikation

  10. #10
    Registriert seit
    12.05.2006
    Beiträge
    21
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Ausrufezeichen


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Kann mir niemand eine Formel oder einen Programmausschnitt schicken, an den man ablesen kann, wie ich die Werte in realle Temperaturanzeigen wandeln kann.

    Wenn ich mein Anloges Eingangswort lade..... was muss ich damit tun oder welcher Baustein hilft mir da weiter?
    Zitieren Zitieren Hilfe  

Ähnliche Themen

  1. Wago PT100 Negative Temperaturen
    Von Speedtriple im Forum CODESYS und IEC61131
    Antworten: 11
    Letzter Beitrag: 22.03.2011, 12:52
  2. Drei Temperaturen auswerten
    Von slider7 im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 28.02.2011, 19:23
  3. Temperaturen günstig messern
    Von emilio20 im Forum Simatic
    Antworten: 18
    Letzter Beitrag: 14.09.2010, 10:44
  4. Temperaturen loggen mit BK9000 (in Excel)
    Von olitheis im Forum CODESYS und IEC61131
    Antworten: 44
    Letzter Beitrag: 03.12.2009, 11:33
  5. Temperaturen erfassen
    Von zotos im Forum Elektronik
    Antworten: 5
    Letzter Beitrag: 06.09.2004, 10:58

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •