Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 16

Thema: Rexroth Indradrive am Profibus

  1. #1
    Registriert seit
    28.06.2006
    Ort
    Königreich Neuseeland
    Beiträge
    2.027
    Danke
    133
    Erhielt 96 Danke für 76 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    hat jemand schonmal einen Rexroth Indradrive am Profibus betrieben ?

    Hat jemand evt. schon Bausteine für diese Anwendung ?
    Zitieren Zitieren Rexroth Indradrive am Profibus  

  2. #2
    Registriert seit
    20.06.2003
    Ort
    Sauerland.NRW.Deutschland
    Beiträge
    4.850
    Danke
    78
    Erhielt 800 Danke für 543 Beiträge

    Standard

    ist ein fu, oder?

    das steuerbit ist im prinzip bei alle fus über pb gleich

    wenn du ppo1 fahren willst, sollte auch mein baustein für den micromaster4 funktionieren.

    für die anderen ppo-typen einfach mal nach ppo suchen.
    .
    mfg Volker .......... .. alles wird gut ..

    =>Meine Homepage .. direkt zum Download

    Meine Definition von TIA: Total Inakzeptable Applikation

  3. #3
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.224
    Danke
    533
    Erhielt 2.698 Danke für 1.950 Beiträge

    Standard

    Für die EcoDrive gibt es einen guten Baustein vom Hersteller. Weiß nicht, ob der auch für die Indradrive geht, die kenne ich nicht. Frag doch einmal bei eurem Lieferanten (oder bei Rexroth) nach.
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  4. #4
    Avatar von Unregistrierter gast
    Unregistrierter gast ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    28.06.2006
    Ort
    Königreich Neuseeland
    Beiträge
    2.027
    Danke
    133
    Erhielt 96 Danke für 76 Beiträge

    Standard

    @Volker:

    Ist sowas wie eine NC-Achse.
    Mit PPOs komme ich leider nicht weiter.
    Die Status / Steuerbitbelegung ist mir bisher noch nicht vorgekommen,
    sowas wie HSW und HIW gibt es nicht.
    (Muss scheinbar über Parameter gemacht werden)

    @Ralle:
    Ich hab Demobausteine, allerdings sind die mir etwas zu umfangreich, es werden mind. 5 Worte belegt, und ich weis nicht, ob ich soviel Platz noch habe.
    Im Prinzip will ich nur ein/aus/Sollwert + Istwert, dazu würden IMHO 2 Worte genügen, ob dass aber machbar ist, kann ich noch nicht absehen.


    Danke euch beiden für die Antworten!

  5. #5
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.224
    Danke
    533
    Erhielt 2.698 Danke für 1.950 Beiträge

    Standard

    Ne, die ECODrive betreibe ich mit 12 IO-Worten, das ist ja noch mehr. Man kann dann aber Position, Geschwindigkeit, Beschleunigung vorgeben. NAch dem Einschalten Enable, dann Referenzfahren und los gehts.
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  6. #6
    Registriert seit
    22.03.2007
    Ort
    Detmold (im Lipperland)
    Beiträge
    11.728
    Danke
    398
    Erhielt 2.406 Danke für 2.002 Beiträge

    Standard

    ... aus gegebenen Anlass muß ich jetzt diesen alten Thread von UG noch mal aufwärmen ...
    Das Thema passt wie "Faust-aufs-Auge" auf meine eigene Problemstellung.

    In meinem Fall handelt es sich um einen IndraDrive C. Die PB-Kommunikation läuft eine zeitlang. Dann ist es irgendwann vorbei. Den Kommunikations-Prozessor des Reglers haben wir schon getauscht - hat nur 2 Tage was gebracht. Besteht hier ein generelles Problem ?

    Zur PB-Kommunikation :
    Bei BR wird das Telegramm frei erstellt - ich definiere also einen Übertragungsblock und der Regler pflückt sich die Inhalte selbst auseinander. Die Übertragung erfolgt von einem DB via Blockmove zum Regler. Mein Verdacht hier ist, dass der Regler (die interne SW) beim Zerpflücken Fehler macht und irgendwas falsch interpretiert ...

    Vielleicht weiß jemand etwas dazu ...

    Gruß
    LL

  7. #7
    Registriert seit
    27.05.2006
    Beiträge
    189
    Danke
    0
    Erhielt 9 Danke für 9 Beiträge

    Standard

    Hallo,
    wir haben über 100 Indradrive's C in unserem Betrieb. Alle laufen ohne Probleme. Es war noch nie einer defekt. Die PB-Kommunikation ist sehr sicher!
    Wenn du zum ersten Mal einen in Betrieb nimmst dann scheint es kompliziert. Nachher ist es aber ganz easy!
    Lies dir die Doku zu der Firmware die du Benutzt. Die Bausteine von Rexroth funktionieren gut und sind überhaupt nicht kompliziert!! Sie sind aber eher für Standard Funktionalität gedacht. Für spezielle Anwendungen haben wir eigene geschrieben. Und die sind erst kompliziert!
    Standardmäßig werden 6 Wörter gesendet und 6 Empfangen. Jeweils erstes Wort ist Standard Zustandswort bzw. Steuerwort. Zusätzlich wird noch der Ist- bzw. Soll Weg geschickt und Empfangen. Jeweils 4 Wörter bleiben frei. Die kannst Du dir nach Belieben konfigurieren. Da hast du noch Signalsteuerwort und Signalzustandswort. Die kannst du auch einstellen wie du möchtest. Jedes Bit einzeln. Es gibt noch andere Steuer- und Zustandswörter. Den Multiplex Kanal gibt es auch, mit dem du sämtliche Parameter zur Laufzeit manipulieren kannst. Ich kenne keinen anderen Antrieb der so flexibel zu betreiben ist. Man muss sich nur etwas damit beschäftigen.
    Versuch Mal mit Hotline von Rexroth. Die sind sehr kompetent!
    Viele Grüße

  8. #8
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.224
    Danke
    533
    Erhielt 2.698 Danke für 1.950 Beiträge

    Standard

    Mit dem Blk-Move, das hört sich danach an, als ob ihr nicht die Bausteine für Step7 (ich hab eigentlich nur einen , hatte aber auch nicht den IndraDriveC) von BR verwendet. Ich kann euch den auch nur empfehlen, mit den normalen Servofunktionen gab es bisher keinerlei Probleme. Aufhänger oder unklare Kommunikation gab es noch nie. Vielleicht wäre es mal einen Versuch wert, das gesamte andere SPS-Programm abzukoppeln und nur den Servo hin- und herlaufen zu lassen. Wenn das überhaupt mit vertretbarem Aufwand geht.
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  9. #9
    Registriert seit
    22.03.2007
    Ort
    Detmold (im Lipperland)
    Beiträge
    11.728
    Danke
    398
    Erhielt 2.406 Danke für 2.002 Beiträge

    Standard

    @Pikador:
    Nach deiner Beschreibung hört es sich für mich an, als ob du von etwas anderem sprichst als ich ... (Aufbau des Telegramms)
    Mit der Hotline habe wir schon stundenlang telefoniert - die haben mehr Fragen an uns als wir an die ... Kompetenz ???

    @Ralle:
    Wir verwenden den abgewandelten Baustein von BR, wie von dir angenommen. Hier passiert ja nun (noch) nicht viel ... Das SPS-Programm ist für mich folglich nicht der Auslöser.

    Zum Problem:
    Die Kommunikation CPU - Regler hat über viele Stunden einwandfrei funktioniert ... Gestern Abend dann auf einmal Sense. Die Steuer-Daten, die über den PB an den Regler geschickt wurden wurden von diesem ignoriert und mit einem Daten-Fehler (???) auf den Regler-Anzeige ausgewiesen. Es werden nach wie vor die gleichen Daten in gleichem Aufbau gesendet ...
    Die Hotline vermutet hier, das wieder (war schon einmal !!!) die Kommunikations-Karte des Reglers defekt ist - können sich dies aber nicht erklären - ich mir auch nicht ...
    An dieser Stelle nun wiederholt mein Aufruf ...
    Kann sich jemand darauf einen Reim machen ? Es ist augenscheinlich kein Fehler im Step7-Programm (auch nach Ansicht der Hotline). Haben wir die Schnittstelle mundtot gequatscht ? (soll es ja geben ...)

    Gruß
    LL

  10. #10
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.224
    Danke
    533
    Erhielt 2.698 Danke für 1.950 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hm, also, es kann auch 2x hintereinander etwas kaputt gehen, aber das ist schon selten. Habt ihr vielleicht irgendwelche Induktionsspannungen auf dem Bus/der Schirmung oder ähnliches? Ich würde in diesem Fall zuerst mal sämtliche Erdungen, die Verkabelung etc. prüfen. Gibt ja Geräte, die empfindlicher reagieren, vielleicht schlechter abgesichert sind. Auch ein Spannungsgefälle zwischen den Schirmenden könnte zu einer Stromfluß führen, was der Indradrive evtl. nicht mag. Da kann man ja mal messen, oder probeweise den Busschirm vom Indradrive wegnehmen.
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

Ähnliche Themen

  1. Bosch-Rexroth Indradrive, Profibus Verb.
    Von Martin L. im Forum Antriebstechnik
    Antworten: 8
    Letzter Beitrag: 02.07.2013, 07:54
  2. IndraDrive C, Profibus und LabVIEW
    Von kola86 im Forum Antriebstechnik
    Antworten: 3
    Letzter Beitrag: 25.03.2011, 12:58
  3. Datenübergabe an Bosch-Rexroth Indradrive
    Von Nordischerjung im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 12.05.2009, 12:03
  4. Bosch Rexroth Indradrive HCS02
    Von bernd67 im Forum Antriebstechnik
    Antworten: 1
    Letzter Beitrag: 13.03.2009, 08:34
  5. Indradrive Führungskommunikation Profibus
    Von ABplanCSE im Forum Antriebstechnik
    Antworten: 2
    Letzter Beitrag: 07.04.2008, 08:14

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •