Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 3 von 3 ErsteErste 123
Ergebnis 21 bis 28 von 28

Thema: Eingang auf 400er CPU trotz zuweisung "0"

  1. #21
    Registriert seit
    19.02.2016
    Beiträge
    589
    Danke
    8
    Erhielt 70 Danke für 65 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ist da vielleicht irgendwo am MCR rumgefummelt worden?

    Bei deiner Fehlerbeschreibung und so Texten in den Bildern wie "Schnelllauftore" und "Brandschutztore"... Könnte ich da ja fast Wetten das dein Kollege ggf. den Hinweis von Big-S einfach ignoriert hat
    "Um das Risiko möglicher Personen- oder Sachschäden auszuschließen, verwenden Sie das MCR
    niemals als Ersatz für ein festverdrahtetes, mechanisches Master Control Relay, das als NOT-AUS-
    Einrichtung dient."

    Such doch mal, ob du was in der Richtung findest. Vielleicht liegt der Baustein-Aufruf selbst ja schon in einem aktivierten MCR-Bereich...

    MfG Fabsi

  2. #22
    Registriert seit
    10.11.2015
    Ort
    Basilea
    Beiträge
    15
    Danke
    0
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Ohne Ahnung von S7-400 Hardware zu haben (nur 300 & 1500) möchte ich dennoch mal was in den Raum werfen .... Wieso schreibt ihr auf eine Eingangsvariable? E-Variablen sind doch für lesezugriff gedacht? Schreibend würde ich an dieser Stelle ein Datenpunkt innerhalb eines G-DB oder I-DB verwenden (zur Not tut es ja auch ein Merker).

    Erlaubt eine S7-400 Schreibzugriffe auf E-Variablen?

  3. #23
    Registriert seit
    14.01.2015
    Beiträge
    2.530
    Danke
    605
    Erhielt 471 Danke für 391 Beiträge

    Standard

    Wieso schreibt ihr auf eine Eingangsvariable?
    So etwas macht man beispielsweise bei Inbetriebnahmen, wenn noch Hardware fehlt usw. oder wenn man mal etwas simulieren möchte.

    Allerdings habe ich dies in meinen Anlagen auch schon in anderer Form gefunden. Dort hat dann der Betriebselektriker einen fehlenden
    Zylinderschalter einfach rausprogrammiert:
    U VentilZylinder
    L S5T#1S

    SE T xx

    U T xx
    = E Zylinderschalter

    Das ist natürlich nicht so gut
    Geändert von DeltaMikeAir (16.05.2018 um 13:04 Uhr)
    Mit Grüßen

  4. #24
    Registriert seit
    08.10.2009
    Ort
    Südpfalz
    Beiträge
    277
    Danke
    49
    Erhielt 56 Danke für 49 Beiträge

    Standard

    Zitat Zitat von Spleanify Beitrag anzeigen
    ... Erlaubt eine S7-400 Schreibzugriffe auf E-Variablen?
    Nicht nur die 400er.

    Bei uns gibt es extra einen Baustein dafür, der am Zyklusanfang aufgerufen wird.
    Da werden bei der Inbetriebnahme z.B. die noch fehlenden externen Signale eingetragen.
    Da sind sie leicht zu finden und sollten nach der IBN verschwunden sein.
    Nicht Mensch, nicht Tier: Programmierer halt ...

  5. #25
    Registriert seit
    22.11.2006
    Ort
    CH
    Beiträge
    3.950
    Danke
    845
    Erhielt 732 Danke für 546 Beiträge

    Standard

    Zitat Zitat von Der Pfälzer Beitrag anzeigen
    Nicht nur die 400er.

    Bei uns gibt es extra einen Baustein dafür, der am Zyklusanfang aufgerufen wird.
    Wär da ein IO Copy am anfang des Zyklus nicht schöner?

  6. #26
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    12.312
    Danke
    996
    Erhielt 3.640 Danke für 2.934 Beiträge

    Standard

    Zitat Zitat von vollmi Beitrag anzeigen
    Wär da ein IO Copy am anfang des Zyklus nicht schöner?
    Meinst Du von PAE zu DB? Dann bräuchtest Du größere Eingriffe ins Programm.
    Ich finde das zentrale Schreiben ins PAE schöner und einfacher und leichter findbar.

    Das darf allerdings nicht soweit führen, daß z.B. generell Öffnerkontakte und Lichtschranken auf diese faule Weise umgedreht werden, weil dann das Beobachten des Ex.y im Programm und in einer Variablenbeobachtungstabelle zu unterschiedlichen Werten führt, wenn der Beobachtungstrigger auf Zyklusanfang steht...

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  7. #27
    Registriert seit
    14.01.2015
    Beiträge
    2.530
    Danke
    605
    Erhielt 471 Danke für 391 Beiträge

    Standard

    Guten Morgen,

    nur der Interesse halber. Wurde die Ursache zwischenzeitlich gefunden?
    Mit Grüßen

  8. #28
    Registriert seit
    17.06.2004
    Ort
    Offenau
    Beiträge
    3.824
    Danke
    209
    Erhielt 430 Danke für 342 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Nicht das ich wüste! Mein Kollege hatte das Problem! Der ist aber z.Z auf Baustelle
    ---------------------------------------------
    Jochen Kühner
    https://github.com/jogibear9988/DotN...ToolBoxLibrary - Bibliothek zur Kommunikation mit PLCs und zum öffnen von Step 5/7 Projekten

Ähnliche Themen

  1. Antworten: 27
    Letzter Beitrag: 10.09.2015, 21:51
  2. Step 7 feste "1" auf eingang legen
    Von stephanoff im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 03.09.2015, 18:37
  3. Antworten: 6
    Letzter Beitrag: 16.03.2012, 18:20
  4. Antworten: 2
    Letzter Beitrag: 14.12.2007, 15:09
  5. Antworten: 4
    Letzter Beitrag: 29.11.2006, 08:59

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •