Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Page 4 of 5 FirstFirst ... 2345 LastLast
Results 31 to 40 of 48

Thread: 2 Draht Druckmesstransmitter für Füllstand Zisterne TIA V15.0

  1. #31
    Join Date
    30.05.2014
    Posts
    46
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    hatte aber auch nicht funktioniert, bei den 3,14 im Netzwerk 3 meckert er direkt an der Zahl mit fehlendes Semikolon; in Netzwerk 2 passt der Datentyp nicht, da kann ich aber kein Bool auswählen; in Netzwerk 1 sagt er unzulässige Anweisung. Desweiteren meckert er die DB Parameter an, obwohl die da sind...

  2. #32
    Join Date
    24.01.2018
    Posts
    149
    Danke
    29
    Erhielt 33 Danke für 30 Beiträge

    Default

    Quote Originally Posted by RedCali View Post
    Zeilen in SCL werden mit Semikolon ";" abgeschlossen
    und Real / Float Werte werden mit Punkt "." getrennt, nicht mit Komma
    Welchen Datentyp hast du den für deine Temporäre Variable eingestellt?

    Was meldet denn der Compiler für Fehler in den Infos?
    hab noch nachträglich geändert
    Beste Grüße und happy coding
    RedCali

  3. #33
    Join Date
    30.05.2014
    Posts
    46
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Default

    mhmm was hab ich nun wieder angestellt....

    den Zwischensatz :

    "Danach: (Volumen Berechnen, r=1; h=4)
    In diesem Fall würde es sich anbieten, "Daten Bewässerung.Füllstand" als Real-Wert zu deklarieren und MIN=1 und MAX=5 zu wählen, dann erhältst du den Füllstand in Metern."

    versteh ich auch noch nicht ganz, wo soll ich da was reinschreiben. Zu den beiden Netzwerken bringt er mir folgende Warnmeldung... im WIN CC wird mir gar keine Werteänderung vom Scale Ausgang angezeigt...

    Warnung.JPGNetzwerk 1 und 2 im Wasser.JPGNetzwerk 1 und 2 ohne Wasser.JPGNetzwerk 2 und 3 im Wasser.JPGNetzwerk 2 und 3 ohne Wasser.JPG

  4. #34
    Join Date
    15.09.2011
    Location
    Österreich
    Posts
    518
    Danke
    43
    Erhielt 139 Danke für 100 Beiträge

    Default

    Ich lasse das einfach mal hier:

    Füllstand.zip

    (HMI ungetestet wegen Zeitmangel)

  5. Folgender Benutzer sagt Danke zu acid für den nützlichen Beitrag:

    ronnystritzke (17.05.2019)

  6. #35
    Join Date
    30.05.2014
    Posts
    46
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Default

    Guten Morgen Acid, vielen herzlichen Dank dafür. Sieht erstmal sehr gut aus. Werde mir dann die einzelnen DB und FB Parameter in mein Projekt ziehen und schauen ob es funktioniert. Bin auf Arbeit und meine CPU zu Hause
    Hoffe das es heute Abend klappt.

    Nochmal vielen herzlichen Dank, bin schon am verzweifeln.

    Eine Frage,wird der Sensor durch die Variable tmpPerValCorrected dann automatisch korrigiert oder wie kann ich dann dann mit der Wirklichkeit beeinflussen?

    Mfg Ronny

  7. #36
    Join Date
    15.09.2011
    Location
    Österreich
    Posts
    518
    Danke
    43
    Erhielt 139 Danke für 100 Beiträge

    Default

    Das einfachte ist, den Transmitter am Einbauort in der Luft zu lassen, dann siehst du den Peripheriewert, den er aktuell liefert (variiert je nach Einbauort etwas). Diesen Wert trägst du dann als Korrekturwert ein, somit ist dein Ergebnis annähernd richtig. Ein paar mm mehr oder weniger machen ja bei dieser Anwendung keinen Unterschied.

    Heißt, er liefert 123 als Wert, dann ist dein Korrekturwert -123

    Den Korrekturwert sollte man aber im HMI bedienen können, kann zB beim Sensortausch notwenig sein.

  8. #37
    Join Date
    30.05.2014
    Posts
    46
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Default

    und wo trage ich das dann ein? Dort wo im Netzwerk 3 die 3.14 stehen?


    mfg Ronny

  9. #38
    Join Date
    15.09.2011
    Location
    Österreich
    Posts
    518
    Danke
    43
    Erhielt 139 Danke für 100 Beiträge

    Default

    3,14 wäre Pi, die Kreiszahl zur Volumenberechnung...

    Der Korrekturwert heißt, wie man erahnen könnte, „Korrekturwert“ im DB (Netzwerk 1)

  10. #39
    Join Date
    30.05.2014
    Posts
    46
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Default

    Ja jetzt, der Korrekturwert war in der der rechten Box versteckt, den hatte ich nicht gehen. Ok danke, dann kann ich das ja direkt am Startwert im DB eintragen... Super danke, getestet wirds heut Abend, mal sehen was mich dabei wieder erwartet...

    mfg Ronny

  11. #40
    Join Date
    30.05.2014
    Posts
    46
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Herzlichen Dank an Acid, hat alles so geklappt wie zur Verfügung gestellt. Korrekturwert musste ich im Netzwerk 1, direkt in der rechten Tabelle eintragen. Habe es noch an meinen DB angepasst. HMI funktioniert auch. alles prima, bin sehr glücklich. Die nächsten Projekte warten... Morgen werde ich versuchen den Sensor in die Zisterne zu bauen, mindest erstmal anklemmen und oben fixieren....wird ja nach dem Regen voll sein mal sehen was die Werte dann machen ...

    Vielen Dank nochmal dafür! Super Hilfestellung!


    Mfg Ronny

Similar Threads

  1. Replies: 7
    Last Post: 16.04.2019, 11:10
  2. Sonstiges Notebook für Eplan und TIA V15
    By Basti92 in forum Simatic
    Replies: 12
    Last Post: 15.04.2019, 17:57
  3. TIA Ersatz für AG_SEND in TIA V15
    By Thommy07 in forum Simatic
    Replies: 11
    Last Post: 09.01.2019, 11:52
  4. TIA Oscat-Bibliothek für TIA V15?
    By AndiVo in forum Simatic
    Replies: 12
    Last Post: 05.11.2018, 15:09
  5. Replies: 13
    Last Post: 21.03.2018, 13:34

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •