Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Results 1 to 8 of 8

Thread: Tia Portal WinCC - Startwert bei HMI-Variable

  1. #1
    Join Date
    29.04.2019
    Posts
    12
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen.
    Ich hoffe, mir kann jemand bei meinem Problem helfen:

    Ich habe in meinem Projekt ein E/A-Feld angelegt und dazu einen unteren Grenzwert (4) und einen oberen Grenzwert (6). Zudem arbeitete ich mit einer Rezepturverwaltung. Ich habe dabei das Problem, dass jedes Mal wenn ich das Projekt starte, oder eine neue Rezeptur anlege, automatisch eine 0 in das Feld geschrieben wird und somit eine Fehlermeldung bzgl. der Grenzwertverletzung kommt. In der HMI-Variable habe ich unter „Eigenschaften“ - „Werte“ einen Startwert von 4 eingetragen, der aber scheinbar nicht eingetragen wird. Arbeite noch nicht lange mit dem Tia-Portal und wäre über Hilfe dankbar

    Panel ist ein KTP400


    Gruß
    Spencer

    Edit: Beim Starten der Steuerung/Panels, klappt es mit dem Startwert. Lediglich beim Anlegen einer neuen Rezeptur wird immer eine 0 reingeschrieben und erzeugt somit eine Fehlermeldung.
    Last edited by Spencer; 24.05.2019 at 09:05.
    Reply With Quote Reply With Quote Answered: Tia Portal WinCC - Startwert bei HMI-Variable  

  2. "Gerade gefunden:
    Ich habe es nicht probiert, aber vielleicht funktioniert es:
    Bei den Rezepturelementen können auch Minimum, Maximum und Standardwerte angegeben werden, diese sollten vor den Einstellungen der verknüpften Variablen wohl sogar Vorrang haben."


  3. #2
    Join Date
    16.11.2007
    Posts
    174
    Danke
    2
    Erhielt 21 Danke für 19 Beiträge

    Default

    Gab es nicht mal eine Funktion in der Rezepturverwaltung ein Rezept (in ein neues) zu kopieren?

  4. #3
    Spencer is offline Neuer Benutzer
    Themenstarter
    Join Date
    29.04.2019
    Posts
    12
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Default

    Hallo Ingmar,

    ja, das müsste funktionieren. Aber ich könnte mir vorstellen, dass es auch beim Anlegen eines neuen Rezeptes eine Lösung dafür geben muss .

    Gruß
    Spencer

  5. #4
    Join Date
    16.11.2007
    Posts
    174
    Danke
    2
    Erhielt 21 Danke für 19 Beiträge

    Default

    Gerade gefunden:
    Ich habe es nicht probiert, aber vielleicht funktioniert es:
    Bei den Rezepturelementen können auch Minimum, Maximum und Standardwerte angegeben werden, diese sollten vor den Einstellungen der verknüpften Variablen wohl sogar Vorrang haben.

  6. #5
    Join Date
    27.05.2013
    Location
    Sauerland
    Posts
    146
    Danke
    20
    Erhielt 21 Danke für 21 Beiträge

    Default

    Guten Morgen,

    ich bin gerade ein wenig verwirrt. So wie wir die Rezepturen verwenden kann man Rezepte entweder laden, speichern, oder ein Neues erstellen. Beim Laden sollte der im Rezept gespeicherte Wert aktiv werden. Beim speichern wird der aktuelle Wert im Rezept gespeichert. Beim neu Erstellen passiert erstmal gar nichts, da man ja nichts lädt, sondern lediglich einen neuen Speicherbereich (ein neues Rezept) anlegt. Dann ändert man die Werte die man anders haben will und speichert sie im Rezept. Mir ist da nicht ganz klar, an welcher Stelle bei dir da der Wert 0 reingeladen wird. Stehe ich da gerade so auf dem Schlauch?

    Gruß Christian
    Please stop killing Dragons to make Snapdragon Processors!

  7. #6
    Spencer is offline Neuer Benutzer
    Themenstarter
    Join Date
    29.04.2019
    Posts
    12
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Default

    Quote Originally Posted by Ingmar64 View Post
    Gerade gefunden:
    Ich habe es nicht probiert, aber vielleicht funktioniert es:
    Bei den Rezepturelementen können auch Minimum, Maximum und Standardwerte angegeben werden, diese sollten vor den Einstellungen der verknüpften Variablen wohl sogar Vorrang haben.
    Habe erst am Montag wieder das Programmiergerät zur Hand und werde es direkt mal ausprobieren und mich dann nochmal melden. Danke erstmal .

    Gruß
    Spencer

  8. #7
    Spencer is offline Neuer Benutzer
    Themenstarter
    Join Date
    29.04.2019
    Posts
    12
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Default

    Quote Originally Posted by Stoky View Post
    Guten Morgen,

    ich bin gerade ein wenig verwirrt. So wie wir die Rezepturen verwenden kann man Rezepte entweder laden, speichern, oder ein Neues erstellen. Beim Laden sollte der im Rezept gespeicherte Wert aktiv werden. Beim speichern wird der aktuelle Wert im Rezept gespeichert. Beim neu Erstellen passiert erstmal gar nichts, da man ja nichts lädt, sondern lediglich einen neuen Speicherbereich (ein neues Rezept) anlegt. Dann ändert man die Werte die man anders haben will und speichert sie im Rezept. Mir ist da nicht ganz klar, an welcher Stelle bei dir da der Wert 0 reingeladen wird. Stehe ich da gerade so auf dem Schlauch?

    Gruß Christian
    Hi Christian,

    Ich verwende für die Rezepturvariablen nicht das vorgegebene Rezepturfenster, sondern gebe alle Werte auf einer separaten Seite in E/A Feldern ein und lade diese auch nicht über den Ladebutton, sondern die Werte werden ständig mit dem DB synchronisiert. Lediglich der Speicherbutton speichert die Werte dann Rezepturabhängig ab. Habe ich bei einer anderen Anlage so gesehen und gefiel mir besser, als die Werte in dem Rezepturfenster einzugeben (Geschmackssache) .
    Die Hmi-Variable, die in dem E/A Feld eingegeben wird, hat eine Unter- und Obergrenze (4-6) und sobald ich in dem Rezepturfenster ein neues Rezept anlege, springt der Wert in dem E/A Feld auf 0 und unterschreitet somit die Untergrenze, was zu einer Fehlermeldung führt.
    Ich probiere am Montag mal das, was der Ingmar vorgeschlagen hat und gebe dann Rückmeldung.

    Gruß
    Spencer

  9. #8
    Spencer is offline Neuer Benutzer
    Themenstarter
    Join Date
    29.04.2019
    Posts
    12
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Quote Originally Posted by Ingmar64 View Post
    Gerade gefunden:
    Ich habe es nicht probiert, aber vielleicht funktioniert es:
    Bei den Rezepturelementen können auch Minimum, Maximum und Standardwerte angegeben werden, diese sollten vor den Einstellungen der verknüpften Variablen wohl sogar Vorrang haben.
    Hallo Ingmar,

    Ich hatte heute schon die Möglichkeit das mit den Eigenschaften der Rezepturelemente zu testen. Du hattest recht, damit funktioniert es. Danke nochmal .

    Gruß
    Spencer

Similar Threads

  1. Replies: 8
    Last Post: 10.10.2018, 10:39
  2. Replies: 2
    Last Post: 13.05.2016, 14:50
  3. Replies: 7
    Last Post: 29.04.2013, 11:37
  4. Replies: 4
    Last Post: 25.03.2013, 12:29
  5. Replies: 0
    Last Post: 07.07.2011, 10:14

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •