Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 9 von 9

Thema: S5 CPU 943B geht alle bar Monate auf Stop

  1. #1
    Registriert seit
    04.02.2006
    Beiträge
    15
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo an alle Meister der S5!

    Habe bei einer Anlage schon seit Jahren das Problem das die CPU alle bar Monate auf STOP geht. Jetzt hab ich es das erstemal geschaft den USTACK und den BSTACK auszulesen (Es hat sonst immer das schlaue Personal CPU selbst gestartet. In der Einheit stecken zwei IP 244 Baugruppen wo es vielleicht einen Adresskonflikt geben könnte.

    Im Anhang der USTACK und BSTACK, vielleicht kann mir jemand helfen wie ich dem Fehler auf die schliche kommen kann.


    Grüsse

    Joe

    BSTACK.jpg

    USTACK.jpg
    Vertrauen ist gut, Kontrolle ist besser.
    Zitieren Zitieren S5 CPU 943B geht alle bar Monate auf Stop  

  2. #2
    Registriert seit
    30.04.2005
    Beiträge
    919
    Danke
    58
    Erhielt 164 Danke für 150 Beiträge

    Standard

    Hi,

    laut Ustack liegt der Fehler bei einem Peripheriezugriff auf Adresse 77.
    Die Stopstelle ist im PB3 an Adresse 488h.

    Nachdem es Adresse 77 ist scheint es eher ne normale Digitalkarte zu sein. Ip's werden eigentlich ab 128 verwendet.

    Gruß Centi
    Krieg ist Gottes Art den Amerikanern Geographie beizubringen

  3. #3
    AWL-Joe ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    04.02.2006
    Beiträge
    15
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Im PB 3 steht aber nichts besonders?

    PB3.jpg
    Vertrauen ist gut, Kontrolle ist besser.
    Zitieren Zitieren S5 CPU 943B geht alle bar Monate auf Stop  

  4. #4
    Registriert seit
    05.10.2005
    Beiträge
    2.382
    Danke
    321
    Erhielt 298 Danke für 268 Beiträge

    Standard

    Hallo,
    da kann ich nur zustimmen, er findet die E/A an Adresse 77 nicht was liegt da?
    Was steckt sonst noch im Rack?
    Wir hatten schon den Fall, das die Kontakte der Rückwandbusverbinder nicht mehr so richtig wollten.
    Das der Fehler nur alle paar Monatte auftaucht ist natürlich bei der Fehlersuche nicht sehr hilfreich.
    Wenn möglich kann mann ja die Karten einmal ziehen und neu einstecken oder die 2 IP-Baugruppen untereinander tauschen ob der fehler mitwandert.
    Und dann heist es warten......

    Thomas

  5. #5
    Registriert seit
    30.04.2005
    Beiträge
    919
    Danke
    58
    Erhielt 164 Danke für 150 Beiträge

    Standard

    Schau halt mal in Adresse 488h nach.
    Das funktioniert aber nur in AWL richtig.
    Einfach Baustein online öffnen und als Suchbegriff 488h eingeben.
    Eine Zeile davor ist deine Stopstelle.
    Hier sollte ein Zugriff auf EB77 oder AB77 stattfinden.
    Es kann auch eine EG Anschaltung sein, die zu solchen Problemen führt.


    Gruß Centi
    Krieg ist Gottes Art den Amerikanern Geographie beizubringen

  6. #6
    Registriert seit
    18.09.2006
    Beiträge
    231
    Danke
    0
    Erhielt 2 Danke für 2 Beiträge

    Standard

    der fehler sollte durch den befehl TNB (BEF-REG: 030E) ausgelöst werden.
    .
    mfg KALEL

    Wer über gewisse Dinge nicht den Verstand verliert, der hat keinen zu verlieren.
    Gottfried Ephraim Lessing

  7. #7
    AWL-Joe ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    04.02.2006
    Beiträge
    15
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Wieviele Bytes belegt eine IP244?

    Eine IP244 wird nämlich mit Baugruppenadresse 64 Parametriert.

    Also im PB 3 gibts es keine Adresse 488h, PB 3 hat nur das gepostete Netzwerk.
    Digitale Bereiche liegen sonst nur bei E/A 0 - 61

    Am Zentral RACK sind noch zweit ER Racks angeschlossen, desweiteren steckt eine CP 524, drei Analoge 460-7 und eine ???Diagnose-Baugruppe AS 304???
    Vertrauen ist gut, Kontrolle ist besser.

  8. #8
    Registriert seit
    30.04.2005
    Beiträge
    919
    Danke
    58
    Erhielt 164 Danke für 150 Beiträge

    Standard

    Die IP244 belegt 32 Byte im Adressraum des AG's

    Also liegt deine Vermutung mit der IP schon richtig.

    Gruß Centi
    Krieg ist Gottes Art den Amerikanern Geographie beizubringen

  9. #9
    AWL-Joe ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    04.02.2006
    Beiträge
    15
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    So ein Wunder ist eingetroffen Fehler ist innerhalb von 4 Stunden wieder aufgetreten USTACK und BSTACK wieder gleich wie vorher.
    Habe mal im MAGAZIN gekrammt, ist sogar noch eine IP auf Lager werde die mal bei Gelegenheit wechseln und wieder Monate warten.
    Vertrauen ist gut, Kontrolle ist besser.

Ähnliche Themen

  1. SPS geht in Stop
    Von Fidibus im Forum Simatic
    Antworten: 9
    Letzter Beitrag: 25.08.2011, 18:22
  2. CPU geht in Stop
    Von JoJo17 im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 26.05.2008, 11:06
  3. 315 2DP geht in Stop
    Von Christian Schröder im Forum Simatic
    Antworten: 12
    Letzter Beitrag: 01.08.2006, 01:53
  4. S5 geht des öfteren in Stop
    Von Andreas.W im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 13.01.2006, 11:59
  5. CPU315-2 DP geht in STOP
    Von Schmiegel im Forum Simatic
    Antworten: 19
    Letzter Beitrag: 04.08.2005, 14:35

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •