Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: SafetyCPU geht in Stopp

  1. #11
    Join Date
    22.06.2009
    Location
    Sassnitz
    Posts
    14,786
    Danke
    1,217
    Erhielt 4,364 Danke für 3,517 Beiträge

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Noch mehr Tippfehler und Designfehler?

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  2. #12
    Join Date
    12.07.2010
    Location
    in NRW
    Posts
    7
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Default

    Hallo


    Benutzt du Taktmerker im Safety-Programm?
    Wenn ja raus damit.

  3. #13
    Neurorancer is offline Erfahrener Benutzer
    Themenstarter
    Join Date
    07.05.2016
    Posts
    364
    Danke
    67
    Erhielt 1 Danke für 1 Beitrag

    Default

    Ich glaube der Wurm ist irgendwo in dem Aufruf der Programme!

    Mein Hautp-Sicherheits-Programm ist unten im Anhang.
    Dieses Programm wird NICHT im OB1 aufgerufen,
    sondern in der F-Ablaufgruppe 1 [RTG1]
    SafetyCPUStopp10.jpg

    Ist das richtig so?

    Hier ist nochmal die übersicht aller F-Bausteine
    SafetyCPUStopp11.png

    Ich nutze die Safety-CPU nur für die Sicherheit.
    Der eigentliche Programmablauf ist in der Simotion.

    Vielleicht sieht Jemand den Fehler. Das Programm ist eigentlich recht einfach.
    Attached Files Attached Files

  4. #14
    Neurorancer is offline Erfahrener Benutzer
    Themenstarter
    Join Date
    07.05.2016
    Posts
    364
    Danke
    67
    Erhielt 1 Danke für 1 Beitrag

    Default

    Eine Sache ist da noch: Der Motor-Modul: F-RS 0,3 - 1A HF 3DI/LC_1

    SafetyCPUStopp12.jpg

    Dieser hat auch Ein- und Ausgänge auf die ich über I-Device zugreife.
    Ich schreibe auf alle seine Eingänge mit I-Device.
    Ich schaue gleich ob eventuell einer dieser Eingänge des Motor-Moduls eventuell
    ein Sicherheits-Eingang ist.

    Das Problem mit dem CPU-Stopp kommt bis jetzt nur nach Not-Aus Situation.
    Im Normalen Betrieb lässt sich die Hardware einwandfrei bedienen.

  5. #15
    Neurorancer is offline Erfahrener Benutzer
    Themenstarter
    Join Date
    07.05.2016
    Posts
    364
    Danke
    67
    Erhielt 1 Danke für 1 Beitrag

    Default

    An dem Motor-Modul kann es nicht liegen. Seine Ein- und Ausgänge im Prozessabbild sind nicht sicherheitsrelevant.

  6. #16
    Join Date
    17.03.2010
    Location
    Bonn
    Posts
    416
    Danke
    4
    Erhielt 99 Danke für 91 Beiträge

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Dein Problem tritt nur bei Nothalt Situation auf .
    du befummelst irgendwo außerhalb von F-Teil den Q200.0 oder Q200.1 so steht es jeden´falls in der Fehlermeldung die zum Stop führt .
    also wenn man sich das anschauen soll stell das ganze Projekt ein

Similar Threads

  1. Step 5 Beim ändern der Zeit geht die CPU in Stopp
    By DiGo1969 in forum Simatic
    Replies: 15
    Last Post: 26.06.2015, 10:44
  2. TIA SPS geht von run auf Stopp bei Not-Aus
    By Georg_1991 in forum Simatic
    Replies: 4
    Last Post: 10.05.2014, 10:57
  3. Replies: 1
    Last Post: 08.06.2011, 13:01
  4. Replies: 11
    Last Post: 10.02.2011, 15:57
  5. CP343-1 IT und CP443-1 IT geht in Stopp
    By Marc_3 in forum Simatic
    Replies: 1
    Last Post: 13.01.2005, 11:12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •