Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Results 1 to 3 of 3

Thread: Beckhoff EL6002 zweiter Kanal

  1. #1
    Join Date
    19.06.2020
    Posts
    2
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Moin moin,

    ich bin neu hier und habe sofort mal eine Frage an euch.
    Ich möchte über ein Beckhoff inkl. EK1100 und EL6002 diverse RS232 Geräte ansteuern. Mit einem Channel aktiv klappt das schon recht gut. Nun benötige ich aber mehr als 2 Kanäle.
    Mein Programm baut auf dem Beispiel 1 in von Beckhoff auf. Ich habe nur alles was mit de KL-Klemme und dem PC-Com Port zu tun hatte raus geschmissen. Wie gesagt läuft ein Kanal ohne Probleme.
    Ich habe also testweise alles was mit dem Kanal 1 zu tun hat kopiert und von EL6001 auf EL6002 umbenannt. Damit ich nicht den Überblick verliere habe ich auch die Globalen Variablen (TxBufferEL und RxBufferEL in TxBufferEL6001 und RxBufferEl6001 usw...) umbenennen wollen. Ab dann beschwert sich aber mein Main Programm und die Kommunikation des ersten Kanals funktioniert auch nicht mehr:
    "Internal error while object 'MAIN' is providing language model Information: Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt".
    Damit ich den zweiten Kanal nutzen kann wollte ich einfach neue Buffer für den zweiten Kanal anlegen. Alles weiter umbenennen und dann testen ob der zweite Kanal parallel auch funktioniert.
    -Anhang-
    Kann es sein dass ich irgendwo noch eine Referenz vergessen habe zu ändern/hinzuzufügen? Langsam komme ich ans Ende von meinem Latein. Ich bin auch weit weg davon ein Profi zu sein aber die Grundlagen kenne ich eigentlich schon … zumindest denke ich das.


    Beste Grüße
    Last edited by Benweis; 29.06.2020 at 07:51.
    Reply With Quote Reply With Quote Beckhoff EL6002 zweiter Kanal  

  2. #2
    Join Date
    11.09.2012
    Location
    obostenoderwestendaheimistesambesten
    Posts
    276
    Danke
    1
    Erhielt 46 Danke für 40 Beiträge

    Default

    2 dinge hab ich gesehen :

    1) Du hast wohl den Baustein Background umbenannt in Backgroundcommunication, aber imTaskaufruf dann eben nicht.

    2) Bei den globalen Variablen ist Dir vor das VAR_Global ein "R" reingerutscht da steht dann RVAR_Global, somit sind diese Variablen nicht bekannt.

    ... dannach laesst es zumindest fehlerfrei uebersetzen.

    Gruss, Wollvieh.
    Nüchtern betrachtet war es besoffen besser.

  3. #3
    Benweis is offline Neuer Benutzer
    Themenstarter
    Join Date
    19.06.2020
    Posts
    2
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Default


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Sorry für die späte Antwort,

    Vielen Dank. Es lag wohl an dem Taskaufruf. Die Sache mit der "RVAR" ist mir nur vor dem hochladen reingerutscht..... jetzt funktioniert es.

Similar Threads

  1. Beckhoff CX9020 El6002 RS232
    By TadejR in forum Sonstige Steuerungen
    Replies: 0
    Last Post: 06.09.2016, 14:00
  2. Beckhoff EL6002 - Prbleme beim Senden/Empfangen von Strings
    By Schnapsbrenner in forum CODESYS und IEC61131
    Replies: 20
    Last Post: 02.05.2016, 18:40
  3. Redundanter Abschaltpfad: 2ter Kanal wird nur im Fehlerfall von Kanal 1 ausgeführt
    By andrejtm in forum Maschinensicherheit - Normen und Richtlinien
    Replies: 5
    Last Post: 19.01.2016, 07:56
  4. Replies: 0
    Last Post: 02.09.2012, 21:32
  5. Replies: 0
    Last Post: 30.06.2012, 09:28

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •